Announcement

Collapse
No announcement yet.

Importing phpBB

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Importing phpBB

    I'm trying to import my database from phpbb (2.0.6) to my newly installed vBulletin using Impex. phpbb is currently running on a different server then VBulletin is running on. I tried setting up the Impex config file but when I called my provider Ipower about what I was doing and to get the proper "sourceserver" name they said what I was trying to do can't be done because of the way they set up their servers and access issues to the database? Ok so now what?

    I tried doing a backup thru cPanel 5 and doing a restore using vDeck even though it says it was sucessful nothing changed, no tables were changed or added.

    I can export the datbase in several fomats SQL, LaTeX, CSV for MS Excel, CSV data or XML.

    Any suggestions how to move this database to VBulletin?

    Thanks,

    Dave

  • #2
    You'll need to export the database from one server and restore it on the new one.

    Export with phpMyAdmin, cpanel, to SQL or even ssh if you have it :

    http://www.vbulletin.com/docs/html/m...nce_ssh_backup

    Then ensure you have a SQL file that you can move to the new server and restore :

    http://www.vbulletin.com/docs/html/m...tabase_restore
    I wrote ImpEx.

    Blog | Me

    Comment


    • #3
      Ok, new problem. I can't use phyMyAdmin because it times out because of file size and I can use SSH/Telnet because of my provider.

      So is there a manual way? One thing I tried was to down load several tables at a time from the old database saving them as SQL and then importing them using phyMyAdmin which seemed to work as the tables did apprear but looking at the forum it still appeared as the default new forum not seeing any of the new tables I uploaded. Do I need to remove all the original tables first?

      Thanks,

      Dave

      Comment


      • #4
        Originally posted by dbright
        .......which seemed to work as the tables did apprear but looking at the forum it still appeared as the default new forum not seeing any of the new tables I uploaded. Do I need to remove all the original tables first?...
        I don't really know what you mean there, uploading the tables won't make anything appear it just means that you have access to the database so you can now do the import.

        If you have all the phpBB tables and the vBulletin tables in the same database, then you can use impex to import the data into vBulletin.

        In your ImpExConfig set the source and target as the same, just with the diffrent table prefixes.

        If the tables arn't in the same database, could you explain a little more as to what you did ?
        I wrote ImpEx.

        Blog | Me

        Comment


        • #5
          Originally posted by dbright
          Sorry I'll try to explain it better. As mention I have my old DB (phpBB) that I'm trying to import into the new vBulletin DB.

          I tried "Backing Up The Database via phpMyAdmin" directions. The problem is if I select all the tables and save them to my desktop and then try the procedure "Restoring The Database via phpMyAdmin" it times out due to size. So instead I tried to backup only one table named phpBB_forum and import it into the new DB and it appears to work. I see the table but I also have the default table zr1netre_forum when I installed vBulletin. So what I tried to do was delete zr1netre_forum and rename phpBB_forum to zr1netre_forum but when I tried to bring up the forum window I get the error message:

          Database error in vBulletin 3.0.7:
          Invalid SQL:
          SELECT forum.forumid, lastpost, lastposter, lastthread, lastthreadid, lasticonid, threadcount, replycount
          FROM zr1netre_forum AS forum

          mysql error: Unknown column 'forum.forumid' in 'field list'
          mysql error number: 1054
          Date: Thursday 28th of July 2005 05:53:43 PM
          Script: http://www.zr1netregistry.com/forum/index.php?
          Referer: http://www.zr1netregistry.com/forum/...ex.php?do=head
          Username: zr1mom
          IP Address: 24.61.91.49
          That makes sense, yes, though what you are trying to do is wrong.

          You have broken your vBulletin database by deleting the forum table.

          You have to use impex to import the data from the source database tables into vBulletin's tables.

          When you have move all the tables over, looks like you have done the forum table, just have to grab the rest now.

          Then you use impex to import the data from the phpBB tables via impex into the vBulletin database.
          I wrote ImpEx.

          Blog | Me

          Comment


          • #6
            Thanks! I got it now and it is almost working. In the admin control panel I can see all the data, users, titles, smileys, all the forums, etc....

            However when I click on "Forum Home Page" it gives me the default home page. It looks as though it is looking at the wrong index page or didn't build a new one?

            Thanks!

            Dave

            Comment


            • #7
              Check out the HOWTO (the end game):

              http://www.vbulletin.com/forum/showthread.php?t=116398

              I'm guessing you need to delete the Default Forum and sort out the display order, then rebuild the theads then the forum details.
              I wrote ImpEx.

              Blog | Me

              Comment


              • #8
                That did it!!

                Thanks for all your help!!!!

                Dave

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X