Announcement

Collapse
No announcement yet.

IPB Import Issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • IPB Import Issue

    Hi

    I am trying to import my source board "IPB 2.0.3" to "vBulletin 3.0.7". I have edit the impex config file according to the the tutorial and it is connecting to my source database. But when I go to the option(s)

    Check and update database 000 sec(s)002
    Associate Users 000 sec(s)003
    Import Usergroup 000 sec(s)004
    Import User 000 sec(s)005
    Import Forum 000 sec(s)006
    Import Thread 000 sec(s)007
    Import Post 000 sec(s)008
    Import Poll 000 sec(s)009
    Import Private Messages 000 sec(s)010
    Import Moderators 000 sec(s)011
    Import Attachment 000 sec(s)012
    Import Smilie


    I get the following errors

    Database error in vBulletin:ImpEx Source 3.0.7:

    Invalid SQL:
    SELECT id, name
    FROM members
    ORDER BY id
    LIMIT 0,25
    mysql error: Table 'hlagrou_forums.members' doesn't exist

    mysql error number: 1146

    Date: Wednesday 27th of July 2005 12:50:27 AM
    Script: http://www.xxxxxx.net/forums/impex/index.php
    Referer: http://www.xxxxxx.net/forums/impex/index.php
    Username: ecko!
    IP Address: 151.213.113.215
    This goes for each option I select

    But as for the "check for updates" it works fine.

    Any ideas?

    Thanks

  • #2
    Check the IPB database. Does the 'members' table exist? Are you using table prefixes?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      I am currenlty looking at my "source" database and heres the following tables

      hlagrou_forums
      ibf_admin_logs
      ibf_admin_sessions
      ibf_announcements
      ibf_attachments
      ibf_attachments_type
      ibf_badwords
      ibf_banfilters
      ibf_bulk_mail
      ibf_cache_store
      ibf_calendar_events
      ibf_cd_pages
      ibf_cd_pages_settings
      ibf_conf_settings
      ibf_conf_settings_titles
      ibf_contacts
      ibf_custom_bbcode
      ibf_email_logs
      ibf_emoticons
      ibf_faq
      ibf_forum_perms
      ibf_forum_tracker
      ibf_forums
      ibf_groups
      ibf_languages
      ibf_mail_error_logs
      ibf_mail_queue
      ibf_member_extra
      ibf_members
      ibf_members_converge
      ibf_message_text
      ibf_message_topics
      ibf_moderator_logs
      ibf_moderators
      ibf_pfields_content
      ibf_pfields_data
      ibf_polls
      ibf_posts
      ibf_reg_antispam
      ibf_search_results
      ibf_sessions
      ibf_skin_macro
      ibf_skin_sets
      ibf_skin_templates
      ibf_skin_templates_cache
      ibf_spider_logs
      ibf_subscription_currency
      ibf_subscription_extra
      ibf_subscription_logs
      ibf_subscription_methods
      ibf_subscription_trans
      ibf_subscriptions
      ibf_task_logs
      ibf_task_manager
      ibf_titles
      ibf_topic_mmod
      ibf_topics
      ibf_topics_read
      ibf_tracker
      ibf_upgrade_history
      ibf_validating
      ibf_voters
      ibf_warn_logs

      Comment


      • #4
        You need to set the source table prefix setting to:

        ipb_
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          heres what I have for the source in the config.php

          Just edit!

          ; mysql OR mssql
          sourcedatabasetype = mysql
          sourceserver = localhost
          sourceuser = "hlagrou_xxxx"
          sourcepassword = "xxxx"
          sourcedatabase = hlagrou_xxxx
          sourcetableprefix = ipb_

          It still has the error with the above

          Comment


          • #6
            I got it working. The suffix was "ibf_". I have updated the counter and everything was a success!

            Thank You!

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X