Announcement

Collapse
No announcement yet.

SMF import - bug report

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Are you sure this is the location of your SMF attachments directory and not a subdirectory of your vB forums:

    /home/******/public_html/forums/attachments

    Can you post a screenshot of your settings?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #17
      Positive. vB is under "testvb".

      Sorry, which settings would you need a SS of?

      Edit:
      Is it possibly not working due to the "testvb" folder being password protected??
      Last edited by xbleed; Thu 14th Jul '05, 8:15pm.

      Comment


      • #18
        That's possible. Try temporarily removing the password protection to see if that works.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #19
          Tried, no luck. I did notice that some of the "error messages" are different on the last page though. I managed to copy a few of them before the refresh occured.

          From : 5000 :: To : 5195

          Source file not found :: attachment -> rabbit.jpg
          Source file not found :: attachment -> vend-3.gif
          Found attachment and DID NOT imported to the mysql database possiably the origional post is missing
          Source file not found :: attachment -> new0017.jpg
          Source file not found :: attachment -> El Tigre.jpg
          Found attachment and DID NOT imported to the mysql database possiably the origional post is missing
          Source file not found :: attachment -> blue_screen2.jpg
          Source file not found :: attachment -> charlesandcamilla.jpg
          Source file not found :: attachment -> cs46-0204.jpg
          Source file not found :: attachment -> ParnKing.jpg
          Source file not found :: attachment -> lotrtoys_aragorn.jpg
          Source file not found :: attachment -> term3a.jpg
          Source file not found :: attachment -> [email protected]
          Source file not found :: attachment -> dorks24.jpg
          Source file not found :: attachment -> Simmons.jpg
          Source file not found :: attachment -> Sharkey.jpg
          Source file not found :: attachment -> RF2Pop6.jpg
          Source file not found :: attachment -> NewsTeam.jpg
          Source file not found :: attachment -> nase.jpg
          Source file not found :: attachment -> Linuxcletus4.jpg
          Source file not found :: attachment -> john.jpg
          Source file not found :: attachment -> high5.jpg
          Source file not found :: attachment -> nosurv.jpg
          Source file not found :: attachment -> 041797specialk3ij.jpg
          Source file not found :: attachment -> GeneralFai.gif
          Source file not found :: attachment -> Vogon-Poet1.jpg
          Found attachment and DID NOT imported to the mysql database possiably the origional post is missing
          Found attachment and DID NOT imported to the mysql database possiably the origional post is missing
          Source file not found :: attachment -> michael jackson.jpg
          Source file not found :: attachment -> Mongoose vs Cobra.JPG
          Source file not found :: attachment -> jesus brb.JPG
          Just incase that helps at all.

          Comment


          • #20
            Hmmm...'source file not found' should mean exactly that. Did you veriffy these files do exist in that direcotry and that are world-readable (usually 644)?

            As for 'Found attachment and DID NOT imported' did you import the posts first? This means that the fattachment files were found, but there was no post containing these attachments.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #21
              Wow. Weird.

              Well, first of all: They are CHMOD correctly and the folder is CHMOD 777. So reading/writing shouldn't be an issue. However, I paid closer attention to the filenames in the attachments folder and they are all named like this:

              "1330_bub2_gif5b6175664381d2af68e0548512573168"

              So that's definately not what Impex is reading (impex is reading just "bub2.gif"). Now if I weren't lost before, I'm even more lost now.. hah.

              Comment


              • #22
                Jerry will have to confirm this but it may be that Impex is taking the file name from the post or the db, and this name isn't matching what's in that directory. I think we'll need to wait for Jerry on this.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #23
                  Okay, I'll await his response. I apologize for not mentioning this before hand, I just remembered it myself to be honest.

                  This was once an installation of Invision Power Board that I transferred to SMF. Now I'm more than positive I want vB for all my websites, so I'm hoping to be able to get this to work.

                  Perhaps that's why the attachments were named differently, since it is already an imported forum? We'll see what Jerry says.

                  Thanks Steve,

                  Comment


                  • #24
                    Originally posted by xbleed
                    Found attachment and DID NOT imported to the mysql database possiably the origional post is missing
                    Source file not found :: attachment -> michael jackson.jpg
                    Source file not found :: attachment -> Mongoose vs Cobra.JPG
                    Source file not found :: attachment -> jesus brb.JPG
                    Are these attachments to posts, or are they avatars stored in the attachments directory? SMF stores avatars in the attachments directory by default. They weren't moved over at all with the first version of ImpEx I tried. The second version moved over only the avatars that were specified as links (stored on other servers). I didn't try Jerry's later revision because I decided to stick with SMF and not use vBulletin. But I'm sharing my import results, in case it's helpful to someone...

                    (By the way, I received no email notification of replies in the forum since I posted my original message three days ago until today, when I received 18 notifications at once. There was a similar email delay when I first bought vBulletin. I've been receiving all other mail normally.)

                    I didn't have any polls in my forum and so I couldn't say whether this works - zero polls is correct in my case.

                    I thought the attachments in my attachments directory were not being moved over because they were avatars and not associated with posts in the database. ImpEx clearly saw my attachments (as it clearly saw yours), but then reported they weren't there - which is kind of confusing. Your Web host can tell you the path to the directory, but you must have it right or you wouldn't be seeing the filenames. Here is my log, for what it's worth:

                    Code:
                     
                    012 Import Attachments 
                    Import / Export
                    Database cleanup & restart ||| Online manual
                    Using includes/config.php for target config.
                     
                    Importing 47 attachments
                    From : 0 :: To : 47
                     
                    Source file not found :: attachment -> avatar_4.png
                    Source file not found :: attachment -> avatar_10.png
                    Source file not found :: attachment -> avatar_11.png
                    Source file not found :: attachment -> avatar_1.jpg
                    Source file not found :: attachment -> avatar_16.png
                    Source file not found :: attachment -> avatar_19.png
                    Source file not found :: attachment -> avatar_20.png
                    Source file not found :: attachment -> avatar_22.png
                    Source file not found :: attachment -> avatar_26.png
                    Source file not found :: attachment -> avatar_12.png
                    Source file not found :: attachment -> avatar_7.jpg
                    Source file not found :: attachment -> avatar_36.png
                    Source file not found :: attachment -> avatar_38.png
                    Source file not found :: attachment -> avatar_41.png
                    Source file not found :: attachment -> avatar_52.png
                    Source file not found :: attachment -> avatar_57.png
                    Source file not found :: attachment -> avatar_76.png
                    Source file not found :: attachment -> avatar_3.png
                    Source file not found :: attachment -> avatar_66.png
                    Source file not found :: attachment -> avatar_106.png
                    Source file not found :: attachment -> avatar_83.png
                    Source file not found :: attachment -> avatar_98.png
                    Source file not found :: attachment -> avatar_97.png
                    Source file not found :: attachment -> avatar_112.gif
                    Source file not found :: attachment -> avatar_101.png
                    Source file not found :: attachment -> avatar_132.png
                    Source file not found :: attachment -> avatar_130.png
                    Source file not found :: attachment -> avatar_131.png
                    Source file not found :: attachment -> avatar_58.png
                    Source file not found :: attachment -> avatar_32.png
                    Source file not found :: attachment -> avatar_154.png
                    Source file not found :: attachment -> avatar_91.png
                    Source file not found :: attachment -> avatar_134.png
                    Source file not found :: attachment -> avatar_169.png
                    Source file not found :: attachment -> avatar_166.png
                    Source file not found :: attachment -> avatar_113.png
                    Source file not found :: attachment -> avatar_69.png
                    Source file not found :: attachment -> avatar_195.png
                    Source file not found :: attachment -> avatar_138.png
                    Source file not found :: attachment -> avatar_204.png
                    Source file not found :: attachment -> avatar_208.png
                    Source file not found :: attachment -> avatar_213.jpg
                    Source file not found :: attachment -> avatar_206.png
                    Source file not found :: attachment -> avatar_193.png
                    Source file not found :: attachment -> avatar_221.png
                    Source file not found :: attachment -> avatar_223.png
                    Source file not found :: attachment -> avatar_70.png
                     
                    vBulletin v3.0.7, Copyright ©2000-2005, Jelsoft Enterprises Ltd.

                    Comment


                    • #25
                      I have both attachments, and avatars in my attachments folder. My avatars are very minimal though.

                      Comment


                      • #26
                        Originally posted by Jerry
                        Nope, its not going to resize the images, its going to scale them on the front end with HTML. The only way around this is to get the users to upload a correctly sized version of the image, impex is not going to do image scaling on the fly.
                        You can call getimagesize() on the images and insert the height/width into customavatar.height and customavatar.width. Same with profile pictures, if the software has them. You should be doing this with all imported avatars. If getimagesize() fails, then just insert 0x0 for the widthxheight.

                        Comment


                        • #27
                          Originally posted by Freddie Bingham
                          You can call getimagesize() on the images and insert the height/width into customavatar.height and customavatar.width. Same with profile pictures, if the software has them. You should be doing this with all imported avatars. If getimagesize() fails, then just insert 0x0 for the widthxheight.
                          Yup can do though, that won't change the actual size of the image in 3.0.7, i.e. if they are 400x400px thats how they will be display.

                          I'll do it for 3.5 as that can handel it.

                          Though the getimagesize() and filesize() i've done now.
                          I wrote ImpEx.

                          Blog | Me

                          Comment


                          • #28
                            Originally posted by Jerry
                            Yup can do though, that won't change the actual size of the image in 3.0.7, i.e. if they are 400x400px thats how they will be display.

                            I'll do it for 3.5 as that can handel it.

                            Though the getimagesize() and filesize() i've done now.
                            Yes, of course, it only applies to 3.5

                            Comment


                            • #29
                              Originally posted by Jerry
                              Yup can do though, that won't change the actual size of the image in 3.0.7, i.e. if they are 400x400px thats how they will be display.

                              I'll do it for 3.5 as that can handel it.

                              Though the getimagesize() and filesize() i've done now.
                              Jerry, would you happen to need a database backup to look at for the attachment problem?

                              Comment


                              • #30
                                Originally posted by xbleed
                                Jerry, would you happen to need a database backup to look at for the attachment problem?
                                I would need a full mysqldump, not a partly hacked example and the whole attachment dir so I can set up the equivalent example on a dev server to do the import, then I can debug and update the importer.
                                I wrote ImpEx.

                                Blog | Me

                                Comment

                                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                                Working...
                                X