Announcement

Collapse
No announcement yet.

New BB, new import UBB 6.7

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • New BB, new import UBB 6.7

    Hi!

    I installed 3.0.7 and am importing users into my DB. When I do this, I get an error:

    Warning: mktime() [function.mktime]: Windows does not support negative values for this function in \impex\ImpExFunction.php on line 164

    Any idea what I might be doing wrong?

  • #2
    Bump?

    Comment


    • #3
      <Moved to Import forum>

      It would appear that some of the data you are trying to import has negative time values, which is a problem with the data itself. I moved this to the Import forum so Jerry can help you with this.
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #4
        Jerry? Are you there????



        This is the error message I am getting for probably 10% of my users:
        Warning: mktime() [function.mktime]: Windows does not support negative values for this function in \impex\ImpExFunction.php on line 164

        This is a brand new install, these are the steps I am following:
        drop existing database
        delete vbb files
        reupload vbb files
        edit config file
        run install script (no errors)
        upload impex
        edit impex file
        run impex steps 1 and 3 (3 is where I get the errors)

        I am importing a UBB 6.7 system. I am running IIS on 2003 with PHP 5 and MYSQL. I will check the actual versions if you need me to.

        Thanks in advance for the help.

        -Josh

        Comment


        • #5
          I just noticed something else....

          I am getting this error when I import the forums:
          Parse error: syntax error, unexpected ',' in C:\Inetpub\mr\forum\impex\systems\ubb_classic\005.php(233) : eval()'d code on line 7

          One other thing I should mention. I have done this about 3 times now (ignoring the errors on the user imports). This is good practice for when I actually move my board, but there is a big problem.

          After I complete all import steps, I begin to install the chat mod. The chat mod does not overwrite any of the preexisting files. After I installed the chat mod the last time, I began to get the "No input file specified" error message. I do not think this is related to the chat mod, so I am guessing that after some time, the entire system dies and I get that message when I open any file (main index, admincp, etc). I am going to go back and do a reinstall tonight to try and find out what step is causing this problem. Essentially, whatever is happening is killing the whole board and I have to drop the database and start over. This is very frustrating. Tonight I will do the install without uploading the chat mod to confirm that it is not the cause.

          I would like to figure out the first two error messages I receive in order to eliminate them as potential causes of this problem.

          Thanks,
          Josh

          Comment


          • #6
            The eval()'d code error is going to be ImpEx trying to turn a perl array into php, this should effect the import, it just means that you'll be missing some info for the forums, though they should all be there.

            The mktime, isn't fatal either, where that warning is, it just means that it can't figure out if a users is COPPA or not.

            You say you are getting errors on module 003 though the error you are posting is from 005 ?

            I'm a bit confused.
            I wrote ImpEx.

            Blog | Me

            Comment


            • #7
              Sorry, the mktime error is from #3, the last error I posted is from 5. I am also getting an error on the import posts but can't catch it before the refresh and don't know where it is actually logged.

              So I can just ignore these first two messages?

              Thanks.

              Comment


              • #8
                Originally posted by trana
                Sorry, the mktime error is from #3, the last error I posted is from 5. I am also getting an error on the import posts but can't catch it before the refresh and don't know where it is actually logged.

                So I can just ignore these first two messages?

                Thanks.
                Ubb.classic imports are always a bit rough, though I would ignore the warnings and run the whole import then see what the end result is like.

                The eval() warning is common, as is the mktime() on windows (though that is a bug that needs posting).

                Do the whole import, read the how to on how to clean up and then see what is missing/wrong etc.
                I wrote ImpEx.

                Blog | Me

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X