Announcement

Collapse
No announcement yet.

ImpexConfig.php help needed

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Jerry
    replied
    Originally posted by Shredder1
    I must be doing something wrong..
    Is the datbase actualy restored ?

    Leave a comment:


  • Shredder1
    replied
    this is what it's setup to use now..

    targetdatabasetype = mysql
    targetserver = localhost
    targetuser = "theshredder"
    targetpassword = "vbtest"
    targetdatabase = vb
    targettableprefix =
    [ Source Database ]

    ; If the system that is being imported from uses a database,
    ; enter the details for it here and set 'sourceexists' to TRUE.
    ; If the source data is NOT stored in a database, set 'sourceexists' to FALSE
    sourceexists = true
    ; mysql OR mssql

    sourcedatabasetype = mysql
    sourceserver = localhost
    sourceuser = "theshredder1"
    sourcepassword = "vbtest"
    sourcedatabase =vb1
    sourcetableprefix =

    *edit * I found another note that fixed one problem. I changed the source table prefix to ib_ and it found al lthe missing tables. But now when I go to import data from them, I get 0 data imported.

    I first click on Import Export. Then I click on Ikon_mysql. All the data was uploaded using Plesk, MySQL and the Database .sql files. I then Click on the module buttons and start the process, but it dosn't import a thing..

    I must be doing something wrong..

    Last edited by Shredder1; Tue 5 Apr '05, 4:13pm.

    Leave a comment:


  • Jerry
    replied
    What is your source table prefix ? (sourcetableprefix = in ImpexConfig)

    Looks like b_ or o_ from that image ? I can't quite see.

    Leave a comment:


  • Shredder1
    replied
    OK, I think I restored it to Mysql properly. But when I use Impex to convert it, I get this message...




    I reconfigured Impexconfig.php to point to the new database. What else am I doing wrong?

    Leave a comment:


  • Jerry
    replied
    Originally posted by Shredder1
    OK, I got ahold of the database, But I'm d irectly at the server itself. How do I telenet in, or do I even need to?

    Thanks
    You are directly at the server ? You mean its local, i.e. the machine you are typing on now ?

    If that is the case check out the link in my last post and restore the database into MySQL.

    Leave a comment:


  • Shredder1
    replied
    OK, I got ahold of the database, But I'm d irectly at the server itself. How do I telenet in, or do I even need to?

    Thanks

    Leave a comment:


  • Jerry
    replied
    Originally posted by Shredder1
    If I can get ahold of that, what's the next step?
    Restore that file to a database thus :

    http://www.vbulletin.com/docs/html/m...ervers_restore

    Then set that as your sourcedatabase in your ImpExConfig.

    Leave a comment:


  • Shredder1
    replied
    Yeah, I think my friend still has a copy of it, as that's how he imported all the data before I installed impex.

    If I can get ahold of that, what's the next step?

    Thanks

    Leave a comment:


  • Jerry
    replied
    Ok, well the important bit is the Ikon database, thats where all your infomation is. Can you get a copy or back up of that database ?

    Leave a comment:


  • Shredder1
    replied
    Guess I didn't explain it clearly.

    I didn't see the option to backup the VBulliten Board in the AdminCP/Import and Maintenance/Backup section, and didn't use that to backup the board data. I just went to my Sites folder on the server where the board was located, in this case c:/inetpub/vhosts/ntn/forum and copied the forum folder where the board is.

    As far as I can tell, the Ikon Board is no longer connected to a mysql database.

    Hope that explained it a bit better

    Leave a comment:


  • Jerry
    replied
    Originally posted by Shredder1
    If I'm understanding your question right, I didn't back it up using the admin panel, because at the time I didn't see that option. I just copied the folder it was in, in this case forum, and pasted it to the D Drive hoping that would back up all the data.
    I don't know what you mean or what you have done here, you need the source database not the files for the site.

    Originally posted by Shredder1
    Also, I changed the source database to mysql and it still is importing Zero data.
    Is the database there ?

    Leave a comment:


  • Shredder1
    replied
    If I'm understanding your question right, I didn't back it up using the admin panel, because at the time I didn't see that option. I just copied the folder it was in, in this case forum, and pasted it to the D Drive hoping that would back up all the data.

    Also, I changed the source database to mysql and it still is importing Zero data.

    Leave a comment:


  • Jerry
    replied
    Originally posted by Shredder1
    2 Questoins.

    1)I'm trying to convert user data/Posts/ and Passwords from Ikon Board over to VBulliten 3.

    sourcedatabasetype = C:\Inetpub\vhosts\ninjaturtlesnetwork.com\httpdocs\forums

    The IkonBoardis in the Plesk Folder located above.
    But as far as I know, is no longer connected to an MYSWL database. Am I doing something wrong? When I try to transfer the info, no board data comes across. I've never attempted this before, so please forgive if it sounds like a stupid question...
    Yes thats wrong, that is a file path, the source database type will be "mysql", if its all in the same database it will most lightly be localhost with a diffrent table prefix.

    Originally posted by Shredder1
    2)Before I had to reformat the server, a friend of mine imported all the Data from the old board to the new board. I saved the forum folder that he updated it with, and thought that would be enough to backup the boards. Figuring I could just cut and paste and everything would be back to normal. Don't laugh, I'm a message board novice .

    Is it easier to import the data from there(VB3 to VB 3), and if so, how would it be accomplished?

    Thanks
    Neil
    It is the database version of Ikonboard and not the flat file version isn't it ?

    Leave a comment:


  • Shredder1
    started a topic ImpexConfig.php help needed

    ImpexConfig.php help needed

    2 Questoins.

    1)I'm trying to convert user data/Posts/ and Passwords from Ikon Board over to VBulliten 3.

    I've got impexconfig.php configured as follows...

    targetdatabasetype = mysql
    targetserver = localhost
    targetuser = "theshredder"
    targetpassword = "vbtest"
    targetdatabase = vb
    targettableprefix =
    [ Source Database ]
    ; If the system that is being imported from uses a database,
    ; enter the details for it here and set 'sourceexists' to TRUE.
    ; If the source data is NOT stored in a database, set 'sourceexists' to FALSE
    sourceexists = true
    ; mysql OR mssql
    sourcedatabasetype = C:\Inetpub\vhosts\ninjaturtlesnetwork.com\httpdocs\forums
    sourceserver = localhost
    sourceuser = "theshredder"
    sourcepassword = "vbtest"
    sourcedatabase = vb
    sourcetableprefix =

    The IkonBoardis in the Plesk Folder located above.
    But as far as I know, is no longer connected to an MYSWL database. Am I doing something wrong? When I try to transfer the info, no board data comes across. I've never attempted this before, so please forgive if it sounds like a stupid question...

    2)Before I had to reformat the server, a friend of mine imported all the Data from the old board to the new board. I saved the forum folder that he updated it with, and thought that would be enough to backup the boards. Figuring I could just cut and paste and everything would be back to normal. Don't laugh, I'm a message board novice .

    Is it easier to import the data from there(VB3 to VB 3), and if so, how would it be accomplished?

    Thanks
    Neil
Loading...
Working...
X