Announcement

Collapse
No announcement yet.

Impex: Recieving MySQL Error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Impex: Recieving MySQL Error

    I'm recieving the following error when I try to run Impex:

    Warning
    : opendir(/home/diffuse/public_html/forum/./impex/systems): failed to open dir: No such file or directory in /impex/ImpExDisplay.php on line 492

    I'm also unable to select the "phpBB2" system from the dropdown menu. Everything is configured properly, as far as I can tell. Does anyone have any ideas about this?
    Last edited by Gravity Kills; Fri 1 Apr '05, 5:37pm.

  • #2
    Nevermind, I figured it out. Sorry!
    Is it ok or not ? Need a hand ?
    I wrote ImpEx.

    Blog | Me

    Comment


    • #3
      I figured out the first problem, but ran into another. I edited the above post

      Comment


      • #4
        Can you please stick to one error at a time and wait for a reply before editing a message so I/we know what error we are trying to answer.
        I wrote ImpEx.

        Blog | Me

        Comment


        • #5
          Originally posted by Gravity Kills
          I figured out the first problem, but ran into another. I edited the above post
          Are you broswing directly to impex or do you have it installed inside vBulletin ?
          I wrote ImpEx.

          Blog | Me

          Comment


          • #6
            Originally posted by Jerry
            Can you please stick to one error at a time and wait for a reply before editing a message so I/we know what error we are trying to answer.
            Sure, sorry about that.

            I figured out that second problem, and now I ran into another (*laughs*)

            Warning: main(./impex/systems/phpBB2/000.php): failed to open stream: No such file or directory in /impex/index.php on line 207

            Fatal error: main(): Failed opening required './impex/systems/phpBB2/000.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/diffuse/public_html/forum/impex/index.php on line 207

            Comment


            • #7
              Originally posted by Gravity Kills
              Sure, sorry about that.

              I figured out that second problem, and now I ran into another (*laughs*)

              Warning: main(./impex/systems/phpBB2/000.php): failed to open stream: No such file or directory in /impex/index.php on line 207

              Fatal error: main(): Failed opening required './impex/systems/phpBB2/000.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/diffuse/public_html/forum/impex/index.php on line 207
              Are you broswing directly to impex or do you have it installed inside vBulletin ?

              Its the path, just got to figure out why php and impex are looking in the wrong place.
              I wrote ImpEx.

              Blog | Me

              Comment


              • #8
                I've got it installed inside vBulletin. I'm currently browsing to Impex through the Import/Export menu in the Admin CP.

                Comment


                • #9
                  Originally posted by Gravity Kills
                  I've got it installed inside vBulletin. I'm currently browsing to Impex through the Import/Export menu in the Admin CP.
                  Ok good.

                  What system are you on ? Webserver, PHP version, OS ?
                  I wrote ImpEx.

                  Blog | Me

                  Comment


                  • #10
                    Apache 1.3.33
                    Operating System: Linux (Not sure which distro)
                    PHP 4.3.10
                    MySQL 4.0.22-standard

                    Comment


                    • #11
                      Originally posted by Gravity Kills
                      Apache 1.3.33
                      Operating System: Linux (Not sure which distro)
                      PHP 4.3.10
                      MySQL 4.0.22-standard
                      And the file impex/systems/phpBB2/000.php is in place ?

                      Though it should be opened on line 207.

                      Have you changed the source ?
                      I wrote ImpEx.

                      Blog | Me

                      Comment


                      • #12
                        Alright, that was the problem. Filezilla didn't upload it correctly, for whatever reason. Now I'm back to the first problem. I'm unable to connect to the source server, and I'm guessing it's the fact that the cPanel auto installation never told me the password associated with the database username.

                        Comment


                        • #13
                          I created a new user and pass, which I dropped into the DB. I can access it now, but I only have the options to "Database Cleanup and Restart" or "Online Manual". There's no listing of importers anymore

                          Comment


                          • #14
                            You will need to configure, ImpExConfig.php with all the details and check that sourceexsists = true.
                            I wrote ImpEx.

                            Blog | Me

                            Comment


                            • #15
                              Alright, done. Started the import and it seemed to go alright, until I got to the second module, which gives this error:

                              Database error in vBulletin:ImpEx Source 3.0.7:

                              Invalid SQL:
                              SELECT user_id,username
                              FROM users
                              ORDER BY user_id
                              LIMIT 0,25
                              mysql error: Table 'diffuse_phpbb1.users' doesn't exist

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X