Announcement

Collapse
No announcement yet.

Problems connecting to MS-SQL

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • dsmania
    replied
    Problem solved. I added an SA account to SQL 2k and that seems to have taken care of the issue.

    Thanks,

    Dave

    Leave a comment:


  • dsmania
    replied
    Yes, IIS has been restarted several times now. ntwdblib.dll has also been copied to the \windows\system32 directory. Is this the file you're refering to?

    Can you confirm that this script works if SQL 2000 authentication is set to use the Windows login? Do I need to make any security changes to SQL 2k in order for this to work?

    Thanks,

    Dave
    Last edited by dsmania; Sat 29 Jan '05, 10:56am.

    Leave a comment:


  • Zachery
    replied
    Did you restart apache? (or IIS) if you did you will also need the dll from the windows SQL server cd that will allow you to run and access MSSQL servers.

    Leave a comment:


  • dsmania
    replied
    I'm pretty sure that I have. I've uncommented extension=php_mssql.dll from the php.ini file in \WINDOWS and copied the php_mssql.dll file into \WINDOWS\system32

    Is anything else involved?

    Thanks,

    Dave

    Leave a comment:


  • Zachery
    replied
    Did you configure php with mssql support?

    Leave a comment:


  • dsmania
    started a topic Problems connecting to MS-SQL

    Problems connecting to MS-SQL

    Hello. I'm now on day 3 trying to convert my FuseTalk forums in MS-SQL over to the VBulletin. Any advice on this would be greatly appreciated.

    I've tried numerious combinations of sourceserver, sourceuser, and sourcepassword in the ImpExConfig.php file. The results are always the same during import.

    Warning: mssql_connect(): message: Login failed for user 'USERID'. (severity 14) in \impex\db_mysql.php on line 54

    Warning: mssql_connect(): Unable to connect to server: SERVERNAME in \impex\db_mysql.php on line 54

    Warning: mssql_select_db(): supplied argument is not a valid MS SQL-Link resource in \impex\db_mysql.php on line 169

    I've done some research online, and found suggestions ranging from creating and using the data source name instead of "localhost" to using the computer name instead of "localhost". I've tried both to no avail.

    MS SQL was loaded on my local machine using Windows authentication. Does it need to be configured differently? If not, what exactly is MS SQL looking for from the ImPex script?

    Do I need to set up and reference an ODBC data source or can I go directly to MSSQL?
    Thanks,

    Dave

Related Topics

Collapse

Working...
X