Announcement

Collapse
No announcement yet.

Connect Failure

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Connect Failure

    I have a fresh copy of vB 3.06 running on my site and I installed the Impex system so I can import from my old phpbb2 forum.

    I click on the "Import / Export" link in my ACP and I get the following error:

    --------------------------
    Database error in vBulletin:ImpEx Target 3.0.6:

    Link-ID == false, connect failed
    mysql error:

    mysql error number: 0
    --------------------------

    Currently, my ImpExConfig.php lookis like this:
    Code:
    ;vBulletin:Impex Config File<?php /*
    ;| #################################################################### |;
    ;| # vBulletin 3.0.6 - Licence Number [b]<REMOVED>[/b]
    ;| # ---------------------------------------------------------------- # |;
    ;| # Copyright ©2000–2005 Jelsoft Enterprises Ltd. All Rights Reserved. |;
    ;| # This file may not be redistributed in whole or significant part. # |;
    ;| # ---------------- VBULLETIN IS NOT FREE SOFTWARE ---------------- # |;
    ;| # http://www.vbulletin.com | http://www.vbulletin.com/license.html # |;
    ;| #################################################################### |;
     
    [ Target Database ]
    ; The following settings allow ImpEx to connect to the vBulletin 3
    ; database into which you will be importing data.
     
    targetdatabasetype = mysql
    targetserver = localhost
    targetuser = "username is here"
    targetpassword = "password is here"
    targetdatabase = "database name is here"
    targettableprefix =
     
    [ Source Database ]
    ; If the system that is being imported from uses a database,
    ; enter the details for it here and set 'sourceexists' to TRUE.
    ; If the source data is NOT stored in a database, set 'sourceexists' to FALSE
     
    sourceexists = true
     
    ; mysql OR mssql
    sourcedatabasetype = mysql
    sourceserver = localhost
    sourceuser = "username is here"
    sourcepassword = "password is here"
    sourcedatabase = "database name is here"
    sourcetableprefix = "phpbb2_"
     
    ;| #################################################################### |;
    ;| # File ends with closing PHP tag... # |;
    ;| #################################################################### |;
    ;*/ ?>
    Now, I know the username, password and database name for the target is proper because it is the same as in my config.php file my my vB.

    I know that the information is correct for the source because it is the same as in the config.php for my phpbb2.

    Ideas?
    Last edited by Floris; Wed 26 Jan '05, 12:32pm.

  • #2
    I've removed your license number from the .php file you posted to prevent abuse by others.

    Comment


    • #3
      Oops! Thank you

      Comment


      • #4
        This is almost certainly an issue with the db info in the ImpexConfig.php file. It's either that or a problem with your server.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          I agree with you that this is the way it seems. However, my vbb is working fine and using that same db info and my phpbb is working fine using that same db info. Could it be a formatting issue?

          Comment


          • #6
            It's possible. Try to retain the exact format and syntax of the ImpexConfig.php.new file.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Thank you Steve. I started completely over with fresh files and it worked. Hadf to be something I typed wrong.

              Thanks again.

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X