Announcement

Collapse
No announcement yet.

Restoring the Database on the New Server WON'T WORK

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Collectors
    replied
    It works!

    Originally posted by Mike Sullivan
    Looks like your dump tries to create the database too. Try dropping the database you just created, and using this command to restore it:

    mysql –uUSERNAME –p < /PATH/TO/NEW/DUMP.SQL
    Special thanks to Mike Sullivan and Steve Machol, Excellent work

    Cheers!

    Leave a comment:


  • Collectors
    replied
    Working!

    Originally posted by Mike Sullivan
    Looks like your dump tries to create the database too. Try dropping the database you just created, and using this command to restore it:

    mysql –uUSERNAME –p < /PATH/TO/NEW/DUMP.SQL
    This works!
    Last edited by Collectors; Fri 21 Jan '05, 1:35pm.

    Leave a comment:


  • Mike Sullivan
    replied
    Looks like your dump tries to create the database too. Try dropping the database you just created, and using this command to restore it:

    mysql –uUSERNAME –p < /PATH/TO/NEW/DUMP.SQL

    Leave a comment:


  • Collectors
    replied
    Thank you for the ultra-fast reply!

    I made the 'NEWDBNAME' and it's returning a new error stating:

    ERROR 1007 at line 12: Can't create database 'NEWDBNAME'. Database exists

    Someone please give me a drink

    Leave a comment:


  • Steve Machol
    replied
    You need to create a database with that name.

    Here is our online documentation for creating a new database and db user:

    http://www.vbulletin.com/docs/html/create_database

    And from the MySQL site:

    http://dev.mysql.com/doc/mysql/en/CREATE_DATABASE.html

    Leave a comment:


  • Collectors
    started a topic Restoring the Database on the New Server WON'T WORK

    Restoring the Database on the New Server WON'T WORK

    Hi,

    I'm trying to restore a mysql database dump (a phpBB sql dump to be exact, for import to vBulletin with ImpEx) as the documention specified, like this:

    mysql –uUSERNAME –p NEWDBNAME < /PATH/TO/NEW/DUMP.SQL

    I tried a tests before and it did work but now I'm getting an error stating:

    ERROR 1049: Unknown database 'NEWDBNAME'

    This is really frustrating please someone help out!!!

    Server Specs:

    Free BSD
    MySQL 4.0.17
    Apache 1.3.33
    Last edited by Collectors; Fri 21 Jan '05, 12:07pm.
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X