Announcement

Collapse
No announcement yet.

Batch Member Import (Auto Registration)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Batch Member Import (Auto Registration)

    I'm setting up a brand new vBulletin 3.0.6 installation (my first vB). In a small corporate environment, this vB installation will be for internal use only. I'm looking to pre-register my network users, using their existing network usernames (which would then be their vB member names). I can create a web form to capture network usernames/passwords from users, saving into a file. Could I then use this file (.TXT, .CSV, etc.) to batch/import, basically auto-registering new members? TIA.

  • #2
    I haven't used this myself, but i assume that is what the Flat file user (CSV style) importer does.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      I downloaded the ImpEx source from the Members Area (Appendix 5 of the manual); I'll prep a CSV and give it a try. Thanks for the pointers, Steve.

      Comment


      • #4
        Originally posted by Steve Machol
        I haven't used this myself, but i assume that is what the Flat file user (CSV style) importer does.
        I installed the most recent ImpEx, but I find that Flat File User (CSV style) is not in the list. Other vB posts note the CSV importer at #42, which is XMB Forum for me. Is there an older ImpEx out there that would do the job?

        Comment


        • #5
          I just downloaded the latest Impex, installed it, and the text file importer is definitely listed as #42.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            Did my ImpEx install go wrong? I'll try again. I remove impex from my vB system directory, then AdminCP > Import & Maintenace : Import/Export is gone. Good. I download vB3 Importers from Members again, and reinstall to my server, under my vB /forums directory, a directory named /impex.

            BTW: impex.readme.txt file reports this version:
            Code:
             
            /**
            * A read me
            *
            * @package ImpEx
            * @version $Revision: 1.55 $
            * @author Jerry Hutchings <[email="[email protected]"][email protected][/email]>
            * @date $Date: 2005/01/06 23:33:50 $
            *
            */
            Back in AdminCP > Import & Maintenance and Import/Export is back. Great! I open to find no CSV Flat File Importer anywhere in the list, and #42 is absolutely "XMB Forum". (see attach). Why are we seeing different screens, using the same rev. ImpEx?
            Attached Files

            Comment


            • #7
              Yes, something went wrong. Most likely you did not overwrite the existing Impex files when you uploaded the new ones.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                I've literally deleted and freshly uploaded both my local and remote server /impex folders - two or three times - being sure I've got latest copy of ImpEx (vB3 Importer) from the Members section. Still, I get no CSV Importer. I figured CSV Importer was in an OLDER ImpEx, but Steve... you get CSV Importer with a fresh ImpEx install? I'll drop Jerry a message and see if he knows why I can't get the CSV Importer showing in my list of importers. I'm looking to import about 150 usernames and passwords only. I'm spending alot of clock time gettin' nowhere fast!

                Comment


                • #9
                  It is displayed as : Text file importer 0.0

                  Isn't that showing up for you ?
                  I wrote ImpEx.

                  Blog | Me

                  Comment


                  • #10
                    # 33. on his screenshot.

                    Comment


                    • #11
                      It's #42 on the Impex files I downloaded last night.
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #12
                        There isn't any specific sorting on the folders, is as the OS returns the dir listing.

                        I might stick a numbering sort in so people can refer to a system by number opposed to a name.
                        I wrote ImpEx.

                        Blog | Me

                        Comment


                        • #13
                          I 'really' like that idea: 'fix' a number in the list alongside the importers, so we have an absolute reference for discussion. And the Text File Importer link? Nice touch if that link would go to a vB.com/subpage w/ help importing txt files, maybe with a few examples, etc. In a perfect world. Thanks, Jerry - and Steve.
                          Last edited by Brett James; Thu 27 Jan '05, 5:47am.

                          Comment


                          • #14
                            I've prepped a clean users.txt file of (username,email,password) i.e.

                            Jerry,[email protected],jerry_password
                            Steve,[email protected],steve_password

                            etc.

                            I upload it ASCII into (path to vBsystem)/impex/systems/txt_file/ folder - and I run ImpEx, Module 001, but every time I get this NOT OK warning:

                            ---

                            Altering tables

                            ImpEx will now Alter the tables in the vB database to include import id numbers.

                            If you have large tables (i.e. lots of posts) this can take some time.

                            They will also be left after the import if you need to link back to the origional vB userid.

                            moderator - importmoderatorid OK
                            usergroup - importusergroupid OK
                            ranks - importrankid OK
                            poll - importpollid OK
                            forum - importforumid OK
                            forum - importcategoryid OK
                            user - importuserid OK
                            style - importstyleid OK
                            thread - importthreadid OK
                            post - importthreadid OK
                            thread - importforumid OK
                            smilie - importsmilieid OK
                            pmtext - importpmid OK
                            avatar - importavatarid OK
                            customavatar - importcustomavatarid OK
                            customprofilepic - importcustomprofilepicid OK
                            post - importpostid OK
                            attachment - importattachmentid OK
                            pm - importpmid OK
                            users.txt - NOT OK

                            ---

                            What's not okay? The file structure? The path to the file? If I DO attempt to run Module 002 anyway and forget about the warning, after I designate field1 = username, field2 = email, field3 = password then click <Continue>, an error shows on the screen, but only for a micro-split second before the error is covered over by the modules screen. I BELIEVE the error message is something like...

                            ---

                            "... invalid argument supplied for foreach()"

                            ---

                            Last edited by Brett James; Fri 28 Jan '05, 3:28am.

                            Comment


                            • #15
                              It's the Path To users.txt that's the problem. I was using path from root of website. When I changed it to... path from root of server, NOT OK became OK.

                              Moving on...

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X