Announcement

Collapse
No announcement yet.

Import & Maintenance -> Import / Export ???

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by criscokid
    I've finished running ImPex and everything appears to be ok except that all my forum and user IDs have changed. This was probably because there was previously a load of users, forums and posts from my vb2 to vb3 upgrade.

    How to I now undo this (reset all the IDs at 0 before re-running Impex?) and get them to be the same IDs as my vB2 forum?
    This is at the top of the every impex page under clean up. You cannot force force forum ID's into the database.

    Originally posted by criscokid
    The statstics block at the bottom of /forums/index.php shows for my vb3 board:
    Threads: 139, Posts: 175, Members: 2,554
    and for my vB2 board:
    Threads: 739, Posts: 835, Members: 2,553

    When I click on members list it lists 1 user (myself)
    Read the howto and sort out your usergroups.

    Originally posted by criscokid
    In the Usergroup Manager all of my usergroups appear twice - once in the Help Default Usergroups section and once in the Custom Usergroups section. How do I bulk move the users in each custom category to the relevant default category?
    If they are in the correct groups in custom then they are the imported groups and can be moved via SQL, if they are un organized or duplicated then you will need to re-run the import.
    I wrote ImpEx.

    Blog | Me

    Comment


    • #17
      It was originally told that Impex would be the best approach... http://www.vbulletin.com/forum/showthread.php?t=125715

      I'm now thinking that I would indeed have been better off...

      * closing my current vb2 board and upgrading it to vb3
      * copying the users and relevant threads tables from the newly upgraded site into my vb3 site that I've been working on the last few weeks.

      "Read the howto and "Read the howto and sort out your usergroups" - I've read the how to before running Impex and used it step by step as I was running it. What do you mean by "sort out your usergroups". Please can you be more specific.

      "If they are in the correct groups in custom then they are the imported groups and can be moved via SQL"
      They do appear to be organised. Is there no way to move them using vB CP? I'd appreciate it if you could please tell me what mySQL commands to use.

      My 1st user is an administrator, so I already had one use when I started Impex. Impex imported all the users and the forum posts but all posts made by that first administrator user are now written by 'imported_administrator'.

      Comment


      • #18
        Originally posted by criscokid
        It was originally told that Impex would be the best approach... http://www.vbulletin.com/forum/showthread.php?t=125715

        I'm now thinking that I would indeed have been better off...

        * closing my current vb2 board and upgrading it to vb3
        * copying the users and relevant threads tables from the newly upgraded site into my vb3 site that I've been working on the last few weeks.

        "Read the howto and "Read the howto and sort out your usergroups" - I've read the how to before running Impex and used it step by step as I was running it. What do you mean by "sort out your usergroups". Please can you be more specific.
        Have you either moved the users from the imported groups to the default groups or set the psermissions of the imported groups ?

        Originally posted by criscokid
        "If they are in the correct groups in custom then they are the imported groups and can be moved via SQL"
        They do appear to be organised. Is there no way to move them using vB CP? I'd appreciate it if you could please tell me what mySQL commands to use.
        Where X is the old group and Y is the new one :

        Code:
        UPDATE user SET usergroupid = Y WHERE usergroupid = X;

        Originally posted by criscokid
        My 1st user is an administrator, so I already had one use when I started Impex. Impex imported all the users and the forum posts but all posts made by that first administrator user are now written by 'imported_administrator'.
        Use the admincp to merge the admin users into one.
        I wrote ImpEx.

        Blog | Me

        Comment


        • #19
          Thank you very much for that - all done :-) I assume it's ok now to delete the custom usergroups (none of them have any users in them).

          I've run Rebuild Attachment Thumbnails in the admin CP and none of my graphic attachments are showing up inline (they're set in in CP to show up inline) - this applies to both old and new posts. I'm running PHP 4.3.10 with inbuilt GD2.

          Comment


          • #20
            Originally posted by criscokid
            I've run Rebuild Attachment Thumbnails in the admin CP and none of my graphic attachments are showing up inline (they're set in in CP to show up inline) - this applies to both old and new posts. I'm running PHP 4.3.10 with inbuilt GD2.
            Does anyone have any idea what other settings I should be checking to get the image attachments to show up inline in forum posts?

            Comment


            • #21
              I turned 'show image attachments inline' off and then on again and still it made no difference. Only when I closed MSIE and restarted it did my image attachments show inline :-)

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X