Announcement

Collapse
No announcement yet.

Unable to connect to database

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to connect to database

    I searched all the forums and did everything I should. I checked the config parameter 500 times and I still get this when I try to open the import option in de admin module

    Database error in vBulletin:ImpEx Target 3.0.5:
    Link-ID == false, connect failed
    mysql error:

    mysql error number: 0


    Why is this happening

  • #2
    The impexconfig.php file has the wrong information in it.

    Make sure the top part of the config file matches your config.php

    Comment


    • #3
      that's what I said in my first post ,,this is al correct....

      Comment


      • #4
        Then mysql must be down, as if everything is absolulty correct it would work.

        Comment


        • #5
          mysql is definitely NOT down,,there are other website running on this server.

          Comment


          • #6
            If you can confirm you are still receiving this error and MySQL server is up .. please check the details in your config.php file. As we do not know those details confirm them with your hosting provider. If they are still correct then please confirm you are running all the latest 3.0.5 files unmodifed, uploaded 100% in ascii transfer mode, not resumed or skipped during upload and there is no other errors in config.php. If you believe that is correct too then please start a new support ticket (link back to this thread) and include your admincp url, your forum admin user/pass - your ftp host/port user/pass and phpmyadmin details so we can confirm the database is reachable (if shell access isn't possible) and one of our staff will take a deeper look and try to find why it doesn't connect.

            Comment


            • #7
              Is the syntax of the file correct?
              [ CONTENT REMOVED ]

              Comment


              • #8
                Originally posted by bist
                Is the syntax of the file correct?
                [ CONTENT REMOVED ]
                Content removed as it has your license number and server details which could lead in someone abusing those details.

                We can only check through ftp, not over copy/paste.

                Comment


                • #9
                  Is your vBulletin 3.0.5 installation running on the same web server account as where this impex is being run from? Or is that a different account?

                  Comment


                  • #10
                    The same. It's running plesk as hosting software. The idea is I want to migrate from phpbb to vb.

                    The databases are on the same server. Everything is on the same server.

                    Comment


                    • #11
                      and the username/password/database name in include/config.php is same in impex/ImpExConfig.php ?

                      Open a support ticket so we can have a look at this.

                      http://www.vbulletin.com/members/mem...ontactform.php
                      I wrote ImpEx.

                      Blog | Me

                      Comment


                      • #12
                        Just for what it's worth, we just had the same problem. Granted it only lasted for about 5 minutes, we received the same error message and haven't had a problem in about 6 months (just upgraded to 3.0.5 when it first came out as a critical update).

                        Comment


                        • #13
                          hmmmmm i have this problem ... i think u are use passwrod like this

                          //]'/.;'p[o

                          Comment

                          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                          Working...
                          X