Announcement

Collapse
No announcement yet.

Need help w/convert from phpbb

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Need help w/convert from phpbb

    hey guys

    Here is my story. I have a phpbb 2.04 board that is not very updatable to a new version as it's pretty hacked. So I decided to update to vb. I bought my license and have already customized my vb board to my liking. I did not want to import users and other stuff until it was ready for them.

    My old board is on another server. I installed a Fresh phpbb.2.11 on this new server, and imported my old 2.04 database into the new board. MyphpAdmin says it's there, though the board is not working

    But now I am trying to use the Impex script and when I click on import/export I get:

    Database error in vBulletin:ImpEx Target 3.0.4:
    Link-ID == false, connect failed
    mysql error:
    mysql error number: 0
    Date: Tuesday 11th of January 2005 12:08:46 AM
    Script: http://72.9.227.2/~aquatic/forum/impex/index.php
    Referer: http://72.9.227.2/~aquatic/forum/adm...dex.php?do=nav
    Username: paradise
    <removed>

    Thanks, everyone, in advance,
    Edward

  • #2
    Please note that it is against the forum rules to solicit paid services on these forums.

    This error means that either the info in your ImpExConfig.php file is wrong or there is a problem with the MySQL server. If you are sure that the db info is correct then you need to contact your host.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      sorry, did not mean to. was not aware of the rules on that one.

      Ok, a couple of questions then:

      The way the host's server arranges dbs is different:

      my vb one is called aquatic_vb
      and
      my phpbb one is called aquatic_phpbb1

      Does that mean that aquatic_ is the prefix, and is it aquatic or aquatic_?

      Also the user in the db is aquatic_admin, so is there a prefix or is that the full username? You could see where one could get confused, right?

      Also, have you heard of this method of doing it, i.e. uploading a 2.04 phpbb database to 2.11 board to updage it? does that work? 'cause my server installed it via phpmyadmin, but the 2.11 board is now giving a mysql error.

      Anyone?

      Comment


      • #4
        just a quick update:

        I have a new error:

        Database error in vBulletin:ImpEx Target 3.0.4:
        cannot use database vb
        mysql error: Access denied for user: '[email protected]' to database 'vb'
        mysql error number: 1044
        Date: Tuesday 11th of January 2005 03:38:52 AM
        Script: http://72.9.227.2/~aquatic/forum/impex/index.php
        Referer: http://72.9.227.2/~aquatic/forum/admincp/index.php?
        Username: paradise
        IP Address: 67.49.7.181

        So, if I am reading it correctly, it's recognizing the user and the Db, but it wont grant access, though in mysql the user is given ALL PRIVELEGES. What gives? Please

        Comment


        • #5
          Originally posted by apfparadise
          So, if I am reading it correctly, it's recognizing the user and the Db, but it wont grant access, though in mysql the user is given ALL PRIVELEGES. What gives? Please
          Thats correct.

          Are you using the same username/password/database name that you are for your vBulletin install ?
          I wrote ImpEx.

          Blog | Me

          Comment


          • #6
            the databases have the same prefix, as they are on the same server, aquatic_ , and it's the same admin account that runs both, but the databases have a different name (vb, and phpbb1). So one is aquatic_phpbb1, and the other one is aquatic_vb. Can that work?

            Comment


            • #7
              Originally posted by Jerry
              Are you using the same username/password/database name that you are for your vBulletin install ?
              Can that work?
              Yes.
              I wrote ImpEx.

              Blog | Me

              Comment


              • #8
                thanks, jerry, so what is the problem then ?

                Comment


                • #9
                  I would raise a support ticket then we can have a look at it.

                  http://www.vbulletin.com/members/mem...ontactform.php
                  I wrote ImpEx.

                  Blog | Me

                  Comment


                  • #10
                    Originally posted by apfparadise
                    thanks, jerry, so what is the problem then ?
                    Your database and table prefix in ImpExConfig.php was incorrect.
                    I wrote ImpEx.

                    Blog | Me

                    Comment


                    • #11
                      just looked at it, thanks, you are right, i was totally confused, I thought the aquatic_ was the prefix, not phpbb_ for the phpbb database. That did it.
                      thanks
                      Ed

                      Comment


                      • #12
                        Ok, follow up. Installation completed PERFECTLY. even my 2.04 db went in like butter.

                        One small nag. My old account, same name and everything, on the new board the old posts by me (only) are shown as "guest". Is there a way to fix that? It did not combine the two, did for all other users, but not me, admin.

                        Other than that, I am a HAPPY camper!!! Thanks, Jerry, for all the help. Would not be possible w/out it!!!

                        Comment


                        • #13
                          I take it you were the admin user on the old board so user id 0 or -1 ?

                          If ALL the posts and threads that come up as guest are yours then, the SQL to fix that is fairly easy, if that is the case.
                          I wrote ImpEx.

                          Blog | Me

                          Comment


                          • #14
                            yes, jerry, I would love that. they are all mine can you please do it here or in the original ticket? Thank you, very much.
                            ed

                            Comment

                            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                            Working...
                            X