Announcement

Collapse
No announcement yet.

Message Titles all mixed up

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Message Titles all mixed up

    I imported a phpBB2 database, and installed vBadvanced. I started looking over the forum after that and noticed that message titles were all mixed up.

    Over in phpBB2 some messages had subjects and some did not. after the import, the message subjects from phpBB2 messages were all scattered on the wrong message title in vb3. Not all messages in vb3 got titles either.

    Has anyone ever seen this happen. If so, what is the fix? Do I need a new importer? Or was it something I didn't set up during the import? I'm assuming there is no way to fix it in place other than manually editing all the messages titles to be the correct ones, or trying the whole import cycle over again.

    With vBadvanced installed, can I drop the tables for just vb3, and leave the vBadvanced ones alone, or do I have to drop all tables again to try a new import?

  • #2
    Just to be sure, do you mean posts or private messages ?
    I wrote ImpEx.

    Blog | Me

    Comment


    • #3
      posts in threads.

      The majority of the posts in threads on the phpBB2 board did not have titles (or subjects as they are called in phpBB2), but some did, and they got all switched around when I imported them into vBulletin.

      Just to see what would happen, I redid the import module for posts, from the admincp. It said it was clearing the posts from the database, and re-importing them. Same thing. All the switched titles were on the same posts though, as the first time I imported.

      Comment


      • #4
        And this is with a completely standard phpBB install, no hacks etc ? using impex version 1.55 ?
        I wrote ImpEx.

        Blog | Me

        Comment


        • #5
          I can't see how to tell what version of impex I'm using, but I had version 3.0.3 of vBulletin installed in a test mode, when the 3.0.5 release came out, and I cleared the vBulletin database, and reinstalled a fresh 3.0.5, and used the impex that I downloaded with 3.0.3.

          I suppose that's my problem. I didn't know that impex was tied so closely with the version number of vBulletin, since they were downloaded separately.

          I'll go download the latest impex and try that. Should I have to re import the whole phpbb2 database, or just the posts?

          Comment


          • #6
            also, no hacks on the phpBB2 install. Just one style installed that didn't come with phpBB2.

            Comment


            • #7
              I downloaded the 1.55 version and tried a test import of just the posts, and it seems to have cleared up my titles switch problem. Now I just have to decide if reimporting the posts is enough, or if I should rebuild the db from scratch. And if I do reimport from scratch, I should probably reinsert the vBadvanced stuff. Thanks for the help, any further suggestions are appreciated. I'll probably just rebuild the whole thing from scratch next saturday.

              Comment


              • #8
                Must of been an old version then as I belive that was fixed pre christmas.

                I wouldn't advise a rebuild and import as there are lots of bug fixes between versions, apart from that just read the howto and test lots.
                I wrote ImpEx.

                Blog | Me

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X