Announcement

Collapse
No announcement yet.

Problem Imported with IPB2 to VB3 Error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem Imported with IPB2 to VB3 Error

    Hello

    i just Edit the Config File and ig o to check thelink and it give me this error


    ===========================
    Database error in vBulletin:ImpEx Target 3.0.5:

    Invalid SQL: SELECT title, data FROM datastore WHERE title = 'ImpExSession'
    mysql error: No Database Selected

    mysql error number: 1046
    =================


    This Is how i edit the Config File

    ========================================================
    [ Target Database ]
    ; The following settings allow ImpEx to connect to the vBulletin 3
    ; database into which you will be importing data.

    targetdatabasetype = mysql
    targetserver = localhost
    targetuser = "UserName"
    targetpassword = "MyPassword"
    targetdatabase = Databse_vb3
    targettableprefix =

    [ Source Database ]
    ; If the system that is being imported from uses a database,
    ; enter the details for it here and set 'sourceexists' to TRUE.
    ; If the source data is NOT stored in a database, set 'sourceexists' to FALSE

    sourceexists = false

    ; mysql OR mssql
    sourcedatabasetype = mysql
    sourceserver = localhost
    sourceuser = "Username"
    sourcepassword = "MyPassword"
    sourcedatabase = Database_IPB2
    sourcetableprefix = ibf_
    ======================================================


    any idea please.

    thankyou

  • #2
    Other Q .

    My DataBase is sooo Larg if i go to Take a back up i need to day to download this back up it is over then 3000MB so i dont make any back up of IPB is this importer going to delete the Databse in the IPB2 ?

    Comment


    • #3
      targetdatabase = Databse_vb3

      That is definatly correct ? Its not Database_vb3 ?
      I wrote ImpEx.

      Blog | Me

      Comment


      • #4
        Originally posted by Jerry
        targetdatabase = Databse_vb3

        That is definatly correct ? Its not Database_vb3 ?

        ohhh that is not my right Username i have Change itby my self .. just for Security if u need i can send u via Private Msg .

        Thankyou

        Comment


        • #5
          I'm not talking about the username, I mean the name of the database are you sure it is correct ?
          I wrote ImpEx.

          Blog | Me

          Comment


          • #6
            yes the name of the database is correct i'am sure i just check it 3 time .. to make sure !!!!!!

            Comment


            • #7
              sourceexists = false

              should be

              sourceexists = true

              are the target details the same as imcludes/config.php ?

              Do you have a table prefix ?

              Though the error is that the database can't be selected at all.
              I wrote ImpEx.

              Blog | Me

              Comment


              • #8
                still not need to work maybe iam doing something wrong

                targetdatabasetype = mysql
                targetserver = localhost
                targetuser = "UserName"
                targetpassword = "MyPassword"
                targetdatabase = Databse_vb3
                targettableprefix =

                [ Source Database ]
                ; If the system that is being imported from uses a database,
                ; enter the details for it here and set 'sourceexists' to TRUE.
                ; If the source data is NOT stored in a database, set 'sourceexists' to FALSE

                sourceexists = false

                ; mysql OR mssql
                sourcedatabasetype = mysql
                sourceserver = localhost
                sourceuser = "Username"
                sourcepassword = "MyPassword"
                sourcedatabase = Database_IPB2
                sourcetableprefix = ibf_


                maybe this should be

                ; mysql OR mssql
                sourcedatabasetype = mysql
                sourceserver = localhost
                sourceuser = "Username"
                sourcepassword = "MyPassword"
                sourcedatabase = Database_IPB2
                sourcetableprefix = ibf_
                targetdatabasetype = mysql
                targetserver = localhost
                targetuser = "UserName"
                targetpassword = "MyPassword"
                targetdatabase = Databse_vb3
                targettableprefix =

                [ Source Database ]
                ; If the system that is being imported from uses a database,
                ; enter the details for it here and set 'sourceexists' to TRUE.
                ; If the source data is NOT stored in a database, set 'sourceexists' to FALSE

                sourceexists = false


                ================================

                i dont no if this right or not .. it give me all the time this error .. ?

                one more think do i need to add ""

                like targetdatabase = Databse_vb3

                targetdatabase = "Databse_vb3"

                sourcetableprefix = ibf_
                sourcetableprefix = "ibf_"

                any Idea ??

                Thankyou

                Comment


                • #9
                  Originally posted by Jerry
                  sourceexists = false

                  should be

                  sourceexists = true

                  are the target details the same as imcludes/config.php ?

                  Do you have a table prefix ?
                  are the target details the same as imcludes/config.php ?

                  Do you have a table prefix ?
                  I wrote ImpEx.

                  Blog | Me

                  Comment


                  • #10
                    yes they are the same

                    in the VB i dont have any prefix but inthe IPB i have the prefix ibf_ i dont no what worng .

                    Comment


                    • #11
                      here if the info of the databse was wrong or something it willgive me this error

                      There seems to have been a slight problem with the database.
                      Please try again by pressing the refresh button in your browser.

                      An E-Mail has been dispatched to our Technical Staff, who you can also contact if the problem persists
                      ----------------------------------------------------------


                      why becz i just put a wrong user and i give me this error.. so that error is not about the info .. i dont no but maybe .. any idea about this..

                      Comment


                      • #12
                        I am also getting this error

                        Comment


                        • #13
                          It sounds like you did not make the change Jerry suggested in post #7.
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment


                          • #14
                            i.am 100000% i have checked the file over then millons time all the Info it correct

                            i setup it to "TRUE"

                            and still getting this error any Idea ?

                            Comment


                            • #15
                              I have just downloaded the latest impex and vBulletin and installed and done an import to ensure this isn't a bug in the database handeling of impex.

                              Please compare your ImpExConfig.php to the includes/config.php file you have for vBulletin.
                              I wrote ImpEx.

                              Blog | Me

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X