Announcement

Collapse
No announcement yet.

An easy UBB Classic importing question

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Update:

    1a) Your attempt at importing the data failed. Many of the forums from the UBB had been duplicated - they were listed more than once on the forums list. When I'd attempt to delete (through the control panel) the duplicate forums, it would give an error and say that it couldn't find the forum.

    1b) The duplicated forums were all very old unused forums which had been turned off long ago and, perhaps, had not been imported properly into the current version of the UBB Classic.

    1c) My solution to that problem was to delete the unused forums from UBB Classic then to re-install the vBulletin (including deleting all of the data in the database) and re-import the data from the UBB.

    2) My assumption, from the post above, that the error I made was to have used the wrong file extention on the Impex configuration script, seems now not to have been the case. Even with the extention properly set to .php3, I'm in precisely the same boat as I was before. When I click the Import/Export button and select UBB Classic, all I see is:

    http://www.vbulletin.com/forum/attac...chmentid=12612

    Jerry: Apparently you know what was not done, or what was done improperly, when I started this thread. Would you be so kind as to share?

    Thank you.
    Last edited by Ixtlan; Sat 1 Jan '05, 11:15am.

    Comment


    • #17
      You are using .php3 files for your vB Board/ImpEx. I believe there is some sort of bug with the .php3 version of ImpEx, and I am not sure how to fix that problem...

      Are you able to switch to .php files instead?

      Comment


      • #18
        Originally posted by Cary
        You are using .php3 files for your vB Board/ImpEx. I believe there is some sort of bug with the .php3 version of ImpEx, and I am not sure how to fix that problem...

        Are you able to switch to .php files instead?
        I don't know that much about it, Cary. In order to decide what kind of files to use, I used the webserver's control panel to create a mysql based chat room, and then I looked to see which extention the chat room used.

        However, when Jerry imported the files, they were all php3. And until I see evidence to the contrary, I'm most tempted to assume that the problems with his import were due to the existing but not used (i.e., turned off) forums which were never used with our current version of the UBB. With those deleted, I don't expect those problems to return.

        I'd like to be able to duplicate what Jerry did, but until I find out what he did, I can't do that.

        Comment


        • #19
          More than likely, the .php version of vBulletin/ImpEx will work on your server. Jerry lives the U.K., so currently it is 12am or 1am there, so Jerry may not be online for quite some time. In addition, I'm not sure if he works on Sundays.

          Please understand that if I knew what was wrong with your board, I would tell you. Unfortunately, I don't, and the only thing I can suggest is trying the .php extentions instead.

          Comment


          • #20
            Alright.

            So if the Impex is php rather than php3, does that mean that the whole board needs to be php as well?

            Comment


            • #21
              You are correct.

              Comment


              • #22
                Alright. Thanks. But I think I'll leave it as php3 until Jerry has another chance to chime in. Even if I ultimately have to change it to php, I'd still like to duplicate what Jerry did.

                For the record, and because it might help Jerry to identify my problem, I could find only three differences between what Jerry did and what I did:

                1) From the manual:

                The first thing you must do is to rename this file from ImpExConfig.php.new to ImpExConfig.php (removing the temporary .new extension).
                That's what I did - I removed the .new and left it .php. Jerry uploaded a filed called ImpExConfig.php3. So there were now two configuration files on the server: one with .php and one with .php3.

                2) In the second half of the configuration file...

                sourceexists = FALSE

                sourcedatabasetype = mysql
                sourceserver = localhost
                sourceuser =
                sourcepassword =
                sourcedatabase =
                sourcetableprefix =
                ...he had nothing after the "=" signs for sourcedatabase, sourceserver, etc. Mine retained what came with the original file. None of this should matter, though, since with "sourceexists" set to false, none of that information is used (right?).

                3) Again, from the manual:

                The easiest way to transfer the files is to upload the entire upload/ folder to the server. Using an FTP client we do this by selecting or dragging the upload folder from its location on your computer's hard disk to the web publishing folder on the server.
                That's what I did. The manual said to do it, so I did it. So all of the files in the "systems" folder were uploaded within the "systems" folder.

                But now, from the HOWTO:

                When uploading ImpEx, you only need to up load the dirs and file in the impex/systems folder that you actually need. i.e. if you are importing from phpBB just upload the impex/systems/phpBB folder with the core files.

                Uploading them all won't do any harm, though ImpEx will use more memory when starting for the first time as it checks them all and loads all the modules.
                This would appear to be what Jerry decided upon, since when he finished there was a new directory "backup_systems" and within it was a long list of directories associated with importing from other bulletin boards (perhaps the "ubb_classic" directory was in there too...I didn't notice). The "systems" directory, which had all of those sub-directories in it when I started, now only had the "ubb_classic" directory inside (which left me with only 1 option to choose from within the Import menu).

                .....

                Those are the only three differences I could find. And reproducing all of those conditions hasn't given me any extra measures of success.

                Comment


                • #23
                  None of those things you mentioned is what the problem is. Right now there is a bug using the .php3 extensions, and that bug effects every extension except for .php right now...

                  Comment


                  • #24
                    @Cary: I just deleted the php3 installations of both the bulletin board and the Impex files and replaced them with the php extentions.

                    In order to check my previous work, I simply copied over my php3 configuration files to the new installation and changed their extentions to "php". And, now it works. I haven't done a full import yet, but I'm no longer stuck where I was stuck before (I actually get a list of things to do, each with a "Start Module" button (the first being the one used to set the path).

                    So, apparently you were right - it seems that all of this has resulted from buggy software.

                    @Jerry: I'd still prefer to use a php3 bulletin board and, somehow, you managed an import with it. Can you share how you did it, please? Perhaps you merely upladed the "ubb_classic" directory from a "php" package to my "systems" folder?

                    Thanks, both of you.

                    --Jeff

                    Comment


                    • #25
                      I'm not too sure why you are bolding my name and claiming that I have done things that I haven't, I didn't touch your config file or do a complete import for you, I ran the modules to ensure that they would run after I configured your impex set up. Doing a full import takes a bit of work due to the nature of the source data, I only ensured that it would run.

                      From what I can tell here you have over written the scripts again after reinstalling.

                      Jerry uploaded a filed called ImpExConfig.php3.
                      I did no such thing, I edited index.php3 and ImpExDisplay.php3 to run with the php3 extensions.

                      But I think I'll leave it as php3 until Jerry has another chance to chime in.
                      I will when I return to work, though I'm in the middle of no where at the moment, visiting my brother for my nephews birthday.

                      So, apparently you were right - it seems that all of this has resulted from buggy software.
                      Which I fixed and then was over written.

                      I'd still prefer to use a php3 bulletin board .
                      You can, impex is separate there isn't any dependency, you can even put it in a separate dir and browse to it directly.

                      Though it would appear that you are back on track now, though if not I'll set it up again.
                      Last edited by Jerry; Sun 2 Jan '05, 6:44am.
                      I wrote ImpEx.

                      Blog | Me

                      Comment


                      • #26
                        Ah.

                        That explains it, then.

                        Moving on: is there a FAQ for common problems, somewhere? For example, I've imported the threads, the users, everything, updated the counters, done all of the things that was on the "after the import" list, but I've got weird problems which weren't mentioned. Consider three different scenerios:

                        1) A user, which was created using the vBulletin software to administer it, can browse the forums and read the threads (as expected.)

                        2) A visitor who is not logged in to the forums may browse the forums and read the threads (as expected).

                        3) But once that visitor logs in with the username of anyone who was imported from the UBB Classic boards (administrator, moderator, ordinary user), he can no longer browse the forums or read the threads. Instead he gets a message saying that he doesn't have permission to access the page.

                        It seems very odd to me that a visitor would be able to browse, but a(n imported) registered member would not. And I can't find anything in the menus to use to mass change the permissions of all of the imported users. And the forum permissions seem already set to let everyone browse them.

                        However, this site has been down all day and I've not had access to the manual. I'm going to bed now, and I'll search the manual tomorrow, but any help would be appreciated.

                        Thanks!

                        Comment


                        • #27
                          This will be the usergroups settings, either the groups that the users are in don't have the correct permissions or the users are in the wrong groups.

                          Either move the users into the correct groups or setup the groups they are in.

                          Also, check the permissions and settings of the created forums, as impex creates them with default settings and dosn't import permissions etc.
                          I wrote ImpEx.

                          Blog | Me

                          Comment

                          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                          Working...
                          X