Announcement

Collapse
No announcement yet.

How to IMPORT SMF posts attachments?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to IMPORT SMF posts attachments?

    Hello,

    I would like to migrate my SMF RC2 forum to my new vB owned license, however. I would like some tips on what to do.

    I've currently: 1) SMF is installed in web root /public_html/ and I've uploaded all the files of vB that I uncompressed (upload) into /public_html/vB/ now, I need to import all atachments and all MySQL Data.

    What do I need to do in order to accomplish this? I can't copy SMF over to vB there's a risk of erasing some important vB file, can I just leave attachments dir or something and move it to the vB to get imported?

    Thanks

  • #2
    You don't need to move or copy SMF any where, just download impex (the importer) from the members area and run it.

    Details and directions are here :

    ImpEx manual
    HOWTO
    I wrote ImpEx.

    Blog | Me

    Comment


    • #3
      How to IMPORT SMF posts attachments?

      I'm in the process of migrating to vB, I have a test board and I haven't been able to import the posts attachments successfuly.

      Any help is appreciated.

      Thanks,
      Francisco

      Comment


      • #4
        Originally posted by Jerry
        You don't need to move or copy SMF any where, just download impex (the importer) from the members area and run it.

        Details and directions are here :

        ImpEx manual
        HOWTO
        Thanks for the reply.

        I have executed the script, and worked fine. However, two things:

        1) Attachments are not being imported.
        2) My Admin username is "francisco" and on SMF it is also "francisco" when it got imported all my posts on SMF wheren't on my vB Account (ID 1) but on ID2 as imported francisco

        How can I deal with this? I'm going to re-do it.

        Comment


        • #5
          1) Attachments are not being imported.
          The importer dosn't currently import attachments, that is a module I will have to add, though I've never had a board with the attachments for test data.

          2) My Admin username is "francisco" and on SMF it is also "francisco" when it got imported all my posts on SMF wheren't on my vB Account (ID 1) but on ID2 as imported francisco
          That is correct, the ID2 users is the imported one and the one that all the posts should be linked to. You can merge the users during or after the import if you want to.
          I wrote ImpEx.

          Blog | Me

          Comment


          • #6
            Great...

            So, about the Attachments, would they have to be re-posted?

            Comment


            • #7
              I am just testing an attachment module for SMF at the moment, I'll post back in a min or two.
              I wrote ImpEx.

              Blog | Me

              Comment


              • #8
                I've added the import attachment module to SMF now.

                You'll need to clean out the imported data (use the links at the top of the impex page) and the session then re-upload the smf folder from version 1.45.
                I wrote ImpEx.

                Blog | Me

                Comment


                • #9
                  Originally posted by Jerry
                  I've added the import attachment module to SMF now.

                  You'll need to clean out the imported data (use the links at the top of the impex page) and the session then re-upload the smf folder from version 1.45.
                  Sure, do you believe you could also fix a glich too?

                  On the temp forum I'm testing: Here

                  It says:

                  [quote author=Bryan G link=topic=82.msg187#msg187 date=1100820573]
                  [quote author=Francisco link=topic=82.msg186#msg186 date=1100820123]
                  I've Re-installed Apache and PHP, let me know if this "downtime" happends again to see for an another possible solution.

                  Thank you.
                  [/quote]

                  Could you fix that so it can also import SMF Quotes?

                  Thanks for the great support!

                  Comment


                  • #10
                    Also, Avatars are not being imported too...

                    Comment


                    • #11
                      [ quote ] is done.

                      Avatars, I would need a test board and data with avatars dir because of diffrent types there can be I would have to test it.
                      I wrote ImpEx.

                      Blog | Me

                      Comment


                      • #12
                        Originally posted by Jerry
                        [ quote ] is done.

                        Avatars, I would need a test board and data with avatars dir because of diffrent types there can be I would have to test it.
                        I can provide it, my AIM is navigatorishelp

                        Comment


                        • #13
                          Error

                          Database error in vBulletin:ImpEx Source 3.0.3:
                          Invalid SQL:
                          SELECT * FROM smf_smileys
                          ORDER BY ID_SMILEY
                          LIMIT 0,
                          mysql error: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 3
                          mysql error number: 1064
                          Date: Tuesday 14th of December 2004 01:49:40 PM
                          Script: http://www.navigatoris.org/vB/impex/index.php
                          Referer: http://www.navigatoris.org/vB/impex/index.php
                          Username: Francisco
                          IP Address: *******

                          Comment


                          • #14
                            what did you set the per page to for the smilies ?
                            I wrote ImpEx.

                            Blog | Me

                            Comment


                            • #15
                              Originally posted by Jerry
                              what did you set the per page to for the smilies ?
                              I don't want SMF crappy smilies (didn't used that)

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X