Announcement

Collapse
No announcement yet.

web wiz import: Error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    In the vBulletin Admin CP, click on vBulletin Options and open the Server Settings and Optimization Options section and turn on the Public phpinfo() Display Enabled setting. Then provide the URL to your forums. This may help us troubleshoot this problem.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #17
      the problem with vbulletin

      Allow me to repeat myself.
      PHP for windows comes as BINARY (you cannot compile it)
      we cannot compile the PHP on shared server (there are too many websites on it, and it might cause downtime to them)

      it is weird for me that we need to change the configuration of the server for a forum and not vise versa.

      furturemore, the PHP (binary) for windows (as I belive) should come with support for mssql.

      as I see it there are 3 possible solutions.
      a. using the windows copy to import to the mysql that sits on the linux (which is doesn't work at the moment) or maybe replacing the mssql_connect with ODBC.

      b. allow you to do the import (which will take you less then writing a reply if you have this php compiled with the mssql support)

      c. giving up using the VBulletin (before starting to use it)

      Please advice.
      פורום, פורומים, קהילות - דצ'ו

      Comment


      • #18
        Can you please do what I suggested in post #16 so we can look at your PHP configuration info?
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #19
          You can compile php for windows, but windows lacks a standard compiler unlike most nix systems do, so they provide a binary. PHP can be run one of several ways, CGI Fast CGI, an apache module and an ISAPI filter, if you are on windows with IIS it needs to be run as CGI fast CGI or ISAPI, the bets for the job is ISAPI.

          However in the windows configuration you can load and unload modules abit easier, while php does not come bundled with mssql support i can be eabled in php.ini for windows by uncommenting the line and adding the libs where approaite.

          This is an issue with the hosts configuration of php and not vBulletin, vBulletin will run in the enviroment as it does not need mssql support 99% of the time except in the importer.

          Comment


          • #20
            so how about showing some grace?

            and assist us in the import stage, by executing the IMP from one of your servers?

            do note: I am the host provider, and I can't compile php on a live server
            פורום, פורומים, קהילות - דצ'ו

            Comment


            • #21
              However you can go and uncomment the mssql.dll in php.ini and restart IIS or apache

              Comment


              • #22
                and how will that help?

                and how will that help?
                פורום, פורומים, קהילות - דצ'ו

                Comment


                • #23
                  In windows you can uncomment the items in php.ini for loading moduals, and then once you restart the webserver, php will now have access to said module

                  Comment


                  • #24
                    Thanks Jerry!
                    The importer works great!

                    For those of us without MS Sql support activated in PHP.
                    Goto:
                    http://phprpms.sourceforge.net/mssql
                    Contains paths to RHEL and Fedora RPMs that will activate mssql without recompiling PHP.

                    for RHEL 3 installs

                    freetds-0.62.4-1.i386.rpm
                    php-mssql-4.3.2-14.ent.1.i386.rpm

                    Install the 2 RPMs

                    check your server for mssql.so
                    Probably in the /usr/lib/php4

                    edit your /usr/local/lib/php.ini
                    add the following line :
                    extension=mssql.so

                    make sure you also point
                    extension_dir = /usr/lib/php4


                    Restart Apache.

                    Your golden!

                    Comment


                    • #25
                      Originally posted by dacho
                      and how will that help?
                      Why don't you ask your host to uncomment the php_mssql.dll extension in the php.ini.

                      Simple

                      Comment


                      • #26
                        10x

                        The his poor me to thank and congratulate your you on your courtesy.

                        I wasn't able to do this, without your courteous help all the respect and thousands of softly theron

                        confess you fragrant and in the name every the friends of my forum.

                        David E. & all of members forum
                        פורום, פורומים, קהילות - דצ'ו

                        Comment


                        • #27
                          Thanks
                          I wrote ImpEx.

                          Blog | Me

                          Comment

                          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                          Working...
                          X