Announcement

Collapse
No announcement yet.

Error while trying to import users from XMB

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error while trying to import users from XMB

    I'm trying to import users from XMB and I keep getting this error:
    Invalid SQL:
    SELECT * FROM members
    ORDER BY uid
    LIMIT 0,500
    mysql error: Table 'jenny_board.members' doesn't exist
    I HAVE set the table prefix for the source tables, but it doesn't seem to detect it

  • #2
    Anyone?

    Comment


    • #3
      Does your XMB database use table prefixes? As the error states, the 'members' table does not exist in database 'jenny_board'.
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #4
        Originally posted by Steve Machol
        Does your XMB database use table prefixes? As the error states, the 'members' table does not exist in database 'jenny_board'.
        Yes, they have the prefix xmb2_ and i HAVE set that in the config file, but it doesn't seem to detect it or something

        Here's my config file:
        [ Target Database ]
        ; The following settings allow ImpEx to connect to the vBulletin 3
        ; database into which you will be importing data.
        targetdatabasetype = mysql
        targetserver = localhost
        targetuser = jenny_general
        targetpassword = *******
        targetdatabase = jenny_board
        targettableprefix = vb_
        [ Source Database ]
        ; If the system that is being imported from uses a database,
        ; enter the details for it here and set 'sourceexists' to TRUE.
        ; If the source data is NOT stored in a database, set 'sourceexists' to FALSE
        sourceexists = true
        ; mysql OR mssql
        sourcedatabasetype = mysql
        sourceserver = localhost
        sourceuser = jenny_general
        sourcepassword = *******
        sourcedatabase = jenny_board
        sourcetableprefix = xmb2_

        Comment


        • #5
          When did you download Impex? You could try redownloading it and reupload all fresh files.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            I've checked the XMB importer and the sourcetableprefix is in that bit of the code.
            I wrote ImpEx.

            Blog | Me

            Comment


            • #7
              I did as Steve said, and it worked. Thanks for the help!

              Comment


              • #8
                Coolio
                I wrote ImpEx.

                Blog | Me

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X