Announcement

Collapse
No announcement yet.

Error importing vb3.03 from dcforum+ 1.26

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error importing vb3.03 from dcforum+ 1.26

    I get this error when importing my threads:
    =========================================================
    Database error in vBulletin:ImpEx Source 3.0.3:
    Invalid SQL:
    SELECT * FROM 1_mesg
    WHERE top_id = 0 AND parent_id = 0
    ORDER BY id
    LIMIT 0,500
    mysql error: Table 'dcforum.1_mesg' doesn't exist

    mysql error number: 1146

    Date: Tuesday 06th of July 2004 02:40:25 PM
    Script: http://www.blincmagazine.com/forum_new/impex/index.php
    Referer: http://www.blincmagazine.com/forum_new/impex/index.php
    Username: mknutson
    IP Address: 159.37.7.119



    I get this error when I ran the "Check and update database" action:
    ========================================================================================== =============================
    Import / Export

    Altering tables
    ImpEx will now Alter the tables in the vB database to include import id numbers.

    This is needed during the import process for maintaining refrences between the tables during an import.If you have large tables (i.e. lots of posts) this can take some time.

    They will also be left after the import if you need to link back to the origional DCFm userid.


    moderator - importmoderatorid OK
    usergroup - importusergroupid OK
    ranks - importrankid OK
    poll - importpollid OK
    forum - importforumid OK
    forum - importcategoryid OK
    user - importuserid OK
    style - importstyleid OK
    thread - importthreadid OK
    post - importthreadid OK
    thread - importforumid OK
    smilie - importsmilieid OK
    pmtext - importpmid OK
    post - importpostid OK
    10_mesg NOT found or a non standard table.
    12_mesg NOT found or a non standard table.
    13_mesg NOT found or a non standard table.
    15_mesg NOT found or a non standard table.
    18_mesg NOT found or a non standard table.
    19_mesg NOT found or a non standard table.
    20_mesg NOT found or a non standard table.
    22_mesg NOT found or a non standard table.
    26_mesg NOT found or a non standard table.
    27_mesg NOT found or a non standard table.
    6_mesg NOT found or a non standard table.
    7_mesg NOT found or a non standard table.
    8_mesg NOT found or a non standard table.
    dcannouncement found.
    dcbadip found.
    dcbookmark found.
    dcbuddy found.
    dcevent found.
    dceventrepeat found.
    dcforum found.
    dcforumsub found.
    dcforumtype found.
    dcgroup found.
    dcinbox found.
    dcinboxlog found.
    dcip found.
    dclog found.
    dcmoderator found.
    dcnotice found.
    dcpflist found.
    dcpollchoices found.
    dcpollvotes found.
    dcsearchcache found.
    dcsearchparam found.
    dcsecurity found.
    dcsession found.
    dcsetup found.
    dctask found.
    dctopicrating found.
    dctopicsub found.
    dcupload found.
    dcuser found.
    dcuserrating found.
    dcusertimemark found.


    vBulletin v3.0.3, Copyright ©2000-2004, Jelsoft Enterprises Ltd.


    ==========================================================
    Those tables that are erroring are my thread tables for the forums I have.
    Thank You...Mick Knutson

    BLiNC Magazine Forums: "Everything you ever wanted to know about BASE-Jumping, but didn't know whom to ask."


  • #2
    Got your database now, having a look at why its starting at 1 and not 10.
    I wrote ImpEx.

    Blog | Me

    Comment


    • #3
      Great. I will delete the dump files then.
      Let me know what I can do to help.

      I am available from 9-5 PST to help test it on my server also.
      Thank You...Mick Knutson

      BLiNC Magazine Forums: "Everything you ever wanted to know about BASE-Jumping, but didn't know whom to ask."

      Comment


      • #4
        From what I can see there are some tables missing, or the forums have been moved or deleted in the past.

        Either way I've put in a table check and updated impex to handle it.

        I've updated the download as well so you can re-run it.

        Note either delete the default "Main Forum" before doing the import or change the Parent Forum of the top forums/categories that are imported to "No one" so they appear as they should and aren't nested under the default "Main Forum".
        I wrote ImpEx.

        Blog | Me

        Comment


        • #5
          Originally posted by Jerry
          From what I can see there are some tables missing, or the forums have been moved or deleted in the past.
          Yes, I have been doing some houscleaning and deleted some forums.

          Originally posted by Jerry
          Either way I've put in a table check and updated impex to handle it.
          Great.

          Originally posted by Jerry
          I've updated the download as well so you can re-run it.
          I will download it right away.

          Originally posted by Jerry
          Note either delete the default "Main Forum" before doing the import or change the Parent Forum of the top forums/categories that are imported to "No one" so they appear as they should and aren't nested under the default "Main Forum".
          I really donw't understand this. Do you mean the name of my DCForum forum? Or something on VB?
          Thank You...Mick Knutson

          BLiNC Magazine Forums: "Everything you ever wanted to know about BASE-Jumping, but didn't know whom to ask."

          Comment


          • #6
            I just tried to do the import again, and I got the same error just now. No difference.
            Thank You...Mick Knutson

            BLiNC Magazine Forums: "Everything you ever wanted to know about BASE-Jumping, but didn't know whom to ask."

            Comment


            • #7
              I did the import with you database and the current version of impex in the members area.

              I really donw't understand this. Do you mean the name of my DCForum forum? Or something on VB?
              A default vB3 install has a Forum called "Main Forum" that is the one I was talking about.

              I would suggest a clean vB3 install to import into to ensure there isn't any conflict with importing into an already imported database.
              I wrote ImpEx.

              Blog | Me

              Comment


              • #8
                I changed the "Main FOrum" when I first installed VB.

                Re-Installing VB would require me to pay my graphics designer to re-create the template for my forum. That would cost me greatly!

                I also just downloaded the tar.gz version from the member area and re-installed it again.

                I am getting this error when I first try to update my tables:

                ===================================================================
                Altering tables
                ImpEx will now Alter the tables in the vB database to include import id numbers.
                This is needed during the import process for maintaining refrences between the tables during an import.If you have large tables (i.e. lots of posts) this can take some time.
                They will also be left after the import if you need to link back to the origional DCFm userid.

                moderator - importmoderatorid OK
                usergroup - importusergroupid OK
                ranks - importrankid OK
                poll - importpollid OK
                forum - importforumid OK
                forum - importcategoryid OK
                user - importuserid OK
                style - importstyleid OK
                thread - importthreadid OK
                post - importthreadid OK
                thread - importforumid OK
                smilie - importsmilieid OK
                pmtext - importpmid OK
                post - importpostid OK
                10_mesg NOT found or a non standard table.
                12_mesg NOT found or a non standard table.
                13_mesg NOT found or a non standard table.
                15_mesg NOT found or a non standard table.
                18_mesg NOT found or a non standard table.
                19_mesg NOT found or a non standard table.
                20_mesg NOT found or a non standard table.
                22_mesg NOT found or a non standard table.
                26_mesg NOT found or a non standard table.
                27_mesg NOT found or a non standard table.
                6_mesg NOT found or a non standard table.
                7_mesg NOT found or a non standard table.
                8_mesg NOT found or a non standard table.
                dcannouncement found.
                dcbadip found.
                dcbookmark found.
                dcbuddy found.
                dcevent found.
                dceventrepeat found.
                dcforum found.
                dcforumsub found.
                dcforumtype found.
                dcgroup found.
                dcinbox found.
                dcinboxlog found.
                dcip found.
                dclog found.
                dcmoderator found.
                dcnotice found.
                dcpflist found.
                dcpollchoices found.
                dcpollvotes found.
                dcsearchcache found.
                dcsearchparam found.
                dcsecurity found.
                dcsession found.
                dcsetup found.
                dctask found.
                dctopicrating found.
                dctopicsub found.
                dcupload found.
                dcuser found.
                dcuserrating found.
                dcusertimemark found.

                =================================================================

                Why is 10_mesg a non-standard table?
                Thank You...Mick Knutson

                BLiNC Magazine Forums: "Everything you ever wanted to know about BASE-Jumping, but didn't know whom to ask."

                Comment


                • #9
                  Its not that isn't a non-standard table, its just not one of the default tables.

                  You don't have to destroy the templates, in the status thread there is a SQL file that will clear up all the importer data here :

                  http://www.vbulletin.com/forum/showp...20&postcount=7
                  I wrote ImpEx.

                  Blog | Me

                  Comment


                  • #10
                    OK. I ran that sql, then I cleared the impex session as per another thread I saw. Then I re-ran the import, and the check DB gave me the same error.
                    Is this an error I can ignore, then move to the other steps anyways? Kind-of wierd that I am dead at step 1. ;-)
                    Thank You...Mick Knutson

                    BLiNC Magazine Forums: "Everything you ever wanted to know about BASE-Jumping, but didn't know whom to ask."

                    Comment


                    • #11
                      OK, I tried the import even with the errors on step 1.
                      Everything seemed to work just fine and I the importer says it imported all my threads and postings etc..
                      But, when I go to my forum, I do not see any threads at all. I see zero.

                      What am I missing? Is there a re-build function or something that I need to run to add the threads?



                      Originally posted by Jerry
                      Its not that isn't a non-standard table, its just not one of the default tables.

                      You don't have to destroy the templates, in the status thread there is a SQL file that will clear up all the importer data here :

                      http://www.vbulletin.com/forum/showp...20&postcount=7
                      Thank You...Mick Knutson

                      BLiNC Magazine Forums: "Everything you ever wanted to know about BASE-Jumping, but didn't know whom to ask."

                      Comment


                      • #12
                        ok, I seemed to have gotten it!
                        The script made 3 versions of my forums. THe last one had all the data in it.
                        But in the main conference view, there are still no numbers ever though there are all my postings.

                        But, I have a question now:
                        How do I move VB from www.blincmagazine.com/forum_new/ to www.blincmagazine.com/forum/ as painless as possible?

                        Does the VB script care about the DIR name?
                        Thank You...Mick Knutson

                        BLiNC Magazine Forums: "Everything you ever wanted to know about BASE-Jumping, but didn't know whom to ask."

                        Comment


                        • #13
                          I have been playing around with the new forum. And ALL the dates are Dec 31st 1969 for the "Last Post" date on the thread listing. But the date in the posting itself seems to be OK.
                          Also, all my threads are in reversed order in the listing page.

                          So all my new threads are actually the old ones. Not the option to view oldest->newest. But they are really older in order.

                          Not only that, all my users have actually joined in 1969 as well. Some seem to have the correct dates, but most do not.
                          Last edited by mickknutson; Thu 8 Jul '04, 12:47pm.
                          Thank You...Mick Knutson

                          BLiNC Magazine Forums: "Everything you ever wanted to know about BASE-Jumping, but didn't know whom to ask."

                          Comment


                          • #14
                            I also notice that all the numbers on the main forum listing page shows zero. I then posted into one of my forums, and the number just started incrementing from zero. So somewhere the numbers where lsot for the main forum listing.
                            Thank You...Mick Knutson

                            BLiNC Magazine Forums: "Everything you ever wanted to know about BASE-Jumping, but didn't know whom to ask."

                            Comment


                            • #15
                              You need to update your counters after importing the data.

                              Admin CP -> Imports & Maintenance -> Update Counters
                              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                              Change CKEditor Colors to Match Style (for 4.1.4 and above)

                              Steve Machol Photography


                              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X