Announcement

Collapse
No announcement yet.

Can't get past first step of the Importer

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't get past first step of the Importer

    I am doing a clean, brand new install with no mods, tweaks, or existing conditions.

    After installing vbulletin, I edited the ImpExConfig.php file to reflect both the source database and the destination database.

    In a nutshell, here is what has passed so far:

    1. When I tried to run the import script from the vb control panel, I got this error message:

    Database error in vBulletin:ImpEx Target 3.0.1:

    Invalid SQL: SELECT title, data FROM dale_datastore WHERE title = 'ImpExSession'
    mysql error: Table 'xxx_nnnn.xxx_datastore' doesn't exist


    mysql error number: 1146

    2. Steve referred me to fixoptions.php

    3. I ran that, and got this error message:

    Rebuilding options
    Fatal error: Call to undefined function: build_datastore() in
    /home/xxx/public_html/xxx/includes/adminfunctions.php on line 1785

    Now what can I do?
    Last edited by doubleclick; Tue 15th Jun '04, 12:39pm.

  • #2
    Are you sure you are running this from your forums directory as Freddie psoted? This function is definitely in the default adminfunctions.php file (as well as functions.php) so you may need to reupload the original files.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      yes, I'm running it from that directory.

      I'll replace adminfunctions.php and functions.php as you suggest and see what happens.

      Comment


      • #4
        I replaced them with the original files, and got the same error:

        Rebuilding options
        Fatal error: Call to undefined function: build_datastore() in
        /home/xxx/public_html/xxx/includes/adminfunctions.php on line 1785


        could this be a permission problem?

        Comment


        • #5
          I found a clue that probably explains this problem. However, I don't know what to do with it.

          My forum says it is 7:45 Mountain Time
          My admin control panel says it is Central Time

          Just to take this a step further, I just reset the time in the admin center to Bombay time, and my forum still says it is Mountain time.

          I think this indicates a larger problem that when fixed will probably take care of my original error.

          Comment


          • #6
            Finally - success

            It is always such mixed emotions fixing one of these problems. On one hand, it's great that after hours beating your head on the desk you finally have a solution. On the other hand, when you find the problem it is usually so tiny and simple that you end up beating your head against the desk anyway.

            The problem? a mis-typed table prefix in the ImpExConfig.php file.

            Sheesh.

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X