Announcement

Collapse
No announcement yet.

Some HTML Encoded after Conversion

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Some HTML Encoded after Conversion

    Hi there,

    I've been running vBulletin 3.01 for about a week now. Overall the new system has been running great but we've noticed a few problems with some of the imported threads brought over from Ikonboard 3.02a. I used the Impex system to import directly into vB.

    Here's an example thread with the problem: http://www.volvoxc.com/forums/showthread.php?t=3709

    I tried changing the forum to allow html but this doesn't seem to have fixed the problem.

    Any ideas here?

    Thanks!

  • #2
    Build a little script to just go through each post one by one unencoding, probably something written somewhere - wouldnt take much to write one iether

    just pull it,

    pull =unencode(pull)

    update postid with pull

    Comment


    • #3
      urldecode actually

      Comment


      • #4
        Try this - Uncomment the three lines are if you run it once on your server to make sure it pulls something and looks like what you want done. - when their is no more encoded text, it should stop (the delete is the cache copy, so it forces it to recache after its fixed)


        PHP Code:
        <?
        $connection 
        mysql_connect("localhost","USERNAME","PASSWORD") or die ("Cannot connect to server.");
        $db mysql_select_db("DATABASE"$connection) or die ("Could not select database.");
        $sql "SELECT * FROM post WHERE pagetext LIKE '%&lt;%' ORDER BY postid DESC LIMIT 1";
        $sql_result mysql_query($sql$connection) or die ("Could not execute $sql.");
        while (
        $row mysql_fetch_array($sql_result)) {
        $postid $row["postid"];
        $pagetext urldecode($row["pagetext"]);
        $pagetext=addslashes($pagetext);
        $sql2 "DELETE FROM `post_parsed` WHERE `postid` = $postid LIMIT 1";
        //$sql2_result = mysql_query($sql2, $connection) or die ("Could not execute $sql2.");
        $sql3 "UPDATE post SET pagetext=\"$pagetext\" WHERE postid=$postid;";
        //$sql3_result = mysql_query($sql3, $connection) or die ("Could not execute $sql3.");
        echo $sql2;
        echo 
        "<hr>";
        echo 
        $sql3;
        //echo "<script>window.open('".$PHP_SELF."','_self');</script>";
        }
        ?>



        Originally posted by servoweb
        Hi there,

        I've been running vBulletin 3.01 for about a week now. Overall the new system has been running great but we've noticed a few problems with some of the imported threads brought over from Ikonboard 3.02a. I used the Impex system to import directly into vB.

        Here's an example thread with the problem: http://www.volvoxc.com/forums/showthread.php?t=3709

        I tried changing the forum to allow html but this doesn't seem to have fixed the problem.

        Any ideas here?

        Thanks!

        Comment


        • #5
          thanks very much for the reply Zecherieh, when I get a chance I'll give 'er a try and will post back with the results.

          Cheers!

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X