Announcement

Collapse
No announcement yet.

Couple of issues with vB3.0.1 --> vB3.0.1

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Couple of issues with vB3.0.1 --> vB3.0.1

    Hi folks,

    I'm currently attempting to merge an old db with my testvb copy of my live board. The old board was running vB2.x so I upgraded to vB3.0.1 with only 1 glitch (the settings had a problem but as far as I'm aware they're not important when I'm only interested in members, threads and forums).

    Upon importing the newly updated old db I reached the user group stage and was hit with this error:
    Code:
    Database error in vBulletin:ImpEx Target 3.0.1:
    Invalid SQL: 
    	 INSERT INTO usergroup
    	 (
    	 importusergroupid, title, description,
    	 usertitle, passwordexpires, passwordhistory,
    	 pmquota, pmsendmax, pmforwardmax,
    	 opentag, closetag, canoverride,
    	 ispublicgroup, forumpermissions, pmpermissions,
    	 calendarpermissions, wolpermissions, adminpermissions,
    	 genericpermissions, genericoptions, attachlimit,
    	 avatarmaxwidth, avatarmaxheight, avatarmaxsize,
    	 profilepicmaxwidth, profilepicmaxheight, profilepicmaxsize
    	 )
    	 VALUES
    	 (
    	 '1',
    	 'Unregistered / Not Logged In',
    	 '',
    	 'Guest',
    	 '0',
    	 '0',
    	 '0',
    	 '0',
    	 '',
    	 '',
    	 '',
    	 '0',
    	 '0',
    	 '3',
    	 '0',
    	 '17',
    	 '0',
    	 '0',
    	 '64',
    	 '8',
    	 '0',
    	 '75',
    	 '75',
    	 '6000',
    	 '100',
    	 '100',
    	 '100000'
    	 )
     
    mysql error: Unknown column 'pmforwardmax' in 'field list'
    mysql error number: 1054
    Date: Saturday 29th of May 2004 03:01:03 PM
    Script: [url="http://www.domain.com/testvb/impex/index.php"]http://www.domain.com/testvb/impex/index.php[/url]
    Referer: [url="http://www.domain.com/testvb/admincp/index.php?do=nav"]http://www.domain.com/testvb/admincp/index.php?do=nav[/url]
    Username: 662C
    IP Address: x.x.x.x
    So I find myself editting ImpExDatabase.php to change "pmforwardmax" to "maxforwardpm" and match my testvb database.

    Another thing I've noticed (after I updated the counters, didn't check this before hand) is that the attachment thumbnails aren't appearing for the old posts. Any idea why this might be?

    Also, the associated members lost their current avatars and their join dates were left with the more recent values, is there any way I can have them keep their more recent avatars but use their join date from the old database?

    Any help would be greatly appreciated.


    Cheers,
    Robert
    Visit NoizPollution.com // Your Music Source

    Do not PM or email me for support, you will not receive a response. Please post all requests for support in the main vBulletin forums or via the support system in the main members section of the site.

  • #2
    You are missing the pmforwardmax field in the usergroup table. This is a standard field for that table. This was probably from a bad upgrade. If this was the only thing wrong with that upgrade, you may be able to fix it by manually adding this field to the usergroup table:

    Field: pmforwardmax
    Type: smallint
    Length/Values: 5
    Attributes: Unsigned
    NULL: not null
    Default: 5
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Hi Steve,

      When the error came up I checked the db (testvb, not the upgraded db) I found maxforwardpm, at which point the import worked. I don't know what could be going on there.

      Any idea with the attachment, avatar and join date issues?


      Cheers,
      Robert
      Visit NoizPollution.com // Your Music Source

      Do not PM or email me for support, you will not receive a response. Please post all requests for support in the main vBulletin forums or via the support system in the main members section of the site.

      Comment


      • #4
        You only posted one error. However since it's clear the upgrade did not run correctly (as per the missing field) it's entirely possible that other parts of the upgrade were not completed successfully either.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Is the field "maxforwardpm" meant to exist?
          Visit NoizPollution.com // Your Music Source

          Do not PM or email me for support, you will not receive a response. Please post all requests for support in the main vBulletin forums or via the support system in the main members section of the site.

          Comment


          • #6
            Originally posted by 662C
            Is the field "maxforwardpm" meant to exist?
            Yes, it is- at least pmforwardmax is:

            Originally posted by Steve Machol
            You are missing the pmforwardmax field in the usergroup table. This is a standard field for that table.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              OK I'll redo the process from the ground up with that change made before I import the old db.

              Besides that, after checking further it seems the newly intergrated db doesn't know about the old attachments, can you think of any reason which may've caused this to happen?
              Visit NoizPollution.com // Your Music Source

              Do not PM or email me for support, you will not receive a response. Please post all requests for support in the main vBulletin forums or via the support system in the main members section of the site.

              Comment


              • #8
                Originally posted by 662C
                OK I'll redo the process from the ground up with that change made before I import the old db.

                Besides that, after checking further it seems the newly intergrated db doesn't know about the old attachments, can you think of any reason which may've caused this to happen?
                go to admincp
                there is an 'update counters' option in the import & maintenance. go there.
                do a 'rebuild attachment thumbnails'

                Comment


                • #9
                  Hi ogetbilo,

                  I only noticed the issue after running that the first time.


                  Cheers,
                  Robert
                  Visit NoizPollution.com // Your Music Source

                  Do not PM or email me for support, you will not receive a response. Please post all requests for support in the main vBulletin forums or via the support system in the main members section of the site.

                  Comment


                  • #10
                    Is it normal for associated users avatars to be replaced by their old avatars during the import?


                    Cheers,
                    Robert
                    Visit NoizPollution.com // Your Music Source

                    Do not PM or email me for support, you will not receive a response. Please post all requests for support in the main vBulletin forums or via the support system in the main members section of the site.

                    Comment


                    • #11
                      Originally posted by 662C
                      Is it normal for associated users avatars to be replaced by their old avatars during the import?


                      Cheers,
                      Robert
                      Anybody?
                      Visit NoizPollution.com // Your Music Source

                      Do not PM or email me for support, you will not receive a response. Please post all requests for support in the main vBulletin forums or via the support system in the main members section of the site.

                      Comment


                      • #12
                        Jerry will have to comment on what is normal or not since he wrote it.
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment


                        • #13
                          Originally posted by 662C
                          Is it normal for associated users avatars to be replaced by their old avatars during the import?


                          Cheers,
                          Robert
                          If user A is the origional user and user B is the user being associated with user A during the import.

                          The resulting user will have which ever avatar was linked with user A.
                          I wrote ImpEx.

                          Blog | Me

                          Comment


                          • #14
                            The original user being the user on the target database? If that's the case then there's either something wrong or it'll have been a problem with my board again. I'll give it another go. As far as the associated user join dates are concerned I'll just change the time stamps in phpmyadmin.

                            What's the current situation on attachments?


                            Cheers,
                            Robert
                            Visit NoizPollution.com // Your Music Source

                            Do not PM or email me for support, you will not receive a response. Please post all requests for support in the main vBulletin forums or via the support system in the main members section of the site.

                            Comment


                            • #15
                              Nothing on the attachment issue?
                              Visit NoizPollution.com // Your Music Source

                              Do not PM or email me for support, you will not receive a response. Please post all requests for support in the main vBulletin forums or via the support system in the main members section of the site.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X