Announcement

Collapse
No announcement yet.

Error - Import/Export

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    What I'm trying to figure out, is where is the source data.

    If its in a mysql database on a diffrent server 99.99% likely that the username and password that you have will only work for users/scripts on the localhost (i.e. on the same server that the database is on).

    If you are trying to connect to it from a remote host it will deny you access for security reasons (and as it should really).

    Best thing to do is do to the old server and get a mysqldump of the database, or get your last back up, then load that into the new database on the new server, then run the import again.
    I wrote ImpEx.

    Blog | Me

    Comment


    • #17
      Oh okay! We'll try that! Thank you so much!

      Comment


      • #18
        Actually both boards and databases are on the same server/host. The phpBB board we are trying to import is on the exact same server as the vB board I installed. Both with the same username and password for the databases.
        The #1 Parenting Message Board

        Comment


        • #19
          So in ImpExConfig.php, all the target and source details are the same ?
          I wrote ImpEx.

          Blog | Me

          Comment


          • #20
            Originally posted by erikajune
            Actually both boards and databases are on the same server/host. The phpBB board we are trying to import is on the exact same server as the vB board I installed. Both with the same username and password for the databases.
            Oopss...sorry for the mistake Jerry and Erika. My apologies! Yes, both boards and databases are still on the same server and host, with the exact same password (I misunderstood something Erika told me). Sorry about that!

            Comment


            • #21
              No probs, just trying to understand what is going on

              For it to die on a link its usally permissions or something like that.
              I wrote ImpEx.

              Blog | Me

              Comment


              • #22
                Originally posted by Jerry
                So in ImpExConfig.php, all the target and source details are the same ?
                Yes. The only thing that's different are the database names.

                Is this ever going to work?
                The #1 Parenting Message Board

                Comment


                • #23
                  Originally posted by erikajune
                  Yes. The only thing that's different are the database names.
                  And both databases are on the localhost, and you have tested the username and password to both databases separately and independently of impex ??

                  Impex must be in the correct place if you can select it via the admincp, browsing to it directly will give some strange side effects, so thats probally not it.

                  You started of with a false link error, and then "Warning: mysql_query():".

                  This dose seem to suggest something to do with the dB connection the config or permissions. What is the current error or hold up ?

                  Is this ever going to work?
                  Has done loads of times so far, just got to figure out what is going on and where the database connection is failing and why.
                  Last edited by Jerry; Wed 21 Apr '04, 3:40pm.
                  I wrote ImpEx.

                  Blog | Me

                  Comment


                  • #24
                    The databases work independantly because vB is up and running and so is phpBB right now except one is /boards and one is /forums. (www.onlinechrisitianparents.com)

                    I checked all 3 config files, the impex, phpBB config and vB config... all info is correct.

                    So what could it be then?
                    The #1 Parenting Message Board

                    Comment


                    • #25
                      Is it stopping at the inital page now and showing nothing or is it stopping at the mysql warning ?
                      I wrote ImpEx.

                      Blog | Me

                      Comment


                      • #26
                        Maybe you could post the complete error again?

                        And maybe you could also post your impex config file? (You can offcourse remove the passwords )

                        Comment

                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                        Working...
                        X