Announcement

Collapse
No announcement yet.

AdminCP "Buttons" not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • AdminCP "Buttons" not working

    Hello, I am hoping someone can help me. I have had a nightmare of a couple weeks.

    My host upgraded php which killed my vBulletin version 4.2.4. I have attempted upgrading to version 5 and even purchased a professional install and we have had so many problems, it's beyond comprehension. I still don't really have a working site.

    Anyway, I moved my old site to a new host that still had older versions of php. I am trying simply to get my site back. Everything with my 4.2.4 site seems to be back up EXCEPT for the admincp. None of the buttons are working. So like the buttons to drop down the menus, or the buttons to edit templates, etc. Does anyone know what the cause of this would be? Does my new host not support the javascript or something? I am kind of at a loss.

    Any direction would be appreciated. I know I will have to find a way to upgrade to v5 eventually but for now, if I could just get my site back online after weeks of downtime, that would be great.

  • #2
    Hosts don't really need to support the Javascript. This is executed on your local machine via the web browser. Make sure that Javascript is working on your machine. You can see this by looking at the network and console tabs in your browser's developer tools. The network tab will show access through the webserver. You want everything to be listed as "200" or "from cache." The console will list actual Javascript errors that are occurring.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API

    Comment


    • #3
      I have tried multiple browsers and multiple computers. It doesn't seem to be throwing off any browser errors. I am not sure what could be cauing this. Any other ideas?

      Comment


      • #4
        And what do the .js files say in the Network tab of your browser's developer tools? What is the http result? As I said above, it should be 200 or From Cache. Any other result is incorrect.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API

        Comment


        • #5
          I have attached the error messages.Click image for larger version

Name:	Capture.PNG
Views:	55
Size:	316.2 KB
ID:	4458890

          Comment


          • #6
            Here's another screenshot. This is what happens when I try to edit one of the style templates. A lot of errors.
            Attached Files

            Comment


            • #7
              It looks like Javascript isn't being downloaded and loaded by the browser. The download could be blocked by your hosting provider. Especially if they are security consciouse. The AdminCP uses YUI which has been deprecated by Yahoo since 2017. You would have to ask them if they are blocking any Javascript from download.

              Execution could be blocked by Browser Extensions or Antivirus. You would have to whitelist your site in those extensions and/or antivirus.
              Translations provided by Google.

              Wayne Luke
              The Rabid Badger - a vBulletin Cloud demonstration site.
              vBulletin 5 API

              Comment

              Related Topics

              Collapse

              Working...
              X