Announcement

Collapse
No announcement yet.

Register button not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Register button not working

    Hi

    On my test site I updated to 4.2.5 to see how things go, and all seems OK except for one issue..

    If I click on the "register" button I get the following message.. any idea what the issue may be? I have re-uploaded all the files and still the same..

    Click image for larger version  Name:	Capture.JPG Views:	0 Size:	14.5 KB ID:	4444751
    Attached Files
    Last edited by stuarttunstall; Wed 29 Jul '20, 11:39pm.

  • #2
    A 500 server error typically means something happened and the server doesn't know how to handle it. It could be a PHP Error. It could be a server configuration issue.

    First, make sure that you're not using a version of PHP higher than 7.1.33. If you are then you need to downgrade your PHP Version for vBulletin 4.2.5.

    If the version of PHP if within requirements, then check your httpd and PHP error logs to see if the 500 error if there are any fatal errors. Post those fatal errors here and we'll try to help.

    If you cannot downgrade your version of PHP, then you should upgrade to vBulletin 5.6.2 and use the "Classic" home page to make your site look similar to your vBulletin 4.X installation.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API - Full / Mobile
    Vote for your favorite feature requests and the bugs you want to see fixed.

    Comment


    • #3
      Thank you..

      Strange, the current live site is on the same server and the only difference is the vB version, 4.2.4 and 4.2.5, the live site works perfect. so I am not sure it is server related.

      Comment


      • #4
        A 500 error *is* a server error. There is no bug in the software that would cause this.

        Please advise what version of php the test site is running.
        MARK.B | vBULLETIN SUPPORT

        TalkNewsUK - My vBulletin 5.6.2 Demo
        AdminAmmo - My Cloud Demo

        Comment


        • #5
          It runs 5.6.40 which is exactly the same as my live site they are on the same server, software etc so no idea why one would work and one not..

          Unless, but I cannot think of anything that is different, the test site get changed first then the live site..

          Comment


          • #6
            Originally posted by stuarttunstall View Post
            It runs 5.6.40 which is exactly the same as my live site they are on the same server, software etc so no idea why one would work and one not..

            Unless, but I cannot think of anything that is different, the test site get changed first then the live site..
            If it’s a mirror of live, did you update the site URL so it’s pointing to the right one?
            MARK.B | vBULLETIN SUPPORT

            TalkNewsUK - My vBulletin 5.6.2 Demo
            AdminAmmo - My Cloud Demo

            Comment


            • #7
              it might not be server related. However your server is hiding the error message behind a 500 server error and until you go through your httpd and PHP error logs to find the error and report it to us, there is absolutely no way we can determine what the issue is. a 500 server error is the most generic error available. It isn't any more informative than a blank screen.
              Translations provided by Google.

              Wayne Luke
              The Rabid Badger - a vBulletin Cloud demonstration site.
              vBulletin 5 API - Full / Mobile
              Vote for your favorite feature requests and the bugs you want to see fixed.

              Comment


              • #8
                Thanks for the replies, I do appreciate it...

                I am just confused that the test site register button does not work and the live site does, both on same server with same specifications, the URL is correct, just checked that

                Really need to look at upgrading really... Will see if I can see anything in the logs and post here..

                STuart

                Comment


                • #9
                  I have sorted it with the help of the log....

                  I updated the test forum to the lasted version of my forum, 4.2.5, the main live site is on 4.2.4 I added a new plugin for recaptcha to work with recaptch v2 from vBulletin.org this works OK on the 4.2.4 version but not on the later one.. I have just uninstalled it from the test site and it all works again... The plugin must be incompatible with 4.2.5

                  30-Jul-2020 07:37:43 UTC] PHP Fatal error: Call to undefined method vB_HumanVerify_Abstract::vB_HumanVerify_Abstract() in /home/xxx/public_html/xxxx/forum/includes/class_humanverify_new_recaptcha.php on line 14


                  Thanks for all the advice, much appreciated...

                  One question what is the latest version of PHP, MySQL and Apache vb 4.2.4 can use?
                  Last edited by stuarttunstall; Fri 31 Jul '20, 9:59am.

                  Comment


                  • #10
                    IN older versions of PHP, the construct function in a classes had the same name as the class. PHP 7 deprecated this style of coding and requires the use of the __construct() function to do the same thing. If you change those calls to vB_HumanVerify_Abstract::__construct() then the code will probably work.

                    You may be able to use PHP 5.6.0 with vBulletin 4.2.4. vBulletin 4.2.5 can use up to PHP 7.1.
                    Translations provided by Google.

                    Wayne Luke
                    The Rabid Badger - a vBulletin Cloud demonstration site.
                    vBulletin 5 API - Full / Mobile
                    Vote for your favorite feature requests and the bugs you want to see fixed.

                    Comment


                    • #11
                      Thanks for the reply, i am using 5.6 with 4.2.4 and it works OK...

                      Now I know the issue I am not too bothered at the moment, it works on the current live site and I may upgrade to vb5 soon

                      Comment

                      Related Topics

                      Collapse

                      • Tormod
                        Error after uploaded files
                        by Tormod
                        I tried to run installation wizard after uploading Bulletin 5 Connect, but get this message:


                        Parse error: syntax error, unexpected '?' in /home/XXXX/public_html/includes/vb5/front...
                        Sat 25 Jul '20, 12:54pm
                      • aelalfey
                        Http error 500
                        by aelalfey
                        Hi,

                        I just updated my php version from 5.4.28 to php 5.6 and updated my apache from 2.2 to 2.4 and after that i tried to open my vbulletin v 5.1.10 and got this error "HTTP ERROR 500"....
                        Mon 19 Jun '17, 6:53pm
                      Working...
                      X