Announcement

Collapse
No announcement yet.

PHP Warning: Illegal offset type in 

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] PHP Warning: Illegal offset type in 

    Im getting this error from my we site (www.araphil.com) , It is on mentenace mode for now

    " PHP Warning: Illegal offset type in ..../includes/functions_navigation.php on line 124 "

    what does it mean ? how to solve?

    Thank you in advance
    Starts
    Tue 5th May '20
    Ends
    Wed 6th May '20

  • #2
    Could do with more info. Have you changed anything to make this happen? What version php are you running?

    Comment


    • #3
      We will need to know, as a minimum:

      1. What version of vBulletin this is
      2. What version of php is being run.

      The admincp front page should provide all of this information.
      MARK.B | vBULLETIN SUPPORT

      TalkNewsUK - My vBulletin 5.6.1 Demo
      AdminAmmo - My Cloud Demo

      Comment


      • #4
        Most common cause of this issue is running vBulletin 4.2.5 under PHP 7.2 or higher. That is not supported.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API - Full / Mobile
        Vote for your favorite feature requests and the bugs you want to see fixed.

        Comment


        • #5
          Originally posted by Bat21 View Post
          Could do with more info. Have you changed anything to make this happen? What version php are you running?
          I changed php from 5.4 to 7.1

          Comment


          • #6
            The minimum required version for vBulletin 4.2.5 is PHP 5.6.0.
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud demonstration site.
            vBulletin 5 API - Full / Mobile
            Vote for your favorite feature requests and the bugs you want to see fixed.

            Comment


            • #7
              Originally posted by Mark.B View Post
              We will need to know, as a minimum:

              1. What version of vBulletin this is
              2. What version of php is being run.

              The admincp front page should provide all of this information.

              Vbulletin =4.2.5
              Recently I changed php from 5.4 to 7.1 (before doing this there some issues with the site, that was why i changed)

              But now , i return to the default php in hosgator CP which is 5.4

              Comment


              • #8
                Most likely an add on that is not compatible with later versions of php.

                Please try disabling the plugin/hook system completel.
                Edit includes/config.php and add the following code:
                Just below
                Code:
                <?php
                enter
                Code:
                define('DISABLE_HOOKS', true);
                Does the issue still occur?
                MARK.B | vBULLETIN SUPPORT

                TalkNewsUK - My vBulletin 5.6.1 Demo
                AdminAmmo - My Cloud Demo

                Comment


                • #9
                  Originally posted by Mark.B View Post
                  Most likely an add on that is not compatible with later versions of php.

                  Please try disabling the plugin/hook system completel.
                  Edit includes/config.php and add the following code:
                  Just below
                  Code:
                  <?php
                  enter
                  Code:
                  define('DISABLE_HOOKS', true);
                  Does the issue still occur?
                  I did
                  also i returb back to php 5.4 ( the one used before )

                  But still showing the same message

                  Comment


                  • #10
                    vBulletin 4.2.5 will not work with PHP 5.4. The minimum required version is 5.6.0. No other version of vBulletin 4 is supported.
                    Translations provided by Google.

                    Wayne Luke
                    The Rabid Badger - a vBulletin Cloud demonstration site.
                    vBulletin 5 API - Full / Mobile
                    Vote for your favorite feature requests and the bugs you want to see fixed.

                    Comment


                    • #11
                      Originally posted by Wayne Luke View Post
                      vBulletin 4.2.5 will not work with PHP 5.4. The minimum required version is 5.6.0. No other version of vBulletin 4 is supported.
                      In hostgator CP , the availble options are 5.4 , 7.0 and 7.1

                      so i will try to select 7.0

                      Comment


                      • #12
                        Originally posted by Wayne Luke View Post
                        vBulletin 4.2.5 will not work with PHP 5.4. The minimum required version is 5.6.0. No other version of vBulletin 4 is supported.
                        I selected php 7.0 , but still showing the same message

                        Comment


                        • #13
                          Originally posted by helal_ph View Post

                          I did
                          also i returb back to php 5.4 ( the one used before )

                          But still showing the same message
                          I'm still seeing add ons on the site.

                          Can you please make sure you've disabled add ons in config.php as per my instructions?

                          Also please go to AdminCP > Style Manager
                          and create a new style with no parent.
                          Now set this as the default style to guests in AdminCP > Settings > Options > Style & Language settings.

                          Let me know when this is done so we can see the site running with no add ons.
                          MARK.B | vBULLETIN SUPPORT

                          TalkNewsUK - My vBulletin 5.6.1 Demo
                          AdminAmmo - My Cloud Demo

                          Comment


                          • #14
                            Originally posted by Mark.B View Post

                            I'm still seeing add ons on the site.

                            Can you please make sure you've disabled add ons in config.php as per my instructions?

                            Also please go to AdminCP > Style Manager
                            and create a new style with no parent.
                            Now set this as the default style to guests in AdminCP > Settings > Options > Style & Language settings.

                            Let me know when this is done so we can see the site running with no add ons.
                            yes , now sure all disabled (https://snipboard.io/zsiwm5.jpg )

                            I will fix (Also please go to AdminCP > Style Manager)

                            then update you tomrrow , its 3 am now here

                            Thank you very much for your support

                            Comment


                            • #15
                              Originally posted by Mark.B View Post

                              I'm still seeing add ons on the site.

                              Can you please make sure you've disabled add ons in config.php as per my instructions?

                              Also please go to AdminCP > Style Manager
                              and create a new style with no parent.
                              Now set this as the default style to guests in AdminCP > Settings > Options > Style & Language settings.

                              Let me know when this is done so we can see the site running with no add ons.
                              Good day!

                              - I disabled all plugin already
                              - started to make a new style: AdminCP > Style Manager>import

                              but it is not working: no new style created

                              " Administrative message: Templates Merged Successfully"
                              (see attached screen shots)

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X