Announcement

Collapse
No announcement yet.

HTML not allowed in every article ?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [CMS] HTML not allowed in every article ?

    Hi,

    I put some HTML tables in articles, and that worked fine. All those articles are in the same section of our CMS. Here's an example (the bottom table, not the right one)

    I tried yesterday to add a table in an article which is not in the same section and I get this.

    As you can see, HTML tags are visible and are not "translated".

    I check permissions in the adminCP, they should be OK as far as I know : by default, they are recursive, and the very first section of the CMS has all permissions checked for administrators. To be sure, I checked all permissions for the given section (then saved changes), but that doesn't change anything.

    Also, in the editor menu in this article, I do not have the menu to enable/disable HTML, while I can do this in the editor of the first article I show. So it SHOULD be a permission issue, but I can't see how to fix it...

    Thank you in advance for your answer !

  • #2
    I ran some tests and as far as I know, it doesn't exactly comes from the permissions. The fact is that I cannot add HTML in articles created by former members who left the community, and so those articles are marked as "created by" and no member name is shown. Other articles created by members who are still there seem to accept HTML, even if they are in the same CMS section.

    SO the question would be : what can I do ? Is it possible to assign a member to those orphan articles ? Or, better, to a "guest", to respect the contributor who spent quite much time to create those articles ?

    Comment


    • #3
      If no name is specified then the account might have been deleted and the article is attributed to a guest user.

      There is greater control over who can use HTML in vBulletin 5. It is a channel level permissions that can be set for each usergroup.
      Translations provided by Google.

      Wayne Luke
      The Rabid Badger - a vBulletin Cloud demonstration site.
      vBulletin 5 API - Full / Mobile
      Vote for your favorite feature requests and the bugs you want to see fixed.

      Comment


      • #4
        Hi Wayne,

        Yes, the account has been deleted on request. We didn't know that it would cause that mess with HTML permissions thereafter.

        Is there a way to modify the author through the database or whatever ?

        Thank you for your answer !

        Comment


        • #5
          You would have to use a database query. I don't have a vBulletin 4 database currently but it should be something like:

          UPDATE cms_node SET userid=XXX WHERE nodeid=YYY

          XXX would be the userid that you want to set it to. YYY would be the article's ID number shown in the URL.

          After making this change, you will probably have to edit and resave the article.
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud demonstration site.
          vBulletin 5 API - Full / Mobile
          Vote for your favorite feature requests and the bugs you want to see fixed.

          Comment


          • #6
            Thank you for your answer I tried this in the MySQL console and got this :

            Code:
            mysql> UPDATE cms_node SET userid=15384 WHERE nodeid=232
            ->
            I tried to check the node table and to empty the system cache, I tried editing then saving the concerned article but nothing changed for the moment.

            Did I forget something ?

            In the other hand, I'm looking for installing PHPMyAdmin on the server, this may be easier for me as I'm not accustomed with database manipulations...

            Thank you again !


            edit : OK, I forgot the ; ant the end of the line. Now I get :

            Code:
            ERROR 1046 (3D000): No database selected
            So which db is concerned, please ?


            second edit : as I said, I'm not accustomed... so I loaded the concerned DB and now I'm looking for the good table in our DB. Would it be vb_cms_node ?

            third edit : that was it and that works : author is now set properly. Now I just have to set the good permissions and that should be fine !
            Last edited by Mornagest; Fri 7th Feb '20, 10:37am.

            Comment


            • #7
              I don't know the name of your database. It would be written in your /includes/config.php for the Master database name.

              The table may have vb_ at the beginning if you have a table prefix defined in your /includes/config.php file.
              Translations provided by Google.

              Wayne Luke
              The Rabid Badger - a vBulletin Cloud demonstration site.
              vBulletin 5 API - Full / Mobile
              Vote for your favorite feature requests and the bugs you want to see fixed.

              Comment


              • #8
                That's ok now, I found where I was wrong and that works fine !

                Thank you again, Wayne

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X