Announcement

Collapse
No announcement yet.

Problems after activate Cloudflare

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Problems after activate Cloudflare

    Hello.
    In the first time, I don't know if this question and/or problem is better post here or in the cloudflare forum, but I know others users with vb and not have this problem...
    I hope to explain myself well:
    When I have cloudflare activated, on the home page, the login dialog does not work, normally, when you click with the mouse the text is deleted to insert username and password, when I have cloudflare it is not, I must delete the text and enter my username and password, when clicking on login, go to the wrong username and password page. On that same page, I can login correctly.

    On the other hand, I also observe that, when I am moderating, I go to a subforum and choose / mark several topics (although I only check 1) when I open the drop-down menu to delete them, move them ... etc ... it indicates that I have no subject selected and the count of selected topics appears in 0.
    The same happens to me if I select individual posts, although the count is 0, in that case if it allows me to perform some operation.
    In private messages the same thing happens, although I dial 10 mp's it tells me in count that I have marked 0, but it allows me to perform the operations that I want.

    This problem happens intermittently, happening 90% of the time.
    I have cleared cloudflare cache, I have activated a rule so that it does not generate cache, nothing solves it.
    The only thing that solves it is when I put cloudflare on pause.

    I forgot, I tried to disable all plugins and products, the problem persists.

    Any ideas?

    Thanks in advance and greetings.

    PD: VB 4.2.5 and PHP 7.1

  • #2
    vBulletin 4 hasn't been tested or developed to support Cloudflare. However, you might be able to work around your issues by setting the Proxy Management in your /includes/config.php file. Specifically, you need to add this code to the bottom of your config.php file:

    Code:
    //default configuration for Cloudflare proxy.
    $config['Misc']['proxyiplist'] = '103.21.*, 103.22.*, 103.31.*, 104.16.*, 108.162.*, 131.0.*, ' . 
        '141.101.*, 162.158.*, 172.64.*, 173.245.*, 188.114.*, 190.93.*, 197.234.*, 198.41.*,  ' . 
        '2400:cb00:*, 2405:b500:*, 2606:4700:*, 2803:f800:*, 2c0f:f248:*, 2a06:98c0:*';
    
    $config['Misc']['proxyipheader'] = 'HTTP_CF_CONNECTING_IP';
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API - Full / Mobile
    Vote for your favorite feature requests and the bugs you want to see fixed.

    Comment


    • #3
      Hi.
      First of all thanks for your answer.
      When I started with Cloudflare I had to make modification in the config.php file so that the users appeared with their true ip (not with the cloudflare ip), I left the file in this way (in the final part where it indicates the proxy):
      Code:
      /* #### REVERSE PROXY IP ####
      If your use a system where the main IP address passed to vBulletin is the address of a proxy server
      and the actual 'real' ip address is passed in another http header then you enter the details here
      Enter your known proxy servers here. You can list multiple trusted IPs separated by a comma.
      You can also use the * wildcard (at the end of a definition only) or use the keyword 'all' to represent any ip address.*/
      $config['Misc']['proxyiplist'] = '127.0.0.1, 192.168.*, all';
      /* If the real IP is passed in a http header variable you can set the name here; */
      $config['Misc']['proxyipheader'] = 'HTTP_X_FORWARDED_FOR';
      I am going to leave that part that I modified in the past as it originally came and I will add in the end the code that you have indicated to me, I post results.
      Again thanks and greetings.

      Comment


      • #4
        Sorry for the delay in response...

        With this config, I can view the real ip of users in the site, also, I made the changes in mod_remoteip in the apache server for appears a real ip in the apache.

        But the problem with login was continue.

        After some changes in cloudflare config, I view the problem.

        To fix this problem I disable "Rocket Loader" option in CloudFlare. now, work fine, the issue with login are fixed.

        But a doubt or question:
        In the config.php file, per default we have the line:
        Code:
        $config['Misc']['proxyipheader'] = 'HTTP_X_FORWARDED_FOR';
        For comment or uncomment, for view the real ip we need uncomment this line, but in your post (and others that I read) this line chage to:
        Code:
        $config['Misc']['proxyipheader'] = 'HTTP_CF_CONNECTING_IP';
        What are the difference between this two lines? (http_x_forwarded_for or http_cf_connectiong_ip)

        Thanks and regards!

        Comment


        • #5
          The first is the standard forwarding IP used by 10s of thousands of Proxy Servers around the world. This is known and recognized by all servers.

          The second is the proprietary header used by Cloudflare to forward the IP. Cloudflare will only work with the second.
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud demonstration site.
          vBulletin 5 API - Full / Mobile
          Vote for your favorite feature requests and the bugs you want to see fixed.

          Comment


          • #6
            Thanks for the explanation Wayne,

            I understand that, the first, standard forwarding ip used by 10s of thousands of proxy servers, also work with cloudflare, but not the cloudflare with others.

            I was have the first in my config.php file and indicate the real ip users in the forum but after your post, I was change to second.
            If set the 2 in the config.php file, some problem? Only I use cloudlfare...

            Sorrys if some doubt its a "stupid" doubt

            Thanks and regards!

            Comment


            • #7
              You can't set both. It is a single value and the last line will be what is set.

              Have you gone through these steps: https://support.cloudflare.com/hc/en...ulletin-forums

              Translations provided by Google.

              Wayne Luke
              The Rabid Badger - a vBulletin Cloud demonstration site.
              vBulletin 5 API - Full / Mobile
              Vote for your favorite feature requests and the bugs you want to see fixed.

              Comment


              • #8
                Originally posted by Wayne Luke View Post
                You can't set both. It is a single value and the last line will be what is set.
                Ok, thanks for the indication.
                Then, only one line, and use that you indicate above, only use cloudflare, but the original line, its for more and works also with cloudflare.

                Have you gone through these steps: https://support.cloudflare.com/hc/en...ulletin-forums
                Yes, I was read this some days ago and I config all, only this doubt, in this line in config.php file, HTTP_X_FORWARDED_FOR or HTTP_CF_CONNECTING_IP.

                Thanks and regards!

                Comment

                Related Topics

                Collapse

                Working...
                X