Announcement

Collapse
No announcement yet.

HTML codes like <p> are adding to the text when typing or cut-and-paste to editor

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • StevenAvery
    replied
    Thanks Omnibus and Wayne.

    Since I am using the forum as a research blog, I don't really have the security problem.

    When I rendered HTML for the forum I am using as a test, the view of codes did vanish but the spacing was wrong.

    I'm checking with Siteground about the PHP level. We are upgrading from 5.6 to 7.1

    More to follow.

    Leave a comment:


  • Wayne Luke
    replied
    HTML is disabled by default. Enabling HTML should be considered a security risk because it cannot be controlled by Usergroup in vBulletin 4.2.X. It is a global setting per channel. We recommend against allowing HTML on vBulletin 4.2.X. Please note that in vBulletin 4.2.X, all carriage returns in your HTML will be turned into <br> tags. This means that if you use complex HTML like tables, the entire table needs to be on a single line of text or it will break the display of your site. In addition to this, allowing HTML will allow your users to post Javascript, CSS, and potential malware on your site.

    If you wish to disregard this recommendation, you can enable HTML under Forums & Moderators -> Forum Manager. Edit the forum in question and HTML is one of the options available.

    If you want better control over HTML inclusion within posts, you should upgrade to vBulletin 5.5.4. vBulletin 5 allows HTML permissions per usergroup as well as per channel. This provides a much safer environment for your end users.

    Leave a comment:


  • In Omnibus
    replied
    I don't think the HTML is being "added in." I think it's already there and is not being parsed.

    vBulletin 4.2.5 works with PHP 7.1 so that upgrading be a logical first step.

    Leave a comment:


  • HTML codes like <p> are adding to the text when typing or cut-and-paste to editor

    My forum is
    https://www.purebibleforum.com/

    "You are currently running vBulletin version 4.2.4."

    =================================================

    Recently I moved from Liquid Web to SIteground.
    And Siteground gives fine support, even with simply a shared server.
    (LiquidWeb still has my business WooCommerce site.)

    I was getting a fatal PHP error, which Siteground fixed,

    Siteground had helped me with .htaccess stuff and installing Cloudflare as a firewall due to attacks of 10s of thousands of visits, mostly from Singapore or China.

    =================================================

    When I sent them the code lines with the fatal error:

    Siteground:
    This is because the .htaccess file that our system administrators created didn't have the handler for PHP version 5.6 and the default PHP version on the server is 7.1.
    I've added the following line to the current .htaccess file:

    [ AddHandler application/x-httpd-php56 .php .php5 .php4 .php3 ]


    =================================================

    My vBulletin now is adding codes when I write or copy-paste into the editor.

    <p>
    <br />

    &lt;br /&gt;
    &lt;p&gt;
    &amp;nbsp

    I could add a pic, but I think you get the idea.

    =================================================

    Thoughts about why these HTML codes are adding in is appreciated!
    And solutions.

    =================================================


    And if there is a PHP version mismatch, what are my options? (I am just guessing here.)
    Generally I am happy on my release 4.

    Feel free to bring up any other vBulletin ideas.

    The forum is used mostly as my personal research blog, so there is no critical time component.

    =================================================

    Steven Avery

Related Topics

Collapse

Working...
X