Announcement

Collapse
No announcement yet.

What is latest PHP and MySQL version 4.2.5 can run on?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • What is latest PHP and MySQL version 4.2.5 can run on?

    I have look around and could not find this specific question (I'm sure it's been addressed somewhere but I couldn't find it).

    What is the latest PhP version and MySQL version that vB 4.2.5 can run on?

  • #2
    vBulletin 4.2.5 requires PHP 5.6.0+ and MySQL 5.5.8+.

    There are customers who have reported it working on PHP versions later than 7.1 but that is the official latest working PHP version.

    There are customers who have reported it working on SQL versions later than 5.6 but I believe that is the latest supported version.

    Comment


    • #3
      Ok, super - thank you!

      Comment


      • #4
        Originally posted by In Omnibus View Post
        There are customers who have reported it working on SQL versions later than 5.6 but I believe that is the latest supported version.
        MySQL 8.0 is backwards compatible with the basic SQL used in vBulletin 4.

        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API

        Comment


        • In Omnibus
          In Omnibus commented
          Editing a comment
          Thanks. I couldn't remember if it was 5.7 or 8.0 that was backwards compatible since I'm not using either version with my vBulletin 4 licenses.

      • #5
        4.2.5 and php 7.1.30 ==> i have problem with paid subscriptions (acces to admin tools, automatical group assignment when granting a paid subscription...)

        Error: Call to undefined function set_magic_quotes_runtime() in ..../includes/init.php(357) : eval()'d code(30) : eval()'d code(1) : eval()'d code(1) : eval()'d code(1) : eval()'d code(1) : eval()'d code(1) : eval()'d code(1) : eval()'d code(1) : eval()'d code(1) : eval()'d code(1) : eval()'d code(1) : eval()'d code on line 5

        i will downgrade php then

        thanks

        Comment


        • #6
          Your add-on products and plugins will have to be upgraded to work with PHP 7.1.
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud demonstration site.
          vBulletin 5 API

          Comment


          • Sylv1
            Sylv1 commented
            Editing a comment
            thanks Luke

        • #7
          Originally posted by Wayne Luke View Post
          Your add-on products and plugins will have to be upgraded to work with PHP 7.1.
          I downgraded to 5.6.4 and now, symptom has changed; it only occurs in paid subscription admin tools :
          Software: Apache. PHP/5.6.40

          uname -a: Linux webd043.cluster014.gra.hosting.ovh.net 4.14.119-ovh-vps-grsec-zfs-classid #1 SMP Wed
          May 15 10:40:34 CEST 2019 x86_64


          uid=210290(userforum) gid=100(users) groups=100(users)

          Safe-mode: OFF (not secure)

          /home/userforum/www/forum_notrez/ drwx---r-x
          Free 0 B of 0 B (0%)
          do you have idea on what happens?

          Comment


          • #8
            The answer is exactly the same. Line 357 of /includes/init.php is:
            Code:
            ($hook = vBulletinHook::fetch_hook('init_startup')) ? eval($hook) : false;
            So a plugin that is installed on the init_startup hook is failing with your version of PHP. Line 30 of the problematic plugin to be precise.
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud demonstration site.
            vBulletin 5 API

            Comment


            • #9
              Originally posted by Wayne Luke View Post
              The answer is exactly the same. Line 357 of /includes/init.php is:
              Code:
              ($hook = vBulletinHook::fetch_hook('init_startup')) ? eval($hook) : false;
              So a plugin that is installed on the init_startup hook is failing with your version of PHP. Line 30 of the problematic plugin to be precise.
              i have neither product nor module and have refreshed my php files from source.
              + delete pub in header

              when php is 5.6; subscription.php goes to screen !C99madShell v. 2.0 madnet edition!
              when php is 7...., subscription.php leads to Error: Call to undefined function set_magic_quotes_runtime() which indeed looks like a compatibility with php 7

              but 5.6 should work

              is there a missing prerequisite on server?
              all woks fine except subscription

              Comment


              • #10
                Originally posted by Sylv1 View Post

                i have neither product nor module and have refreshed my php files from source.
                + delete pub in header

                when php is 5.6; subscription.php goes to screen !C99madShell v. 2.0 madnet edition!
                when php is 7...., subscription.php leads to Error: Call to undefined function set_magic_quotes_runtime() which indeed looks like a compatibility with php 7

                but 5.6 should work

                is there a missing prerequisite on server?
                all woks fine except subscription
                Seems you have some sort of exploit on your server that doesn't work in PHP 7.1.

                Please secure your site: https://forum.vbulletin.com/forum/vb...ring-your-site
                Translations provided by Google.

                Wayne Luke
                The Rabid Badger - a vBulletin Cloud demonstration site.
                vBulletin 5 API

                Comment


                • #11
                  Originally posted by Wayne Luke View Post
                  The answer is exactly the same. Line 357 of /includes/init.php is:
                  Code:
                  ($hook = vBulletinHook::fetch_hook('init_startup')) ? eval($hook) : false;
                  So a plugin that is installed on the init_startup hook is failing with your version of PHP. Line 30 of the problematic plugin to be precise.
                  hi Wayne

                  i do have a plugin installed in the init_startup hook
                  Click image for larger version

Name:	init_startup_hook.JPG
Views:	436
Size:	28.6 KB
ID:	4426712


                  when I desactivate it, subcriptions.php works fine whatever php 5.6 or 7.1

                  is it really from vBulletin or is it the result of hacking?

                  Comment


                  • #12
                    You should delete it if you don't know what it is. There should be no plugins on the vBulletin Product in vBulletin 4.2.5 unless you created them.

                    This would be the result of hacking. Wouldn't be able to say when it was added to your database. This is why we stopped allowing Third-Party products to insert code into the database in vBulletin 5. This practice has a purpose in the past. Today it is just a security risk.
                    Translations provided by Google.

                    Wayne Luke
                    The Rabid Badger - a vBulletin Cloud demonstration site.
                    vBulletin 5 API

                    Comment


                    • #13
                      Originally posted by Wayne Luke View Post
                      You should delete it if you don't know what it is. There should be no plugins on the vBulletin Product in vBulletin 4.2.5 unless you created them.

                      This would be the result of hacking. Wouldn't be able to say when it was added to your database. This is why we stopped allowing Third-Party products to insert code into the database in vBulletin 5. This practice has a purpose in the past. Today it is just a security risk.
                      deleted

                      thanks a lot for your help, Wayne

                      Appreciated it

                      Comment


                      • #14
                        Anyone found a solution for a PHP upgrade higher than 7.1?
                        Macht mit beim 2-Wheel-Planet Adventskalender:

                        2WP Adventskalender

                        Comment


                        • #15
                          Originally posted by MK_1 View Post
                          Anyone found a solution for a PHP upgrade higher than 7.1?
                          There isn't one. The code is not compatible.
                          MARK.B | vBULLETIN SUPPORT

                          TalkNewsUK - My vBulletin 5.6.4 Demo
                          AdminAmmo - My Cloud Demo

                          Comment

                          Related Topics

                          Collapse

                          Working...
                          X