Announcement

Collapse
No announcement yet.

V4.25 Requirements - Server & HTML

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • V4.25 Requirements - Server & HTML

    After a recent PHP upgrade on my host's servers (To v7.2) and forum down time I have some questions.

    1.) My host says that PHP v7.0 is not compatible with vB 4.25, and yet my forum ran fine for several weeks using it. Are they correct, v4.25 doesn't work with PHP 7?

    2.) I've been discussing the index.html file with them. Is an index.html file used in v4.25 - example at the root of the domain directory or forum directory - and is there an example of the proper coding available here? (Or does vB rely upon an index.php file being present?)

    3.) Error logs can report errors on a specific line number from a .php file. I use Notepad++ to examine files by line numbers. Host says error log reports error on line 4 in xxx.php, I see a blank like in Notepad++. Is there a better text viewer for viewing numbered lines?

  • #2
    Your host is wrong.

    vBulletin 4.2.5 is compatible with PHP 7.0.x or 7.1.x.

    vBulletin 4.2.5 is not compatible with PHP 7.2.0 or higher.

    See thid notice at the top of this page and any pother pager about vBulletin 4.2.5.

    Click image for larger version

Name:	vB425.png
Views:	116
Size:	66.9 KB
ID:	4413380
    Send your host a link to this page is he doesn't believe you.

    Psychlinks Mental Health Support Forum
    Local Search Forum

    Comment


    • #3
      1) You need to downgrade to between PHP 5.6 and 7.1

      2) There should not be an index.html file in the root of your vBulletin directory. The index.php file should be the default file served by the Web Server.

      3) What is the entire error?
      Translations provided by Google.

      Wayne Luke
      The Rabid Badger - a vBulletin Cloud customization and demonstration site.
      vBulletin 5 Documentation - Updated every Friday. Report issues here.
      vBulletin 5 API - Full / Mobile
      I am not currently available for vB Messenger Chats.

      Comment


      • #4
        Sorry to be late getting back to this. It was due to host's upgrade of PHP on their servers. Original Issue is resolved with host. I appreciate the confirmation on PHP version and index file.

        Comment


        • #5
          Originally posted by djbaxter View Post

          vBulletin 4.2.5 is not compatible with PHP 7.2.0 or higher.

          Originally posted by Rakehel View Post
          After a recent PHP upgrade on my host's servers (To v7.2) and forum down time I have some questions.
          I am running PHP v7.2 for my forum vB 4.2.5 without any problems, only 2 plugins are not compatible but I fixed them. Wondering why you could not run it.

          Best Internet Marketing Forum & Webmaster Forum for webmasters and Internet Marketers discussing and trading!

          Comment


          • #6
            Thank you webmastersun. Sorry, I'm an infrequent visitor here. I believe I've resolved the issue via looking at plug-ins and whittling them down some.

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X