Announcement

Collapse
No announcement yet.

Upgrade from 4.2.3 to 4.2.5

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Upgrade from 4.2.3 to 4.2.5

    Hey all.
    this week some of your advice to me upgrade my forum from 4.2.3 to 4.2.5

    I know the processes

    - take backup
    - copy 4.2.5 Files to my root and change Files and folders
    - run upgrade.php


    I just thinking about I have some plugin like advanced sratistic, like button, ...:: etc

    should I make or change for these plugin ?

    thanks for your feedbacks

  • #2
    As far as I recall, there are no plugins which will break by upgrading from 4.2.3 to 4.2.5.

    There are a few which require updated versions or small edits if you upgrade from PHP 5.x to PHP 7.x though.
    Psychlinks Mental Health Support Forum
    Local Search Forum

    Comment


    • #3
      Originally posted by djbaxter View Post
      As far as I recall, there are no plugins which will break by upgrading from 4.2.3 to 4.2.5.

      There are a few which require updated versions or small edits if you upgrade from PHP 5.x to PHP 7.x though.
      I have to upgrade, but I dont have enough experience about upgrading and care to do it without problem.

      Comment


      • #4
        It's not a difficult process. PM me if you need help.
        Psychlinks Mental Health Support Forum
        Local Search Forum

        Comment


        • #5
          Originally posted by djbaxter View Post
          It's not a difficult process. PM me if you need help.
          Ok thank you very much.

          I want to do it Turkey time Saturday Night 23.30 - 24.00.
          if I cant I will pm you.

          Comment


          • #6
            Just want to make sure
            I will start 2 hours later upgrade my forum but still I have some question on my head. Because I have some plugin when I copy all 4.2.5 files to my root , it is going to ask replace all files and folder and I will say yes.

            But I make some postbit setting up and also some folder has specific plugin files, when I say yes replace all folders , these files will replace and my addings will delete. Is that right or no ?

            Comment


            • #7
              Can someone help me please ? When I start upgrade.php it gives an error, Internal server error 500

              How can I resolve it.

              Comment


              • #8
                Anyone here ?

                If php version 5.4 It gives this error

                Parse error: syntax error, unexpected '*' in /home4/omega/public_html/includes/functions.php on line 1576


                when I changed php version from 5.4 to 7 or 7.1 while setup proggress it gives an error below. Please help me.


                Code:
                Unexpected Text:
                <?xml version="1.0" encoding="windows-1252"?>
                <?xml version="1.0" encoding="windows-1252"?>
                <errors>
                    <error><![CDATA[<p>Database Error</p>
                
                Invalid SQL:
                
                            SELECT bt.userid, bt.dateline, blogtextid, ipaddress, firstblogtextid
                            FROM blog_text bt
                            JOIN blog bl USING (blogid)
                            LEFT JOIN ipdata ip ON (
                                bt.ipaddress = ip.ipid AND bt.blogtextid  = ip.contentid
                                AND bt.userid = ip.userid AND ip.contenttypeid IN (, )
                            )
                            WHERE ipid IS NULL;
                
                You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ' )
                            )
                            WHERE ipid IS NULL' at line 6]]></error>
                    <error_html><![CDATA[<p>Database error in vBulletin 4.2.5</p>
                <p>Invalid SQL:
                
                            SELECT bt.userid, bt.dateline, blogtextid, ipaddress, firstblogtextid
                            FROM blog_text bt
                            JOIN blog bl USING (blogid)
                            LEFT JOIN ipdata ip ON (
                                bt.ipaddress = ip.ipid AND bt.blogtextid  = ip.contentid
                                AND bt.userid = ip.userid AND ip.contenttypeid IN (, )
                            )
                            WHERE ipid IS NULL;<p>
                <p>
                <strong>MySQL Error</strong>   : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ' )
                            )
                            WHERE ipid IS NULL' at line 6<br />
                <strong>Error Number</strong>  : 1064<br />
                <strong>Request Date</strong>  : Sunday, January 13th 2019 @ 12:30:41 PM<br />
                <strong>Error Date</strong>    : Sunday, January 13th 2019 @ 12:30:42 PM<br />
                <strong>Script</strong>        : http://www.defineyolu.com/install/upgrade.php<br />
                <strong>Referrer</strong>      : https://www.defineyolu.com/install/upgrade.php<br />
                <strong>Classname</strong>     : vB_Database_MySQLi<br />
                <strong>MySQL Version</strong> : 5.6.41-84.1<br />
                </p>]]></error_html>
                </errors>
                Last edited by wtrk68; Sun 13th Jan '19, 9:45am.

                Comment


                • #9
                  You will need to use at least php 5.6 and ensure you have uploaded ALL the 4.2.5 files from the full package.
                  MARK.B | vBULLETIN SUPPORT

                  TalkNewsUK - My vBulletin 5.5.2 Demo
                  AdminAmmo - My Cloud Demo

                  Comment


                  • #10
                    Originally posted by Mark.B View Post
                    You will need to use at least php 5.6 and ensure you have uploaded ALL the 4.2.5 files from the full package.
                    Before I uploaded only forum files upload folder but its asking cms like this.
                    then I uploaded full cms and blog files upload folder but it gives an error 18/30 which is showing up.

                    PHP version is 5.6 and 7.0 but same error.




                    Also It did not complete yet but my forums looking version changed. Is it normal ?


                    Last edited by wtrk68; Sun 13th Jan '19, 9:01pm.

                    Comment


                    • #11

                      Comment


                      • #12
                        Do you have the blogs disabled in 4.2.3?

                        Comment


                        • #13
                          Originally posted by motd2 View Post
                          Do you have the blogs disabled in 4.2.3?
                          YDS I disabled it and didnot used ever.

                          Comment


                          • #14
                            Originally posted by wtrk68 View Post

                            YDS I disabled it and didnot used ever.
                            You will need to re-enable them. The Blogs (& CMS) were never intended to be disabled in that manner. Then run install/upgrade.php

                            Comment


                            • #15
                              Originally posted by motd2 View Post

                              You will need to re-enable them. The Blogs (& CMS) were never intended to be disabled in that manner. Then run install/upgrade.php
                              How can I enable it ?
                              I dont know

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X