Announcement

Collapse
No announcement yet.

Lost admin password - tried everything so far

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Lost admin password - tried everything so far

    Sorry to have to ask this one again, but I think I've run out of ideas.

    I was changing my password and somehow got things out of sync.
    My old password doesn't work, and my new one was auto-generated by a password manager, but didn't get saved. So, the password manager keeps using the old password.



    Anyway, I can't register as a new user because Captcha is broken. I can't request a password reset, because Captcha is broken.



    I have tried a direct query to the data base and I keep getting errors compaing about unrecognized tokens or fields.
    After working through it, it seems like my version of MySQL (or PHPMyAdmin) is expecting different things in the syntax.

    However, when I do get a valid SQL query formulated, the results do not work - i.e. the password doesn't work.

    I've tried this within phpMyAdmin, substituting anything in <> as appropriate for my database (and omitting the <>)

    UPDATE <prefix>_user
    set password = MD5(concat(MD5('<password>'), user.salt))
    WHERE userid = <userid>

    I saw another example that added "AS user" to the first line. So, I tried that as-stated and also with a valid db user.
    It didn't seem to make a difference in terms of SQL errors.

    With or without the AS user portion, this query is the only one that gets through without SQL errors.

    UPDATE `<prefix>_user` AS <mysql-user>
    set `password` = MD5(concat(MD5('<password>')))
    WHERE `userid`= <userid>

    Note that the difference is the removal of ", user.salt"

    However, the password doesn't seem to work.
    That makes sense as the salt should be part of the algorithm.
    So, I tried this:

    UPDATE <prefix>_user
    set password = MD5(concat(MD5('<password>'), `<prefix>_user.salt`))
    WHERE userid = <userid>

    That went through without errors, but the password still doesn't work.
    Note the ` ` around <prefix>_user.salt. I had to add those to get through without errors.

    This last attempt seems to make the most sense to me (as I realized what the query was trying to do). Yet, it still doesn't work.


    I'm on vb 4.2.5
    MySQL version is 5.6.41-84.1

    Any help is greatly appreciated.

  • #2
    I got it.

    I used this and a password that didn't include the word 'password' in it, and it took right away. It was only going to be temporary.
    Not sure if that should matter, but it all of a sudden worked.
    I did this in the SQL tab while the user table is already selected in phpMyadmin.

    UPDATE <prefix>user SET `password` = MD5(CONCAT(MD5('<password>'), `salt`)) WHERE userid = <userid>

    Carry on.

    Comment


    • #3
      Simplest way is direct go to lost password page -> https://yoursdomain/login.php?do=lostpw
      This way I recover lost admin password.

      Comment


      • #4
        As User is used to change the MySQL User Password. It isn't relevant to vBulletin users.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud customization and demonstration site.
        vBulletin 5 Documentation - Updated every Friday. Report issues here.
        vBulletin 5 API - Full / Mobile
        I am not currently available for vB Messenger Chats.

        Comment

        Related Topics

        Collapse

        Working...
        X