No announcement yet.

Converting attachments from database to filesystem

  • Filter
  • Time
  • Show
Clear All
new posts

  • Converting attachments from database to filesystem

    Every time I do, I get to about 9,000 attachments converted and I consistently get the same SQL error:

    Database error in vBulletin 4.2.5:

    Invalid SQL:

    SELECT filedataid, filedata, filesize, userid, thumbnail
    FROM filedata
    WHERE filedataid >= 9002 AND filedataid < 9302
    ORDER BY filedataid ASC;

    MySQL Error : Lost connection to MySQL server during query
    Error Number : 2013
    Request Date : Friday, September 7th 2018 @ 09:22:47 AM
    Error Date : Friday, September 7th 2018 @ 09:22:49 AM
    Script : http://www.***.com/admincp/attachmen...cherrorcount=0
    Referrer : http://www.***.com/admincp/attachmen...cherrorcount=0
    IP Address :
    Username : jimnyc
    Classname : vB_Database_MySQLi
    MySQL Version :
    Server :
    User Agent :
    It doesn't appear SQL actually "goes away" as the site runs just fine throughout the process and just after the error as well. I wrote my host and he replied with:

    I have increased the memory_limit, post_max_size, upload_max_filesize to 1024M, 128M, 64M respectively. Please try again from your end and let us know if you are having any issues.
    I tried the conversion again and it dies in the exact same spot every single time.

    Anyone have any ideas on what I need to do to get this script to work, and what this error is really meaning?

    Thanks!! -Jim

  • #2
    I lowered it from doing 300 attachments at a time, to 50 at a time, and this time it worked!! Thx!


    • #3
      Actually, I do still have an issue here. My database was about 5gig prior to my conversion. At the end of the conversion, the numbers matched up, so of course I said yes to allow it to delete the attachments in the database, which it did. I even verified this via phpmydamin and what not. But now my total storage has simply double by 5gig, and for whatever reasons, the same database states it is the same 5gig size? I went through all the tables, verified that attachments was basically gone, and all looks great. I can't figure out why it thinks it adds up to 5gig, as it doesn't now that attachments is 10k. But the front page of Cpanel shows the extra storage usage, and if I open my SQL databases, it shows the one I am speaking of as the same 5gig as it was before. I verified all the files were converted over successfully, and they are. So I'm at a dead end as to why it's still that size. Any ideas?



      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.