Announcement

Collapse
No announcement yet.

MySQL Error * : Unknown column 'ip' in 'field list'

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Wayne Luke
    replied
    The database between 4.2.3 and 4.2.5 aren't compatible. The system was switched to store all IP information in a centralized ipdata table. Once you upgrade you have to run the newer version. The correct thing to do is correct the 500 server error. Reverting to an obsolete and unsupported version isn't the solution.

    What does the PHP error log say about this error? Can your hosting provider give more information since they are the ones obscuring the error to begin with?

    Leave a comment:


  • khalled
    replied
    Originally posted by Wayne Luke View Post
    Are you using PHP 5.6.X or higher?

    Do you have out of date addons that haven't been updated to your version of PHP and vBulletin?
    use PHP 5.6.X , and i disable all addons before upgrade to 4.2.5 but also not running while i disable all addons
    so i return again to 4.2.3
    no problem i can run forum with 4.2.3 but how i can overcome database error while i send post

    Leave a comment:


  • Wayne Luke
    replied
    Are you using PHP 5.6.X or higher?

    Do you have out of date addons that haven't been updated to your version of PHP and vBulletin?

    Leave a comment:


  • khalled
    replied
    Originally posted by Trevor Hannant View Post
    As there is no 'ip' column in a default installation of 4.2.5, did you upgrade to 4.2.5 from a previous version? If so, did you run the upgrade script or just upload the files?
    many thanks
    i actually upgrade from 4.2.3 to 4.2.5 directly but after i upgrade i can't open the forum and only i can go to forum control admin control panel
    but if i try to access forum website url i get the following error page
    Code:
     This page isn’t working
    
    
    www.xxxx.net is currently unable to handle this request.
    
    HTTP ERROR 500
    so i extract the vb4.2.3 file acain and run the upgrade script , after that the forum website work with me but the above error when i try to post new threat appear with me

    Leave a comment:


  • Trevor Hannant
    replied
    As there is no 'ip' column in a default installation of 4.2.5, did you upgrade to 4.2.5 from a previous version? If so, did you run the upgrade script or just upload the files?

    Leave a comment:


  • MySQL Error * : Unknown column 'ip' in 'field list'

    when i try to post new thread in the forum i get the following error

    Code:
    Database error in vBulletin 4.2.5:
    
    Invalid SQL:
    
                    INSERT INTO postlog
                    (postid, useragent, ip, dateline)
                    VALUES
                    (361834, 'Mozilla/5.0 (Windows NT 6.2; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.181 Safari/537.36', 3307476098, 1524428084);
    
    MySQL Error   : Unknown column 'ip' in 'field list'
    Error Number  : 1054
    
    Classname     : vB_Database_MySQLi
    MySQL Version : 5.6.38

Related Topics

Collapse

Working...
X