Announcement

Collapse
No announcement yet.

After upgrade, everything gives 500 errors

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Wayne Luke
    replied
    Database Repair fixes one issue and one issue only... It will fix a crashed MyISAM table. Nothing more, nothing less.

    What is the actual database error? It will be emailed to the technical contact email address specified in /includes/config.php file.

    Leave a comment:


  • Valkysas
    replied
    I uploaded everything from the upload package in ascii mode again (and updating the config.php file appropriately), and now everything gives a database error. I can’t even get the admincp open now.

    Http://www.pavilionboards.com/forum

    I’ve run database repair, and that fixes nothing.

    Leave a comment:


  • Trevor Hannant
    replied
    To troubleshoot this, first download a fresh copy of the vBulletin ZIP file from the Members Area then reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all plugins.Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php:

    define('DISABLE_HOOKS', true);

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

    Do you have the same problem?

    Leave a comment:


  • Valkysas
    replied
    Hoping someone will have a fix for this, my forum is just a white page with this error on it at this point.

    Leave a comment:


  • Valkysas
    replied
    No plug ins or add ons that relate to profile fields. We have custom profile fields though.

    Leave a comment:


  • djbaxter
    replied
    Are you using any plugins or add-ons that alter user profile fields? Do you have any custom profile fields?

    Leave a comment:


  • Valkysas
    replied
    Thanks. Now I’m getting:


    Parse error: syntax error, unexpected '*' in /home/valkysas/public_html/forum/includes/functions.php on line 1576

    Leave a comment:


  • Trevor Hannant
    replied
    You need to install the mb_string library in PHP. With a default installation of PHP, this is not installed. You need to contact the host.

    http://php.net/manual/en/mbstring.installation.php

    If you are using cPanel and the host allows you to switch your PHP Version, you can select this module on the PHP Version screen.

    Leave a comment:


  • Valkysas
    replied
    So the errors I’m getting now are:

    PHP User Warning: fetch_template() calls should be replaced by the vB_Template class. Template name: threadban_banlist in ..../includes/functions.php on line 4197

    Fatal error: Call to undefined function mb_detect_encoding() in /home/valkysas/public_html/forum/includes/functions.php on line 729

    The first one is referencing three customized templates that allowed us to ban users from individual threads. The option to revert these three templates is grayed out in the style manager, for every style we’ve had. Even the original style they were added in does not give the option to revert. They are not marked with any colors as customized or inherited. I have no idea how I can remove these. In the past, I was just able to revert anything I wanted gone.

    the second seems to be related to censored words?

    Leave a comment:


  • Mark.B
    replied
    A 500 error is a generic server error and doesn't tell us anything about the problem. It literally just means "something went wrong".

    Youll need to ask your host to turn on logging so you can see the real error. We will need that error in order to assist.

    Leave a comment:


  • Valkysas
    started a topic After upgrade, everything gives 500 errors

    After upgrade, everything gives 500 errors

    Upgraded from vbulletin 3.8 to 4.2.5, uninstalled and physically removed all add-ons beforehand. Now everything gives me a 500 error. The only thing I can load and use is the admin control panel, and only because I manually type in the url. I’ve checked my server logs and there’s no errors reported there.

    Forum is located at pavilionboards.com/forum

    mysql is 5.6.38
    php is 5.6.34

    Please help?

Related Topics

Collapse

  • aelalfey
    Http error 500
    by aelalfey
    Hi,

    I just updated my php version from 5.4.28 to php 5.6 and updated my apache from 2.2 to 2.4 and after that i tried to open my vbulletin v 5.1.10 and got this error "HTTP ERROR 500"....
    Mon 19 Jun '17, 6:53pm
Working...
X