Announcement

Collapse
No announcement yet.

Please help with class_core.php Error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Change you config file to use "127.0.0.1" for the MySQL server rather than "localhost".
    This is my signature.

    Comment


    • #17
      Hello and thank you for your reply.

      May I ask why do you think this might help?

      Comment


      • #18
        Originally posted by dmx07 View Post
        Thank you guys for your replies. We are running vbulletin 4.2.5 PHP7.
        PHP 7 what? Did your host upgrade to version 7.2 recently? That might be an issue.

        Comment


        • #19
          Hello, thanks for your reply yes we recently upgraded to PHP 7.2

          Errors persist and new ones develop:

          Database error in vBulletin

          mysqli_real_connect(): (HY000/2002): No such file or directory
          /home/public_html/includes/class_core.php on line 1351

          MySQL Error
          Request Date : Friday, November 17th 2017 @ 09:43:31 AM
          Error Date : Friday, November 17th 2017 @ 09:43:31 AM
          Classname : vB_Database_MySQLi

          Stack Trace:

          #0 vB_Database->halt() called in [path]/includes/class_core.php on line 5948
          #1 catch_db_error() called in on line
          #2 mysqli_real_connect() called in [path]/includes/class_core.php on line 1351
          #3 vB_Database_MySQLi->db_connect() called in [path]/includes/class_core.php on line 280
          #4 vB_Database->connect() called in [path]/includes/init.php on line 212
          #5 require_once([path]/includes/init.php) called in [path]/includes/class_bootstrap.php on line 101
          #6 vB_Bootstrap->init() called in [path]/includes/class_bootstrap.php on line 72
          #7 vB_Bootstrap->bootstrap() called in [path]/global.php on line 26
          #8 require_once([path]/global.php) called in [path]/attachment.php on line 115

          Feels like slow certain death if this continues.

          Should I edit my config file to use "127.0.0.1" for the MySQL server to see if this will help?

          Comment


          • #20
            vBullletin 4.2.5 is not compatible with PHP 7.2 unless something has recently changed.

            Ask your host to downgrade your PHP version to 7.1

            Comment


            • #21
              You will not be able to use versions of PHP newer than 7.1.X with vBulletin 4.2.5.

              Currently, the only version of vBulletin that is compatible with PHP 7.2.0 RC5 and higher is vBulletin 5.3.4. We have no plans to update vBulletin 3.8 or 4.2 to be compatible with PHP 7.2.
              Translations provided by Google.

              Wayne Luke
              The Rabid Badger - a vBulletin Cloud demonstration site.
              vBulletin 5 API - Full / Mobile
              Vote for your favorite feature requests and the bugs you want to see fixed.

              Comment


              • #22
                Thank you Wayne.

                Comment


                • #23
                  Just a quick update on this error. After four weeks of trying to figure what was going on Wayne and the others were right this was definately a server problem with our host which they finally admitted MySQL is being restarted during cpanel updates and DB queries made during this time fail. We are running PHP 7.0. What version do you recommend for vbulletin 4.2.5?

                  Comment


                  • #24
                    PHP 7.0.X should be sufficient. You want to run between 5.6.30 and 7.1.9.
                    Translations provided by Google.

                    Wayne Luke
                    The Rabid Badger - a vBulletin Cloud demonstration site.
                    vBulletin 5 API - Full / Mobile
                    Vote for your favorite feature requests and the bugs you want to see fixed.

                    Comment


                    • #25
                      Thanks Wayne.

                      Comment

                      Related Topics

                      Collapse

                      • Paul.
                        Database Error
                        by Paul.
                        Hi,

                        Literally no idea why we're getting problem after problem since upgrading to vB5.
                        Can anyone let me know what happens here? I am not sure if I'm pasting sensitive information. Mods,...
                        Mon 28 Mar '16, 7:41am
                      • vb_nils
                        Mysql error with Sphinx enabled
                        by vb_nils
                        Hello,

                        Since a long time I get sporadic errors emails indicating "Database Error".
                        I finally have time to investigate, and it seems to happen when a user is writting an answer
                        ...
                        Sun 25 Oct '15, 12:06am
                      Working...
                      X