Announcement

Collapse
No announcement yet.

404 Not Found after Server Migration

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 404 Not Found after Server Migration

    Hi all,

    I get 404 not found error in threadlist we recently had to migrate to a new server and I am not sure what's causing this error. Any hints will be highly appreciated. Also some files show up as "not recognized as part of vbulletin" in suspect files diagnostics.

  • #2
    Download a fresh copy of the vB4 files for your version, and upload these to the server, taking care to ensure you overwrite what is already there.
    MARK.B | vBULLETIN SUPPORT

    TalkNewsUK - My vBulletin 5.5.4 Demo
    AdminAmmo - My Cloud Demo

    Comment


    • #3
      Hi Mark, thanks for your fast response. Already did all that still stuck with 404 page. Could it be error in the config file or server misconfiguration?

      Comment


      • #4
        It will be server misconfiguration. A 404 means the file cannot be found.
        MARK.B | vBULLETIN SUPPORT

        TalkNewsUK - My vBulletin 5.5.4 Demo
        AdminAmmo - My Cloud Demo

        Comment


        • #5
          Damn, that's what I thought. Thanks for your time. Any specific direction where I should look? Any hints will be life saving for our community we have been stuck in limbo for days.

          Comment


          • #6
            BTW all 404 error pages on the source server were made to redirect to the main page - index.php but this is not the case on the destination server. Could this be causing problems?

            Comment


            • #7
              It could be.

              We can't really provide server support. Every server is different, and we're not server experts anyway.

              Server issues are better handled by the host.
              MARK.B | vBULLETIN SUPPORT

              TalkNewsUK - My vBulletin 5.5.4 Demo
              AdminAmmo - My Cloud Demo

              Comment


              • #8
                Thank you Mark.

                Comment


                • #9
                  Do you know a reason why user may not be able to upload attachments in social groups - after upload is finished the page goes white and doesn't return errors, redirect or do anything?

                  Comment


                  • #10
                    Originally posted by dmx07 View Post
                    Do you know a reason why user may not be able to upload attachments in social groups - after upload is finished the page goes white and doesn't return errors, redirect or do anything?
                    Check the channel permissions, beyond that I would suggest starting a new thread. Multiple issues in one thread gets confusing for everyone....
                    MARK.B | vBULLETIN SUPPORT

                    TalkNewsUK - My vBulletin 5.5.4 Demo
                    AdminAmmo - My Cloud Demo

                    Comment


                    • #11
                      Thank you and apologies for raising multiple issues at once. Server migrations are nightmare haven't done one in more than ten years.

                      Comment


                      • #12
                        Check the full directory location address. When I migrated, the host changed the forum address correctly but I had to manually change the attachment location... ie... /home/xxxxxold/... to /home/xxxxnew/...

                        Comment


                        • #13
                          Thanks Rob, I will look into that right away.

                          My host is unable to help with the 404 error they haven't a clue how vbulletin works.

                          Comment


                          • #14
                            Originally posted by dmx07 View Post
                            Thanks Rob, I will look into that right away.

                            My host is unable to help with the 404 error they haven't a clue how vbulletin works.
                            They don't need to know how vBulletin works to understand what a 404 is.
                            MARK.B | vBULLETIN SUPPORT

                            TalkNewsUK - My vBulletin 5.5.4 Demo
                            AdminAmmo - My Cloud Demo

                            Comment


                            • #15
                              Hey Mark, yup 404 is...well, 404 still they don't know what to do.

                              Now I am getting #2038 vbulletin error in files manager. I think this is related to the 404 error. What do you think? Any suggestions?

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X