Announcement

Collapse
No announcement yet.

Encoding problem when merging posts, after upgrade

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    I don't mean to press or anything, and I realize that you might have plenty of work, but I have opened a ticket on the 27th of October and I don't see any reply at all, there.

    When can I expect to get any kind of answer there?

    Thanks

    Comment


    • #17
      If someone hasn't picked it up yet, I'll look at it this afternoon. I am really hard pressed for time on new tickets at the moment though. Will get to it as soon as possible.
      Translations provided by Google.

      Wayne Luke
      The Rabid Badger - a vBulletin Cloud demonstration site.
      vBulletin 5 API - Full / Mobile
      Vote for your favorite feature requests and the bugs you want to see fixed.

      Comment


      • #18
        (All the info is there.)

        Comment


        • #19
          Your ticket is assigned to a support staff member. It is best to follow up on the ticket.
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud demonstration site.
          vBulletin 5 API - Full / Mobile
          Vote for your favorite feature requests and the bugs you want to see fixed.

          Comment


          • #20
            Hi,
            I opened this thread on 17 Oct. 2017.

            I opened a ticket on 27 Oct 2017.

            21 November I supplied the last pieces of info etc. that have been asked from me.

            I've been constantly checking ever since, to see how we are progressing with my quite serious problem (that most probably is also affecting registrations, cutting off traffic from my site)

            I can't help but feel that my case has sunk into oblivion.

            I am sure that you all have your plates full and I always try to be polite and understanding but as months go by, how much waiting is reasonable before asking to know about the progress?

            Thanks

            Comment


            • #21
              anyone?

              Comment


              • #22
                You will need to make sure all tables and all fields within each table have the same character set and collation. It is the only fix for mixed collation errors.
                Translations provided by Google.

                Wayne Luke
                The Rabid Badger - a vBulletin Cloud demonstration site.
                vBulletin 5 API - Full / Mobile
                Vote for your favorite feature requests and the bugs you want to see fixed.

                Comment


                • #23
                  But why did the vB update messed the database so bad and now I am charged with such a heavy load?

                  This cannot be the proper way to do things, can it?

                  Anyway, I am willing to follow instructions how to solve all this mess. Can anyone direct me?

                  Comment


                  • #24
                    So, what next?

                    Even if we suppose that you cannot replicate the one symptom (when merging posts; which btw is something we experience on a constant basis) the other half is always there for everyone to see: when you enter extended latin: etc. it appears in html codes: á ó ý í ñ ü etc. (check this thread)

                    It's been months since I mentioned the problem, since I opened a ticket, since I started checking on a very constant basis to see how we are progressing. But it seems that nothing much happens.

                    This problem is connected to registration issues, too, and I'm missing registrations month after month.

                    I mean, I wonder, what do you expect of me? That I will drop the issue and let it slip into oblivion? Or that I will keep checking while growing old? We have to live with the gibberish texts every day.

                    It was October 2017, November came by, then December, then January, it's February 2018 now. The way things are going (they are not) I'm sure that we are going to reach summer, then winter, then yet another year.

                    What next?

                    ( I apologize if I seem to have an attitude. If you scroll up you will notice that I have always tried to be polite and understanding. But now I start to wonder, who is going to show understanding towards my troubles caused by the vB update? )

                    Thanks for your attention.

                    Comment


                    • #25
                      In your version, UTF-8 characters are stored as HTML Entities. This is the same in vBulletin 4.2.2 and vBulletin 4.2.5. The only way to fix the issue is to make sure that every aspect of your server from the operating system to vBulletin is running UTF-8 and that you're using PHP 7 with mbstring and iconv as already stated to you multiple times. We cannot provide a different answer.

                      Operating System: UTF-8
                      Database: UTF-8
                      EVERY TABLE: UTF-8
                      Every Field in every table: UTF-8
                      PHP using iconv and MBString
                      vBulletin Language using a UTF-8 Locale.
                      Every date override filled in to fit your needs.

                      This is the same solution that we've been promoting for UTF-8 issues for years.
                      Translations provided by Google.

                      Wayne Luke
                      The Rabid Badger - a vBulletin Cloud demonstration site.
                      vBulletin 5 API - Full / Mobile
                      Vote for your favorite feature requests and the bugs you want to see fixed.

                      Comment


                      • #26
                        But why has it been working well and got messed after an update, all by itself?

                        I've been following the instructions you give, from day 0. When I installed vB, 10 years back, and before every update, ever since. Checking requirements, too.

                        And this is my biggest reservation. vB messes things, that becomes a major problem to me, my members and the overall performance, but then I'm left alone with a general instruction that bears no practical value.

                        Comment


                        • #27
                          Create backup.
                          Go to AdminCP / Language and Phrases / Download/Upload Languages
                          Download your current Greek language with all products (you may download multiple files, one for whole only vbulletin, one for post thanks, one for another one, ...).
                          Again go to AdminCP / Languages and Phrases / Language Manager
                          Delete Greek Language.
                          Rebuild all languages in this part.
                          If you're using Suite version (Blog+CMS), deactivate them before upgrading (or if you do not use them, delete them)
                          Now run upgrade.
                          You may still have problem with languages and phrases after upgrade.
                          Add
                          Code:
                          define('DISABLE_HOOKS', true);
                          after
                          Code:
                          <?php
                          in /includes/config.php, now it should be like this
                          Code:
                          <?php
                          define('DISABLE_HOOKS', true);
                          If everything is now fine, now go AdminCP / Products and Plugins / Product Manager, and disable CMS and Blog.
                          Change DISABLE_HOOKS like this
                          Code:
                          //define('DISABLE_HOOKS', true);
                          Now see if everything works fine. If yes, Now again add Greek language you've downloaded before.

                          Comment


                          • #28
                            Hi Saeed and thanks for trying to help. Usually I am very reluctant to follow any other's instructions that the staff's. Of course, now that I am practically left alone, in a problem caused by the software itself (other greek forum's suffer by such problems, too) I suppose I might have to reconsider.

                            Would you mind telling me why you are proposing these instructions? What do you think this is going to work for me?

                            Comment


                            • #29
                              I understand you dimitrios. I'm not the staff here, but I'm the staff of some Persian and Iranian forums in my country Iran, and what I told you is my experience of some situations in such matters.
                              You may submit a ticket at vbulletin.com or re-open the current one, but what I told is the thing that have been worked in some forums and have not been worked in some other forums (because the solution of theirs was something else).
                              Please do this, if it didn't work, I'll tell you the other way.

                              Comment


                              • #30
                                Dear Saeed, I am so pissed off by vBulletin, I cannot tell you.

                                I wish I had used some other software back then. I have paid for it twice (v. 3 and v. 4) and I'm stuck with buggy software, with no real support about those bugs, and it's not even responsive! To get a responsive version I need to buy it again (v. 5) which I might have done already if I didn't know another Greek forum that is practically dying because of the v.5 bugs. It's been two years now and they are still fighting with the bugs.

                                And all that when my other phpBB forum has costed me nothing, works perfectly fine, has none of all these encoding bugs and troubles, and is responsive (!) and all that... for free.

                                I have weighted migrating to other software but that's a major operation by itself and I'm also afraid about how google is going to react to the change of the thread URLs. Of course, the migration option remains on the table since my forum looks out of date and it is problematic. Members keep complaining about not being able to register and we cannot even write properly in posts.

                                Anyway. Since, I am practically left alone by the staff, I will proceed with your instructions. Please, do check for my progress here, now and then.

                                Thanks a lot for trying to help. I appreciate it.
                                Last edited by dimitrios; Mon 19th Feb '18, 8:55am.

                                Comment

                                Related Topics

                                Collapse

                                Working...
                                X