Announcement

Collapse
No announcement yet.

vBulletin 4.2.5 and HTTPs Mixed Content Issue with Skimlinks

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] vBulletin 4.2.5 and HTTPs Mixed Content Issue with Skimlinks

    I use the default vBulletin Skimlinks plugin and am just about to move my site over to HTTPS from HTTP, although during testing I noticed that it adds this code at the bottom of pages and the source call is to http rather than https (i.e. mixed content warnings).

    Code:
    <script type="text/javascript">   
      		var noskimlinks = false, 			noskimwords = false, 			skimlinks_product = 'vbulletin';  		vBulletin.events.SkimlinksActivate.fire();  	</script> 	<script type="text/javascript" src="http://s.skimresources.com/js/5630X653681.skimlinks.js"></script>
    So my question is, where can I edit that src="" call so that I can change http:// to https:// and call the secure script instead?

  • #2
    You can edit this in:

    \packages\skimlinks\hooks\showthread_complete.php
    Vote for:

    - *Admin Settable Paid Subscription Reminder Timeframe*
    -
    *PM - Add ability to reply to originator only*
    - Add Admin ability to auto-subscribe users to specific channel(s)
    - "Quick Route" Interface...

    Comment


    • #3
      Originally posted by mark99 View Post
      I use the default vBulletin Skimlinks plugin and am just about to move my site over to HTTPS from HTTP, although during testing I noticed that it adds this code at the bottom of pages and the source call is to http rather than https (i.e. mixed content warnings).

      Code:
      <script type="text/javascript">
      var noskimlinks = false, noskimwords = false, skimlinks_product = 'vbulletin'; vBulletin.events.SkimlinksActivate.fire(); </script> <script type="text/javascript" src="http://s.skimresources.com/js/5630X653681.skimlinks.js"></script>
      So my question is, where can I edit that src="" call so that I can change http:// to https:// and call the secure script instead?
      Did you get this working mark99 ? I edited the showthread_complete.php and cleared the cache, but it's still loading as http. Do I need to reinstall the plugin or something?
      http://www.bordersdown.net - 10 years of videogame reviews and chat

      Comment


      • #4
        You will need to edit the file as per Trevor's comment.
        MARK.B | vBULLETIN SUPPORT

        TalkNewsUK - My vBulletin 5.6.2 Demo
        AdminAmmo - My Cloud Demo

        Comment


        • #5
          Figured it out. Trevor's file edit was working fine in the forums that were skimlinks enabled, but I had hard coded the footer template with to always fire the skimlinks on all articles, which is set as the homepage, with a conditional on product type = CMS. As you can imagine, I was tearing my hair out for a bit! If in doubt though, it's always a hard coding thing......
          http://www.bordersdown.net - 10 years of videogame reviews and chat

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X