Announcement

Collapse
No announcement yet.

incorrect time after update 4.2.5

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • incorrect time after update 4.2.5

    i update my forum to 4.2.5
    now incorrect time show on Asia/Kolkata timezone.
    time is running delay by 30 minutes
    i set time zone to +5.30 Asia/kolkata but forum display timezone +5. only
    i unable to set +5.30 timezone.

    its a bug in 4.2.5
    please tell me how can i fix it.

  • #2
    vBulletin takes its time from the server. There is no bug that would cause this.

    You should speak to your host and ensure the server time is correct.

    MARK.B | vBULLETIN SUPPORT

    TalkNewsUK - My vBulletin 5.6.4 Demo
    AdminAmmo - My Cloud Demo

    Comment


    • #3
      Originally posted by Mark.B View Post
      vBulletin takes its time from the server. There is no bug that would cause this.

      You should speak to your host and ensure the server time is correct.
      for testing perpose i install 2 diffrant version on same server.
      same issue on vb 4.2.5 and correct time show on 4.2.2

      here is testing link for
      vb 4.2.2 test link http://www.xdafile.com/vb/forum.php
      vb 4.2.5 test link http://www.xdafile.com/vb4/forum.php

      Comment


      • #4
        if you need login detail for both site and server, i can pm you

        Comment


        • #5
          https://www.vbulletin.org/forum/show...64#post2589264
          This is my signature.

          Comment


          • #6
            i know because both thread made by me. i need solution

            Comment


            • #7
              If what stingray27 says is correct, then there isn't anything we can do about this. There is no development now on vBulletin 4.
              MARK.B | vBULLETIN SUPPORT

              TalkNewsUK - My vBulletin 5.6.4 Demo
              AdminAmmo - My Cloud Demo

              Comment


              • #8
                There is no more official development on VB 4.x but if you post a thread on vBulletin.org and link it from here, explain the issue, I (or someone) might be able to make a plugin for your site to fix the time for users who have a specific timezone selected or some other kind of work-around.

                For what it's worth the bug isn't unique to that timezone. No timezone with an offset other than a full number of hours work. For example Caracus is -4:30, the 30 doesn't work. Another is +5:45, the 45 doesn't work. An unfortunate bug missed before 4.2.5 was finalized.
                Last edited by BirdOPrey5; Thu 10 Aug '17, 1:25pm.

                Comment


                • #9
                  anybody is here to help me with fix this problem

                  Comment


                  • #10
                    Originally posted by Joe D. View Post
                    There is no more official development on VB 4.x but if you post a thread on vBulletin.org and link it from here, explain the issue, I (or someone) might be able to make a plugin for your site to fix the time for users who have a specific timezone selected or some other kind of work-around.

                    For what it's worth the bug isn't unique to that timezone. No timezone with an offset other than a full number of hours work. For example Caracus is -4:30, the 30 doesn't work. Another is +5:45, the 45 doesn't work. An unfortunate bug missed before 4.2.5 was finalized.
                    i already made a thread on vbulletin.org. by misktake i made that thread on wrong section
                    here is link
                    https://www.vbulletin.org/forum/showthread.php?t=325494

                    please make a plugin to fix my problme

                    thanks

                    Comment


                    • #11
                      At this point any help will come from vBulletin.org. If we get a fix I (or someone) will post it back here for others who may have the same issue.

                      Comment


                      • #12
                        I found a fix that resolves most of the issue. Calendar events will still not be correct if the time of the event is entered by someone from one of these time zones that aren't whole hours apart.


                        Line 4503 of /includes/functions.php to get the time working on (most of) the site.

                        Change:

                        Code:
                        $tzos = [COLOR=Red]intval[/COLOR]($vbulletin->userinfo['timezoneoffset']);
                        to

                        Code:
                        $tzos = [COLOR=Blue]floatval[/COLOR]($vbulletin->userinfo['timezoneoffset']);
                        Unfortunately I don't see any way to make this a plugin, the manual edit is necessary.

                        There hasn't been a lot of testing. If you notice any new problems please post them ASAP at https://www.vbulletin.org/forum/showthread.php?t=325494

                        Comment


                        • #13
                          Originally posted by Joe D. View Post
                          I found a fix that resolves most of the issue. Calendar events will still not be correct if the time of the event is entered by someone from one of these time zones that aren't whole hours apart.


                          Line 4503 of /includes/functions.php to get the time working on (most of) the site.

                          Change:

                          Code:
                          $tzos = [COLOR=Red]intval[/COLOR]($vbulletin->userinfo['timezoneoffset']);
                          to

                          Code:
                          $tzos = [COLOR=Blue]floatval[/COLOR]($vbulletin->userinfo['timezoneoffset']);
                          Unfortunately I don't see any way to make this a plugin, the manual edit is necessary.

                          There hasn't been a lot of testing. If you notice any new problems please post them ASAP at https://www.vbulletin.org/forum/showthread.php?t=325494
                          thanks, its work for me, now time is perfect but time zone not show 5.30 its show 5. only
                          please if its possible then fix it

                          Comment

                          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                          Working...
                          X