Announcement

Collapse
No announcement yet.

IPN not working on 4.2.4.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    I'm only really speculating on this. We have a huge number of vB4 users and I'd expect someone else to mention this.

    I will bring this up internally to see if we can test it.
    MARK.B | vBULLETIN SUPPORT

    TalkNewsUK - My vBulletin 5.5.4 Demo
    AdminAmmo - My Cloud Demo

    Comment


    • #17
      Thank you. We have multiple large forums that we currently run vb4 on. Wish that you would extend support on it. We would be willing to pay. We just don't find 5 to be a feasible solution for us.

      Comment


      • #18
        I'm unsure exactly what changes PayPal made but it does look like it may be the cause. There are some similar issues with vB5 at the moment also.

        Unfortunately, whilst we still support vB4 in terms of product support etc, there is literally no development work on vB4 now so our hands our very much tied. 4.2.5 was the final release in the vB4 series.
        MARK.B | vBULLETIN SUPPORT

        TalkNewsUK - My vBulletin 5.5.4 Demo
        AdminAmmo - My Cloud Demo

        Comment


        • #19
          The paypal code doesnt handle the txn_type of "subscr_failed".

          Since that means the payment failed, it doesnt matter too much, its the same as them never paying.
          This is my signature.

          Comment


          • JoeZ
            JoeZ commented
            Editing a comment
            Even successful payments aren't posting. Hm. Thanks for the info Mark.B vb4 was good to us but it seems it's time to set sail.

          • stingray27
            stingray27 commented
            Editing a comment
            You havent provided any logs or evidence on successful payments failing so cannot say anything about that.

        • #20
          Whilst no development work is planned for vB4, it would certainly be worth raising this as a bug so that management have visibility of the issue.

          Nothing is planned but never say never. If the issue is logged in the tracker there is always a chance, however slim. If it's not there then there's 100% no chance, so I'd give it a go.
          MARK.B | vBULLETIN SUPPORT

          TalkNewsUK - My vBulletin 5.5.4 Demo
          AdminAmmo - My Cloud Demo

          Comment


          • #21
            Originally posted by stingray27 View Post
            The paypal code doesnt handle the txn_type of "subscr_failed".

            Since that means the payment failed, it doesnt matter too much, its the same as them never paying.
            To answer your question. PayPal is showing a 503 error response code but when I contacted my server admin they said that the paypal connection error is showing as a 301 in the logs.. really stumped.

            Comment


            • #22
              ????

              I didnt ask a question.
              This is my signature.

              Comment


              • #23
                Mark.B can you put me in contact with a person that can fix this? We are willing to pay to have it corrected.

                Comment


                • #24
                  Originally posted by JoeZ View Post
                  Mark.B can you put me in contact with a person that can fix this? We are willing to pay to have it corrected.
                  Common man.. at least point me in the right direction. I WANT TO PAY. Things here are really fallen off huh? vb.org may as well be dead after the exodus,

                  Comment


                  • #25
                    Originally posted by JoeZ View Post

                    Common man.. at least point me in the right direction. I WANT TO PAY. Things here are really fallen off huh? vb.org may as well be dead after the exodus,
                    We do not offer paid coding services, nor can we recommend anybody.

                    we do have a "Paid Requests" section over on www.vbulletin.org, that's probably the best place start.
                    MARK.B | vBULLETIN SUPPORT

                    TalkNewsUK - My vBulletin 5.5.4 Demo
                    AdminAmmo - My Cloud Demo

                    Comment


                    • #26
                      VB 4.2.5
                      includes/paymentapi/class_paypal.php

                      I was able to get the Payment API to pass (check mark) by changing the url in line 74 and 191 to 'http://www.paypal.com/cgi-bin/webscr', neither https://www or https://ipnpb will pass the Payment API diagnostic in VBulletin.

                      In line 233 I left the url as 'https://www.paypal.com/cgi-bin/webscr'. http://www will also pass the diagnostic, but will give the "unsecure" nag screen in Firefox and, I suppose, other browsers when users try to submit to paypal.

                      I also own a VB5 license, same thing, actually, the same url's allow it to pass the paypal diagnostic in VB5

                      For what it's worth.


                      Comment


                      • #27
                        Thanks but that still doesnt fix the issue.. can't believe no one is having this issue?

                        Comment


                        • #28
                          Did you get this working? I also have vb 4.2.5 and accept paypal payments and have the same problem. Members are paying via the Paid Subscriptions system, but members are not being added to the premium usergroup any more. This used to work perfectly in the past.

                          In PayPal on the Instant Payment Notification (IPN) page, I have the following settings:

                          Current settings
                          Notification URL https://www.mydomain.com/forum/payme...?method=paypal
                          Message delivery Enabled

                          Is this correct? If not, what should it be? My forum is running on a secure server.

                          I really need to get the payment processor working properly, I am doing it by hand at the moment.

                          If Vbulletin are refusing to fix this for vb 4.2.5, have they fixed this for vb 5 and if so, can we just transfer the fix over to vb 4.2.5. I am sure this is affecting a lot of vb 4 customers.
                          Regards

                          Peter Walker
                          http://www.rifeforum.com

                          Comment


                          • #29
                            Check here as this might be your problem/fix: https://www.vbulletin.com/forum/foru...24#post4341524

                            Comment

                            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                            Working...
                            X