Announcement

Collapse
No announcement yet.

Email Notification to subscribed forum sections not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Email Notification to subscribed forum sections not working

    I have noticed that email notifications to subscribed forum sections is not working, but notifications to individual threads is working fine.

    Also when I go to pathtoforum/subscription.php? it lists all the subscribed threads but to show the subscribed forum sections I have to go to pathtoforum/usercp.php is this correct?

    I'm not sure if this has arisen since moving to v4.2.5 a couple of weeks ago....

    Any ideas folks?

  • #2
    I have now had a few members raise this problem with me, so I'm guessing this is an issue with the latest version 4.2.5.

    Does anyone here know if there is a 'fix' planed for this bug?

    Comment


    • #3
      At this time there is no further development for vBulletin 4.X scheduled. vBulletin 4, doesn't send forum emails out on every new post. If your site did in the past then it was through an addon.

      Are your scheduled tasks running correctly? When is the last time that the Daily Digest and Weekly Digest tasks ran? Schedule Tasks -> Scheduled Task Manager.
      Translations provided by Google.

      Wayne Luke
      The Rabid Badger - a vBulletin Cloud customization and demonstration site.
      vBulletin 5 Documentation - Updated every Friday. Report issues here.
      vBulletin 5 API - Full / Mobile
      I am not currently available for vB Messenger Chats.

      Comment


      • #4
        Originally posted by Wayne Luke View Post
        At this time there is no further development for vBulletin 4.X scheduled. vBulletin 4, doesn't send forum emails out on every new post. If your site did in the past then it was through an addon.
        Hi Wayne, thanks for the reply.

        Out of the box the standard vB software allows members to subscribe to individual threads or complete sections, this isn't an add on.

        If a member subscribed to a thread and they have chosen 'instant notification' then they will receive an email informing them of the reply almost instantly. That still works fine now.

        If they subscribe to a forum section they have the choice of receiving 'Daily' or 'Weekly' notifications. This will either send them a daily or weekly update of what has changed in the section. Ths is what is no longer working.

        On another site I run on vB 3.8.11 this is still working.

        It used to work fine on 4.2.3 but has now stopped working on 4.2.5

        The Daily Digest and Weekly Digest tasks both run at 01:00, they both ran this morning.

        Hope this helps.

        Comment


        • #5
          Originally posted by Bat21 View Post
          Does anyone here know if there is a 'fix' planed for this bug?
          Assuming for a minute it actually turns out to be a bug - how would anyone have planned a fix for a bug they didnt know about ?


          Baby, I was born this way

          Comment


          • #6
            When is the last time the Scheduled Tasks to send the digests ran? How many emails do you have in your email queue? How many emails do you process at a time?
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud customization and demonstration site.
            vBulletin 5 Documentation - Updated every Friday. Report issues here.
            vBulletin 5 API - Full / Mobile
            I am not currently available for vB Messenger Chats.

            Comment


            • #7
              Originally posted by Paul M View Post
              Assuming for a minute it actually turns out to be a bug - how would anyone have planned a fix for a bug they didnt know about ?
              Sorry Paul, I wasn't sure if this was a known issue or not, I guess my question should have been worded "Does anyone here know if this is a known bug or if there is a 'fix' planed for this?".


              Originally posted by Wayne Luke View Post
              When is the last time the Scheduled Tasks to send the digests ran? How many emails do you have in your email queue? How many emails do you process at a time?
              As I said above, the Daily Digest and Weekly Digest tasks both run at 01:00, they both ran this morning. There are no emails waiting in the queue, I'm not sure how many get processed at a time.

              Since my last post I have a little more info if it helps. On another 4.2.5 site I run I subscribed to a forum section to test that one. After subscribing I didn't go back to the site for a day, interestingly that DID send me a notification of all new threads and replies to old ones in that section.

              Is it possible that the notification changes to 4.2.5, being database rather than cookie based, are effecting this?

              Just to clarify, thread reply notifications are working but notifications to new or appended threads are not working as they used to.

              Hope this makes sense.

              Comment


              • #8
                Anyone else having this problem?

                There is definitely a problem with notifications when subscribed to a forum section.

                Comment


                • #9
                  After reading another post I have solved this bug by overwriting the includes/functions_digest.php with the one from v4.2.3.

                  As there are obviously differences between the includes/functions_digest.php in v4.2.5 would it be possible for one of you guys to bug fix the 4.2.5 one, or am I okay just to leave the 4.2.3 one in place?

                  Comment


                  • #10
                    Looking at the changes it seems like one of the cases where some code got half merged.

                    The effect is basically that it will never work - unfortunately, this is another case of something that was never spotted until now.

                    The fix is to revert to the 4.2.4 version of the file.
                    Baby, I was born this way

                    Comment


                    • #11
                      Originally posted by Paul M View Post
                      Looking at the changes it seems like one of the cases where some code got half merged.

                      The effect is basically that it will never work - unfortunately, this is another case of something that was never spotted until now.

                      The fix is to revert to the 4.2.4 version of the file.
                      Thank you for clarifying that Paul.

                      In the other thread you say functions_digest.php in 4.2.3 & 4.2.4 are identical, see below.
                      Given this, is there any point putting replacing v4.2.3 with v4.2.4 of the functions_digest.php file on my server?


                      Originally posted by Paul M View Post
                      There were no changes to functions_digest.php in 4.2.4 - the 4.2.4 & 4.2.3 versions are identical.

                      In fact that file is unchanged as far back as 4.1.5.

                      Comment


                      • #12
                        Originally posted by Bat21 View Post
                        is there any point putting replacing v4.2.3 with v4.2.4 of the functions_digest.php file on my server?
                        Nope, there would be no point in doing that.

                        Baby, I was born this way

                        Comment


                        • #13
                          Originally posted by Bat21 View Post
                          Anyone else having this problem?

                          There is definitely a problem with notifications when subscribed to a forum section.
                          Scheduled Task work not
                          Dutch Online Computer hulp - www.pctuts.be

                          Comment


                          • #14
                            Originally posted by bollie View Post

                            Scheduled Task work not
                            This issue is resolved, see post #9

                            Comment


                            • #15
                              #9 work not
                              Dutch Online Computer hulp - www.pctuts.be

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X