Announcement

Collapse
No announcement yet.

DEV Site - CMS linking to Production

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [CMS] DEV Site - CMS linking to Production

    Not sure what to do at this point.

    I have cloned my database and installation, shifted my IIS vars so I am using www.stage. versus www., and the site loads fine when going to forum.php, etc. However, if I just go directly to the articles or content.php section it redirects to the current production site at www.

    I have gone through the database on stage and it has stage set to the forum url, even set it for the CMS url for kicks. Still redirects. Any ideas?
    Last edited by joshtrav; Tue 30th May '17, 4:49pm.

  • #2
    vBulletin uses the /includes/config.php file to tell it which database to connect to. If you haven't changed this, then your site is connecting to the live database.
    You also need to update the URL settings in the admincp.
    MARK.B | vBULLETIN SUPPORT

    TalkNewsUK - My vBulletin 5.5.4 Demo
    AdminAmmo - My Cloud Demo

    Comment


    • #3
      Originally posted by Mark.B View Post
      vBulletin uses the /includes/config.php file to tell it which database to connect to. If you haven't changed this, then your site is connecting to the live database.
      You also need to update the URL settings in the admincp.
      The sites are hosted on segregated VMs, each with its own mysql install. The databases are completely independent, both pointed to the correct one. I have set URL settings in the admincp to the correct location. The only issue remaining is the CMS side of vBulletin. Is there an additional location where it would have a url setting, not within the base "all settings" area of the admincp?

      Comment


      • #4
        Originally posted by joshtrav View Post

        The sites are hosted on segregated VMs, each with its own mysql install. The databases are completely independent, both pointed to the correct one. I have set URL settings in the admincp to the correct location. The only issue remaining is the CMS side of vBulletin. Is there an additional location where it would have a url setting, not within the base "all settings" area of the admincp?
        I had this same problem when I made my dev site a few days ago. Even though each had it's own SQL table, the CMS redirected to the old site because of the htacess. When I removed the htacess, it came up with a 404 error until I moved the dev site out of public_html into a folder a level above. I don't know if that's your problem too but check your htaccess. Mine was full of redirects for the CMS and for SSL.

        I'm able to have the exact same settings on both the production and dev site now too. The only different thing I did was set the cookie on the dev site to / so it would be a different cookie than on production.

        Comment


        • #5
          Using IIS 8. I checked my URL rewrites and had none. Checked for any htaccess files in case it may be parsing them (I don't have that module enabled, but checked anyway) and found none. Also did a regex across the 20000 files on the stage site for the generic site name, and found none. Still at a loss.

          Comment


          • #6
            vBulletin 4 has a CMS URL option. In case you want to run the CMS elsewhere. Settings -> Options -> Site Name / URL / Contact Details -> CMS Component URL. Make sure it is set correctly.
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud customization and demonstration site.
            vBulletin 5 Documentation - Updated every Friday. Report issues here.
            vBulletin 5 API - Full / Mobile
            I am not currently available for vB Messenger Chats.

            Comment


            • #7
              Originally posted by Wayne Luke View Post
              vBulletin 4 has a CMS URL option. In case you want to run the CMS elsewhere. Settings -> Options -> Site Name / URL / Contact Details -> CMS Component URL. Make sure it is set correctly.
              That was set to the new environment as well, just to rule it out. After a lot of tinkering, it looks like the default cookie path, even when swapping it to the new .stage environment in the admincp was having issues. I had to adjust it to a custom value in order to use a zoned (sub-sub) domain approach. This seemed to have resolved the issue.

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X