Announcement

Collapse
No announcement yet.

Error with 4.2.5 after logging out (400 Bad Request and suddenly 443 port added to URL)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • dan325ci
    replied
    Originally posted by Paul M View Post
    All the required modules are not there - your php installation is missing php-mbstring.

    Here are a couple of my new errors:


    Code:
    [18-May-2017 04:01:44 UTC] PHP Warning:  system(): Cannot execute a blank command in /home/username/public_html/forum/global.php(29) : eval()'d code on line 2
    [18-May-2017 04:01:46 UTC] PHP Warning:  PHP Startup: Unable to load dynamic library '/opt/cpanel/ea-php56/root/usr/lib64/php/modules/php_mbstring.dll' - /opt/cpanel/ea-php56/root/usr/lib64/php/modules/php_mbstring.dll: cannot open shared object file: No such file or directory in Unknown on line 0
    Last edited by dan325ci; Wed 17th May '17, 9:06pm.

    Leave a comment:


  • Paul M
    replied
    All the required modules are not there - your php installation is missing php-mbstring.

    Leave a comment:


  • Error with 4.2.5 after logging out (400 Bad Request and suddenly 443 port added to URL)

    I have all kinds of new errors after upgrading to 4.2.5 and using PHP 7.0 with it.

    Here is one of them.

    After clicking the logout button from the admincp i get the below error and my URL field suddenly becomes http://www.myforumdomain.com:443/admincp/index.php: ...notice the "443" there. I have no idea why this is happening and the below error.


    400 Bad Request

    The plain HTTP request was sent to HTTPS port




    When i try to go back to PHP 5.6, it is now giving me these errors:

    [18-May-2017 02:58:22 UTC] PHP Warning: system(): Cannot execute a blank command in /home/username/public_html/forum/global.php(29) : eval()'d code on line 2
    [18-May-2017 02:58:22 UTC] PHP Fatal error: Call to undefined function mb_detect_encoding() in /home/username/public_html/forum/includes/functions.php on line 729



    The line 729 error is related to this line of code:

    Code:
        if (mb_detect_encoding($text) == 'UTF-8')

    Then i have many small errors such as the Recaptcha no longer working. I have made sure that all the required PHP modules are there also.
    Last edited by dan325ci; Wed 17th May '17, 8:09pm.

Related Topics

Collapse

Working...
X