Announcement

Collapse
No announcement yet.

WYSIWYG Editor suddenly stopped working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • dan325ci
    replied
    Originally posted by Wayne Luke View Post
    It should have either http or https as specified by the comment. It isn't a URL.
    Ok thank you.

    Yes i can now confirm 100% this helps to fix the issue without having to change any other codes. I have tested this only on PHP 5.6. Not sure about PHP 7.0+ but i imagine its the same result.


    Update: Tested on PHP 7.x and its working fine still. Also, can now click on a username to edit their profile without any https errors. So, overall, good all around.
    Last edited by dan325ci; Thu 18 May '17, 3:05pm.

    Leave a comment:


  • Wayne Luke
    replied
    It should have either http or https as specified by the comment. It isn't a URL.

    Leave a comment:


  • dan325ci
    replied
    Originally posted by Paul M View Post

    Yes, that option.

    Make sure you have added it to your actual config file (copy it from the example). It was only added in 4.2.5.

    Given how the code works, it find it hard to believe it doesnt fix the basepath. Since it does on every test forum I have.

    Yes, i uncommented that line out and it didnt work.

    Do i actually have to put my whole forum url there like this:

    $config['Misc']['vb_url_scheme'] = 'https://myforums.com';



    Just an FYI: We are using Cloudflare if that matters at all.....

    Leave a comment:


  • Paul M
    replied
    Originally posted by dan325ci View Post

    Paul,

    You are referring to this in the config file right?

    Code:
    /* #### FORCE URL SCHEME ####
    By default, vBulletin will try and work out what URL scheme to use (http or https) by checking the incoming page request.
    However, in some circumstances, this can fail. You can force the scheme to 'http://' or 'https://' using the below setting. */
    //$config['Misc']['vb_url_scheme'] = 'https://';

    I have always just changed my path in the admin panel, i never knew about this setting. So just uncomment that $config line out?



    UPDATE: uncommented the above but it still did not work after reverting my changes.
    Yes, that option.

    Make sure you have added it to your actual config file (copy it from the example). It was only added in 4.2.5.

    Given how the code works, it find it hard to believe it doesnt fix the basepath. Since it does on every test forum I have.

    Leave a comment:


  • Mark.B
    replied
    Yes, uncomment it.

    Leave a comment:


  • dan325ci
    replied
    Originally posted by Paul M View Post
    That's an unnecessary (and wrong) change.

    Set the correct option in the 4.2.5 config file, and revert the change.
    Paul,

    You are referring to this in the config file right?

    Code:
    /* #### FORCE URL SCHEME ####
    By default, vBulletin will try and work out what URL scheme to use (http or https) by checking the incoming page request.
    However, in some circumstances, this can fail. You can force the scheme to 'http://' or 'https://' using the below setting. */
    //$config['Misc']['vb_url_scheme'] = 'https://';

    I have always just changed my path in the admin panel, i never knew about this setting. So just uncomment that $config line out?



    UPDATE: uncommented the above but it still did not work after reverting my changes.
    Last edited by dan325ci; Wed 17 May '17, 11:35am.

    Leave a comment:


  • Paul M
    replied
    That's an unnecessary (and wrong) change.

    Set the correct option in the 4.2.5 config file, and revert the change.

    Leave a comment:


  • dan325ci
    replied
    Originally posted by Wayne Luke View Post

    Interesting, as the problem shouldn't occur with NONE if you have updated your forum URL in the settings to reflect HTTPS.
    Ok i was completely mistaken. Turns out I never reverted the class_bootstrap.php file back to original. Changing REMOTE YUI to Google does not help at all. It turns out that the only way to get the WYSIWYG editor to work is to replace the following in class_bootstrap.php:


    Code:
    $templater->register('ajaxbaseurl', VB_URL_BASE_PATH);

    with


    Code:
    $templater->register('ajaxbaseurl', $vbulletin->input->fetch_basepath());


    Remote YUI actually does not help at all. Sorry for all the confusion. I am still back to square one now with no resolution except editing the above file.

    Leave a comment:


  • Wayne Luke
    replied
    Originally posted by dan325ci View Post

    From what i can tell, that fixed it up. We had it set to NONE before. Thank you.
    Interesting, as the problem shouldn't occur with NONE if you have updated your forum URL in the settings to reflect HTTPS.

    Leave a comment:


  • dan325ci
    replied
    Originally posted by Mark.B View Post
    Go to Settings > Options > Server Settings & Optimization Options > Use Remote YUI
    Make sure this is set to Google.
    From what i can tell, that fixed it up. We had it set to NONE before. Thank you.

    Leave a comment:


  • Mark.B
    replied
    Go to Settings > Options > Server Settings & Optimization Options > Use Remote YUI
    Make sure this is set to Google.

    Leave a comment:


  • dan325ci
    replied
    Just updated to 4.2.5 and still getting the WYSIWYG editor problem unless i implement the fix here: http://tracker.vbulletin.com/browse/VBIV-15721

    Any ideas what next?

    Leave a comment:


  • dan325ci
    replied
    Originally posted by Paul M View Post
    You are probably using off-loaded https (Cloudflare Flexible ?)

    Turning on the "Always use Forum URL as Base Path" option will likely fix it.

    (and undo whatever "fix" you made).
    Yes we have a Cloudflare SSL certificate we purchased from them. (but that was many months ago, well before this issue started)

    The "Always use Forum URL as Base Path" was already set to YES

    Any ideas now what?

    Leave a comment:


  • Paul M
    replied
    You are probably using off-loaded https (Cloudflare Flexible ?)

    Turning on the "Always use Forum URL as Base Path" option will likely fix it.

    (and undo whatever "fix" you made).

    Leave a comment:


  • dan325ci
    replied
    Originally posted by Mark.B View Post
    This shouldn't be happening. I have converted multiple vB 4 sites to HTTPS without any effect on the editor.
    However, I have seen several reports of this behaviour, so it would be interesting to find out what is really going on, since I just can't replicate it.

    What version of vBulletin are you running?
    Right now we are running the latest stable version of 4.2.4.

    I am not 100% sure if the move to https is the cause or not. I just recently noticed that the WYSIWYG editor was even missing although we converted to HTTPS a couple months ago. Having said that, I didn't make any changes lately so it may have been like this for a while.

    Leave a comment:

Related Topics

Collapse

Working...
X