Announcement

Collapse
No announcement yet.

Metadata redirection in CMS subsections

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [CMS] Metadata redirection in CMS subsections

    Hi,

    I have a problem with the metadata in the CMS subsections. When I use facebook debugger or similar, I can see that the CMS subsections pages makes a metadata redirection, and I can't catch the section metadata title, keywords and description, always catch the Home metadata.

    I tried to look up the redirection but can not find in templates. Inside the articles or other parts the metadta work good, the problem is only with subsections.

    Thanks for your support.
    Regards.

  • #2
    What exactly is your question ?
    Baby, I was born this way

    Comment


    • #3
      Originally posted by Paul M View Post
      What exactly is your question ?
      I can not find where the meta/redirection is performed, I need section metadata without redirection. Do you know where can be generated this redirection?

      Only appens in CMS subsections.

      Comment


      • #5
        Originally posted by PedroMA View Post
        Hi,

        I have a problem with the metadata in the CMS subsections. When I use facebook debugger or similar, I can see that the CMS subsections pages makes a metadata redirection, and I can't catch the section metadata title, keywords and description, always catch the Home metadata.
        Originally posted by Paul M View Post
        What exactly is your question ?
        Originally posted by Trevor Hannant View Post
        Can you give us a link to where to see this?
        I can understand the question that the OP is asking above

        because I also am seeing this problem with my vB 4.2.x

        for example with this post on my vB4 forum

        http://www.webmastersun.com/threads/...B-vs-vBulletin

        when submitting it on Facbeook, Google+, Linkedin or other social networks...then it is showing forum description or forum homepage description instead of showing a short description/content on that thread.

        Here's the screenshot what I am talking about.

        Click image for larger version

Name:	social-networks-og-meta-data.png
Views:	7
Size:	79.7 KB
ID:	4357662
        Best Internet Marketing Forum & Webmaster Forum for webmasters and Internet Marketers discussing and trading!

        Comment


        • #6
          Originally posted by Trevor Hannant View Post
          Can you give us a link to where to see this?
          Hi Trevor

          This is our website: https://guitarbend.com/Magazine/

          If you enter in any post, the metadata works good (works ok in forum sections, forum threads, gallery, blog, CMS articles, etc.. ), except in the CMS subsections. For example, if you check the metadata of this CMS subsection:

          https://guitarbend.com/779-secciones...cas-musicales/

          You can see in the attach file that de facebook get the global metadata, not the subsection metadata.

          Click image for larger version  Name:	Captura de pantalla 2016-10-25 a las 16.22.21.jpg Views:	2 Size:	124.5 KB ID:	4357670
          Attached Files
          Last edited by PedroMA; Tue 25th Oct '16, 6:29am.

          Comment


          • #7
            Originally posted by webmastersun View Post





            I can understand the question that the OP is asking above

            because I also am seeing this problem with my vB 4.2.x

            for example with this post on my vB4 forum

            http://www.webmastersun.com/threads/...B-vs-vBulletin

            when submitting it on Facbeook, Google+, Linkedin or other social networks...then it is showing forum description or forum homepage description instead of showing a short description/content on that thread.

            Here's the screenshot what I am talking about.

            Click image for larger version

Name:	social-networks-og-meta-data.png
Views:	7
Size:	79.7 KB
ID:	4357662
            Hi!

            In my case the problem is only with subsections. In other places work good.

            Regards.

            Comment


            • #8
              Originally posted by webmastersun View Post
              for example with this post on my vB4 forum

              http://www.webmastersun.com/threads/...B-vs-vBulletin

              when submitting it on Facbeook, Google+, Linkedin or other social networks...then it is showing forum description or forum homepage description instead of showing a short description/content on that thread.

              Here's the screenshot what I am talking about.

              Click image for larger version

Name:	social-networks-og-meta-data.png
Views:	7
Size:	79.7 KB
ID:	4357662
              In that example its pulling the description from the [facebook] Open Graph Meta information, which is always generic on vB4.
              Baby, I was born this way

              Comment


              • #9
                Originally posted by Paul M View Post

                In that example its pulling the description from the [facebook] Open Graph Meta information, which is always generic on vB4.
                And in my example?

                Comment


                • #10
                  Originally posted by PedroMA View Post

                  And in my example?
                  Well it's the same issue.
                  MARK.B | vBULLETIN SUPPORT

                  TalkNewsUK - My vBulletin 5.5.4 Demo
                  AdminAmmo - My Cloud Demo

                  Comment


                  • #11
                    Originally posted by Mark.B View Post

                    Well it's the same issue.
                    And why in other sections I can get the vbulletin section metadata and facebook og catch the correct information?

                    Comment


                    • #12
                      Originally posted by PedroMA View Post

                      And why in other sections I can get the vbulletin section metadata and facebook og catch the correct information?
                      In truth, it's either how it was coded, or possibly Facebook changed something. They do that a lot.
                      The reality is, it almost certainly won't get changed in vB4 now.
                      MARK.B | vBULLETIN SUPPORT

                      TalkNewsUK - My vBulletin 5.5.4 Demo
                      AdminAmmo - My Cloud Demo

                      Comment


                      • #13
                        The Facebook code does the same everywhere, so I'd guess its picking up a description from somewhere else.

                        You are free to view the source code on the page and see, just like i did.
                        Baby, I was born this way

                        Comment


                        • #14
                          Originally posted by Mark.B View Post

                          In truth, it's either how it was coded, or possibly Facebook changed something. They do that a lot.
                          The reality is, it almost certainly won't get changed in vB4 now.

                          Therefore I understand that the vb metadata is catched by the search engines and the problem affect only to facebook, is that correct?

                          Originally posted by Paul M View Post
                          The Facebook code does the same everywhere, so I'd guess its picking up a description from somewhere else.

                          You are free to view the source code on the page and see, just like i did.
                          In my case that is incorrect. Facebook get the vb metadata for all sections except for de CMS subsections... that is precisely the problem that I have been saying all this thread.

                          Comment


                          • #15
                            Originally posted by PedroMA View Post
                            In my case that is incorrect. Facebook get the vb metadata for all sections except for de CMS subsections... that is precisely the problem that I have been saying all this thread.
                            No its not incorrect, thats how the FB code works, unless of course you have modifications messing with it.
                            Baby, I was born this way

                            Comment

                            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                            Working...
                            X