Announcement

Collapse
No announcement yet.

Characters posting problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Characters posting problem

    Hi there,

    I have some very strange character problem since I moved to new server.
    And it's only when I posting trough Quick Reply!

    When I post this:
    GoogleZapytanie, Wyszukiwanie gosowe;
    Filmy PlayMoje filmy, Moje programy TV, Moja lista ycze;
    DyskSzukaj;
    GmailUtwrz wiadomo;
    Ksiki PlaySklep, Moja biblioteka;
    TwitterNowy tweet, Wiadomoci;
    I'm getting this:

    Google — Zapytanie, Wyszukiwanie gosowe;
    Filmy Play — Moje filmy, Moje programy TV, Moja lista ycze;
    Dysk — Szukaj;
    Gmail — Utwrz wiadomo;
    Ksiki Play — Sklep, Moja biblioteka;
    Twitter — Nowy tweet, Wiadomoci;
    As you can see the dash sign doesnt appear correct.

    Both servers run same PHP, MySQL, Apache!
    Only OS version is different.

    On server that all is OK is CentOS 6 and on problem server CenOS 7.

    Any ideas?
    Latest Tech News in the World
    Best iPhone and Android games!

  • #2
    You need to make sure the new database collation and character sets match the old server exactly.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
    vBulletin 5 Documentation - Updated every Friday. Report issues here.
    vBulletin 5 API - Full / Mobile
    I am not currently available for vB Messenger Chats.

    Comment


    • #3
      What is your server php version ?

      Comment


      • #4
        Hi guys,

        Everything except OS matching!

        Apache v2.4.23
        PHP 5.6.25
        MySQL Version 5.7.14

        And why the problem affect Quick Reply only?
        Latest Tech News in the World
        Best iPhone and Android games!

        Comment


        • #5
          Realy I don't know why but I'm waiting feedback here http://tracker.vbulletin.com/browse/VBIV-16238 because same problem on my forum If you copy and paste any content from anywhere this problem occured also.

          What is your old server php version ? Because my problem beginin after update php
          Last edited by Bulent Tekcan; Mon 3rd Oct '16, 9:18am.

          Comment


          • #6
            Hi mate,

            yes absolutely the same Copy&Paste problem!
            All is the same on both servers.
            Try using Advanced post mode and you'll see that there is no problem there!
            So I assume the problem is with ckeditor only!
            Latest Tech News in the World
            Best iPhone and Android games!

            Comment


            • #7
              Here is the Environment info:

              NEW server:

              Click image for larger version

Name:	news.JPG
Views:	29
Size:	35.0 KB
ID:	4355275

              OLD server
              Click image for larger version

Name:	olds.JPG
Views:	27
Size:	65.2 KB
ID:	4355274
              Attached Files
              Latest Tech News in the World
              Best iPhone and Android games!

              Comment


              • #8
                Php version old and new ?

                Comment


                • masterross
                  masterross commented
                  Editing a comment
                  As I said above all is the same on both servers:
                  Apache v2.4.23
                  PHP 5.6.25
                  MySQL Version 5.7.14

              • #9
                "BANKADAN KRED EKTM"

                Tarlann hasat edilmek suretiyle msrlarn alndn grnce bandan kaynar sular dkldn ifade eden Demirel, "Komularm aradmda bierdverin hasat yaparak kamyona yklediini rendim. Bankadan kredi ektim, emek verdim.

                Comment


                • #10
                  Look at the message 9, it is mine and copy-paste here. But missing special characters. Original source is attached, this is from Turkish page. I'm sure similar problem exist vB5 here
                  Attached Files

                  Comment


                  • #11
                    Any news about this problem ? I didn't find any solution yet

                    Comment


                    • #12
                      We're working on a fix for 5.2.5. Go to this link - http://tracker.vbulletin.com/browse/VBV-16555 and click watch. If a Patch is made available it will be attached to that link.
                      Translations provided by Google.

                      Wayne Luke
                      The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                      vBulletin 5 Documentation - Updated every Friday. Report issues here.
                      vBulletin 5 API - Full / Mobile
                      I am not currently available for vB Messenger Chats.

                      Comment


                      • #13
                        Originally posted by Wayne Luke View Post
                        We're working on a fix for 5.2.5. Go to this link - http://tracker.vbulletin.com/browse/VBV-16555 and click watch. If a Patch is made available it will be attached to that link.
                        Wayne please focus on PHP , because when I return PHP 4.3 this problem gone on my 4.1.11 version forum. I tested php 5.4 and 5.6 result is bad. I

                        Comment


                        • #14
                          You can't run PHP 5.5 and PHP 5.6 when using vBulletin 4.1.11. We do not support those versions of PHP until vBulletin 4.2.2 and 4.2.3 (respectively). I recommend upgrading. PHP 4.3 shouldn't be used at all on today's servers. I can't even say that vBulletin 4.1.11 is secure.
                          Translations provided by Google.

                          Wayne Luke
                          The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                          vBulletin 5 Documentation - Updated every Friday. Report issues here.
                          vBulletin 5 API - Full / Mobile
                          I am not currently available for vB Messenger Chats.

                          Comment


                          • #15
                            Originally posted by Wayne Luke View Post
                            You can't run PHP 5.5 and PHP 5.6 when using vBulletin 4.1.11. We do not support those versions of PHP until vBulletin 4.2.2 and 4.2.3 (respectively). I recommend upgrading. PHP 4.3 shouldn't be used at all on today's servers. I can't even say that vBulletin 4.1.11 is secure.
                            I know Wayne, only I explain this problem. 4.1.11 work on 5.4.45 not 5.5.x version.

                            Comment

                            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                            Working...
                            X