Announcement

Collapse
No announcement yet.

vBulletin 4.2.5

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #91
    4.2.5 Beta 3 has been released today.
    Baby, I was born this way

    Comment


    • Riasat
      Riasat commented
      Editing a comment
      Testing it now.

      Faced a little issue while upgrading. It gets stuck on Blog step with required_field_x_missing_or_invalid.
      If blog (maybe cms too) product is enabled, this issue goes away.

  • #92
    Is "Admin CP -> Settings -> Options -> General Settings -> Thread/Forum Read Marking Type"

    option removed in 4.2.5 ?

    Comment


    • #93
      Yes.
      Baby, I was born this way

      Comment


      • #94
        Originally posted by Paul M View Post
        Yes.
        Is it set to Database (automatic forum marking)?
        Last edited by Joe D.; Sun 5th Mar '17, 6:16am.

        Comment


        • #95
          In short, yes.
          Baby, I was born this way

          Comment


          • #96
            I just upgraded to Beta 3 after a failed upgrade to 4.2.4...I had forgotten my 4.2.3 had been modified to shoehorn some of the php7 requirements in, so obviously when I did the 4.2.4 patch it overwrote those changes and things didn't work. Last night my upgrade to 4.2.5b3 didn't finish or go fully, so I had database errors overnight. I reapplied the upgrade this morning and everything seems to be ok, except some of the posts that were made during the onslaught of database errors overnight...If there's any testing I should do or cleanup I should do, let me know...but otherwise I'll report any bugs I find.

            Comment


            • #97
              Ooops...looks like I'm not out of the water yet. I am seeing some database errors still:

              Database error in vBulletin 4.2.5 Beta 3:

              Invalid SQL:

              SELECT COUNT(postid) AS posts, IF(post.userid = 0, post.username, user.userid) as memberid, user.userid,
              post.username AS postuser, user.username
              FROM vb_post AS post
              LEFT JOIN vb_user AS user USING(userid)
              WHERE threadid = 4099
              AND visible = 1
              GROUP BY memberid
              ORDER BY posts DESC;

              MySQL Error : Expression #3 of SELECT list is not in GROUP BY clause and contains nonaggregated column 'carto_prime.user.userid' which is not functionally dependent on columns in GROUP BY clause; this is incompatible with sql_mode=only_full_group_by
              Error Number : 1055
              Request Date : Friday, March 10th 2017 @ 09:27:41 AM
              Error Date : Friday, March 10th 2017 @ 09:27:41 AM
              Script : http://www.cartographersguild.com/mi...oposted&t=4099
              Referrer :
              IP Address : 68.180.228.175
              Username : Unregistered
              Classname : vB_Database_MySQLi
              MySQL Version :
              Server : 64.71.79.207
              User Agent :


              Stack Trace:

              #0 vB_Database->halt() called in [path]/includes/class_core.php on line 1403
              #1 vB_Database_MySQLi->execute_query() called in [path]/includes/class_core.php on line 475
              #2 vB_Database->query_read_slave() called in [path]/misc.php on line 229

              Comment


              • #98
                I'm seeing a lot of errors based on not having default values:
                Database error in vBulletin 4.2.5 Beta 3:

                Invalid SQL:

                ### INSERT QUERY GENERATED BY fetch_query_sql() ###
                INSERT INTO vb_moderatorlog
                (`userid`, `dateline`, `type`, `forumid`, `threadid`, `postid`, `pollid`, `attachmentid`, `ipaddress`, `action`)
                VALUES
                ('746', '1489157985', '21', '49', '37231', '0', '0', '0', '173.19.193.46', '');

                MySQL Error : Field 'id1' doesn't have a default value
                Error Number : 1364
                Request Date : Friday, March 10th 2017 @ 09:59:45 AM
                Error Date : Friday, March 10th 2017 @ 09:59:45 AM
                Script : http://cartographersguild.com/inline...37231&p=333005
                Referrer : https://cartographersguild.com/showt...37231&p=333005
                IP Address : 173.19.193.46
                Username : waldronate
                Classname : vB_Database_MySQLi
                MySQL Version :
                Server : 64.71.79.207
                User Agent :


                Stack Trace:

                #0 vB_Database->halt() called in [path]/includes/class_core.php on line 1403
                #1 vB_Database_MySQLi->execute_query() called in [path]/includes/class_core.php on line 446
                #2 vB_Database->query_write() called in [path]/includes/functions_log_error.php on line 337
                #3 log_moderator_action() called in [path]/includes/functions_databuild.php on line 869
                #4 approve_thread() called in [path]/includes/functions_databuild.php on line 796
                #5 approve_post() called in [path]/inlinemod.php on line 3802

                Comment


                • #99
                  Looks like a MySQL mode issue.

                  What do you get when you run this ?

                  Code:
                  SELECT @@sql_mode
                  Baby, I was born this way

                  Comment


                  • Only_full_group_by,strict_trans_tables,no_zero_in_date,no_zero_date,error_for_division_by_ zero,no_auto_create_user,no_engine_substitution

                    Comment


                    • Oh wow, MySQL Strict mode, thats your problem.

                      If you are using the latest config file, uncomment this line [as below];
                      PHP Code:

                      $config
                      ['Database']['set_sql_mode'] = ''


                      Otherwise copy these lines to your config file
                      PHP Code:

                      /* #### FORCE SQL MODE ####
                      // Allows the forcing of a MySQL mode.
                      You only need to modify this value if vBulletin recommends it. */
                      $config['Database']['set_sql_mode'] = ''
                      Baby, I was born this way

                      Comment


                      • Thanks! That definitely worked. No errors since I applied it. Thanks. Do I need to do anything with the jira entry?

                        Comment


                        • Nope, I'm already dealing with that, so its fine.
                          Baby, I was born this way

                          Comment


                          • 4.2.5 Beta 4 was released earlier today.
                            Baby, I was born this way

                            Comment


                            • Just saw this, will try and upgrade this evening. Anything specific we should be testing?

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X